Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » J2SE-1.6 Execution Environment Constraint
J2SE-1.6 Execution Environment Constraint [message #248916] Thu, 18 October 2007 17:09 Go to next message
Miles Parker is currently offline Miles ParkerFriend
Messages: 1340
Registered: July 2009
Senior Member
When validating plugin set for an Eclipse Runtime I get a
Missing-Constraint Bundle-RequiredExecutionEnvironment: JavaSE-1.6
problem. Is this constraint really neccessary? Hoping not as OS X
doesn't have 1.6..

What kind of issues might this cause on runtime side?
Re: J2SE-1.6 Execution Environment Constraint [message #248920 is a reply to message #248916] Thu, 18 October 2007 17:23 Go to previous messageGo to next message
Olivier Thomann is currently offline Olivier ThomannFriend
Messages: 518
Registered: July 2009
Senior Member
Miles Parker a écrit :
> When validating plugin set for an Eclipse Runtime I get a
> Missing-Constraint Bundle-RequiredExecutionEnvironment: JavaSE-1.6
> problem. Is this constraint really neccessary? Hoping not as OS X
> doesn't have 1.6..
>
> What kind of issues might this cause on runtime side?
There are two jdt plugins that requires 1.6 in order to work.
compiler.tool and compiler.apt. They add the jsr199 (compiler API) and
the jsr269 (APT6 support) to the batch compiler.
If you don't have a 1.6 VM, then you don't get this support. You might
not care about it since these are 1.6 features.
--
Olivier
Re: J2SE-1.6 Execution Environment Constraint [message #248925 is a reply to message #248916] Thu, 18 October 2007 17:25 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eclipse6.rizzoweb.com

Miles Parker wrote:
> When validating plugin set for an Eclipse Runtime I get a
> Missing-Constraint Bundle-RequiredExecutionEnvironment: JavaSE-1.6
> problem. Is this constraint really neccessary? Hoping not as OS X
> doesn't have 1.6..

Which bundles are reporting that? If it is the JDT "apt" and
"comiler.tool" stuff then it is OK to remove those from your runtime
config - they are only there to support 1.6-specific features.
See http://dev.eclipse.org/newslists/news.eclipse.tools.jdt/msg2 1421.html

>
> What kind of issues might this cause on runtime side?

The 1.6-specific features that those bundles provide just won't be
available.

Hope this helps,
Eric
Re: J2SE-1.6 Execution Environment Constraint [message #248930 is a reply to message #248925] Thu, 18 October 2007 17:32 Go to previous message
Miles Parker is currently offline Miles ParkerFriend
Messages: 1340
Registered: July 2009
Senior Member
On 2007-10-18 10:25:30 -0700, Eric Rizzo <eclipse6@rizzoweb.com> said:

> Miles Parker wrote:
>> When validating plugin set for an Eclipse Runtime I get a
>> Missing-Constraint Bundle-RequiredExecutionEnvironment: JavaSE-1.6
>> problem. Is this constraint really neccessary? Hoping not as OS X
>> doesn't have 1.6..
>
> Which bundles are reporting that? If it is the JDT "apt" and
> "comiler.tool" stuff then it is OK to remove those from your runtime
> config - they are only there to support 1.6-specific features.
> See http://dev.eclipse.org/newslists/news.eclipse.tools.jdt/msg2 1421.html
>
>>
>> What kind of issues might this cause on runtime side?
>
> The 1.6-specific features that those bundles provide just won't be available.
>
> Hope this helps,
> Eric

It does, thx Eric! They were added when I selected required plugins,
assuming from some other part of jdt, and while apt seemed optional,
compiler.tool sounded important. :)
Previous Topic:Equivalent in IType for Class.isAssignableFrom()
Next Topic:Spell check: french dictionary?
Goto Forum:
  


Current Time: Mon Dec 22 14:17:43 GMT 2014

Powered by FUDForum. Page generated in 0.01565 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software