Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Birt 2.1.2 and Derby 10.2.2
Birt 2.1.2 and Derby 10.2.2 [message #223200] Thu, 08 March 2007 14:33 Go to next message
Bojan Milenkoski is currently offline Bojan Milenkoski
Messages: 30
Registered: July 2009
Member
Hi all,

I have a little problem with birt 2.1.2 and debry 10.2.2 database.
When I try to make a connection to the database I get the following error:

Cannot open the connection for the driver:
org.eclipse.birt.report.data.oda.jdbc
Failed to get connection.
SQL error #1: Failed to start database 'c:/eclipse/.../db', see the next exception for details.
SQL error #2: Database at c:/eclipse/.../db has an incompatible format with the current version of the software. The database was created by
or upgraded by version 10.2.

I cannot even really understand the error. Do Birt developers make different versions for every different version of every different driver?

So what should I do? I should update birt version or downgrade derby version? Or there is some other way of making it work?

Regards,
Bojan
Re: Birt 2.1.2 and Derby 10.2.2 [message #223244 is a reply to message #223200] Thu, 08 March 2007 17:03 Go to previous messageGo to next message
Deepa Remesh is currently offline Deepa Remesh
Messages: 23
Registered: July 2009
Junior Member
Hi,

The error occurs when trying to boot a Derby database created with a
specific Derby version by using a different version of Derby driver.
From your mail, I think you are trying to boot a Derby 10.2.2 database
with a previous version of Derby driver (10.1.2).

BIRT (2.1.x and 2.2Mx) currently package Derby 10.1.2. I do not think
BIRT creates different versions for every different version of a
database driver.

So if you need to use Derby 10.2.2, you will have to get and replace the
derby jar in BIRT's Derby plug-in. I have tried this and it worked
without problems for me. However, I think this configuration is not
tested by BIRT.

Hope this helps.

Regards,
Deepa


Bojan Milenkoski wrote:
> Hi all,
>
> I have a little problem with birt 2.1.2 and debry 10.2.2 database.
> When I try to make a connection to the database I get the following error:
>
> Cannot open the connection for the driver:
> org.eclipse.birt.report.data.oda.jdbc
> Failed to get connection.
> SQL error #1: Failed to start database 'c:/eclipse/.../db', see the next exception for details.
> SQL error #2: Database at c:/eclipse/.../db has an incompatible format with the current version of the software. The database was created by
> or upgraded by version 10.2.
>
> I cannot even really understand the error. Do Birt developers make different versions for every different version of every different driver?
>
> So what should I do? I should update birt version or downgrade derby version? Or there is some other way of making it work?
>
> Regards,
> Bojan
Re: Birt 2.1.2 and Derby 10.2.2 [message #223593 is a reply to message #223244] Fri, 09 March 2007 10:34 Go to previous message
Bojan Milenkoski is currently offline Bojan Milenkoski
Messages: 30
Registered: July 2009
Member
Thanks,

That was it. I don't see how is this happening. What does "Manage Drivers..." in data source creation dialog do? There I chose my 10.2.2
driver. It did copy the same driver in " C:\eclipse\plugins\org.eclipse.birt.report.data.oda.jdbc_2.1 .1.v20070205-1728\drivers " and somehow
didn't use it.
The old driver was only in an older version of some plugin (I forgot which one) that I didn't delete because I thought that eclipse should
only use the newer version, but that wasn't the case as it turns out.

Anyway thanks again for the trouble.
Previous Topic:New Eclipse Instance gets terminated
Next Topic:"Cancel report..." --> overwrite rptdocument?
Goto Forum:
  


Current Time: Tue Sep 23 12:27:59 GMT 2014

Powered by FUDForum. Page generated in 0.01642 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software