Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Versioning questions..
Versioning questions.. [message #205498] Wed, 03 March 2004 15:07 Go to next message
Kevin Duffey is currently offline Kevin Duffey
Messages: 304
Registered: July 2009
Senior Member
How does Eclipse resolve the issue where an extension of the same name/uid
from two different versions of the same plugin, is loaded? Does Eclipse even
care about version information in relation to extension points and
extensions? Or is it only for plugin dependencies that versioning matters?

Does it adopt the versioning of OSGi now, where by the first one found (or
is it the latest version..??) is used and all others are ignored? If so, how
does it handle failures of resolving plugins that do not work against a
version that the OSGi versioning code deems the one to use? For example, a
plugin with ant 1.0 and a plugin with ant 1.2, which ant gets used? It was a
while back I read the OSGi spec in regards to this, but I thought it takes
the latest version of the library? Then again, how does it know what version
a library is? IS it based on the plugin's version information?

Thanks.
Re: Versioning questions.. [message #206724 is a reply to message #205498] Fri, 05 March 2004 15:01 Go to previous messageGo to next message
Kevin Duffey is currently offline Kevin Duffey
Messages: 304
Registered: July 2009
Senior Member
Nobody knows how versioning works between extension points and extension
plugins? Is it only for dependencies, or is it enforced at the EP and E
levels as well?

"spiderman" <supreme_java_guru_1@yahoo.com> wrote in message
news:c25dok$as4$1@eclipse.org...
> How does Eclipse resolve the issue where an extension of the same name/uid
> from two different versions of the same plugin, is loaded? Does Eclipse
even
> care about version information in relation to extension points and
> extensions? Or is it only for plugin dependencies that versioning matters?
>
> Does it adopt the versioning of OSGi now, where by the first one found (or
> is it the latest version..??) is used and all others are ignored? If so,
how
> does it handle failures of resolving plugins that do not work against a
> version that the OSGi versioning code deems the one to use? For example, a
> plugin with ant 1.0 and a plugin with ant 1.2, which ant gets used? It was
a
> while back I read the OSGi spec in regards to this, but I thought it takes
> the latest version of the library? Then again, how does it know what
version
> a library is? IS it based on the plugin's version information?
>
> Thanks.
>
>
Re: Versioning questions.. [message #206972 is a reply to message #206724] Sat, 06 March 2004 13:02 Go to previous messageGo to next message
Eclipse User
Originally posted by: p.essi.fr

For every plugin that declares extension, the runtime select one and
only one version of that plugin. Therefore, there is not problem with
extension / extension pointS.

PaScaL

spiderman wrote:
> Nobody knows how versioning works between extension points and extension
> plugins? Is it only for dependencies, or is it enforced at the EP and E
> levels as well?
>
> "spiderman" <supreme_java_guru_1@yahoo.com> wrote in message
> news:c25dok$as4$1@eclipse.org...
>
>>How does Eclipse resolve the issue where an extension of the same name/uid
>>from two different versions of the same plugin, is loaded? Does Eclipse
>
> even
>
>>care about version information in relation to extension points and
>>extensions? Or is it only for plugin dependencies that versioning matters?
>>
>>Does it adopt the versioning of OSGi now, where by the first one found (or
>>is it the latest version..??) is used and all others are ignored? If so,
>
> how
>
>>does it handle failures of resolving plugins that do not work against a
>>version that the OSGi versioning code deems the one to use? For example, a
>>plugin with ant 1.0 and a plugin with ant 1.2, which ant gets used? It was
>
> a
>
>>while back I read the OSGi spec in regards to this, but I thought it takes
>>the latest version of the library? Then again, how does it know what
>
> version
>
>>a library is? IS it based on the plugin's version information?
>>
>>Thanks.
>>
>>
>
>
>
Re: Versioning questions.. [message #207025 is a reply to message #206972] Sat, 06 March 2004 15:50 Go to previous message
Kevin Duffey is currently offline Kevin Duffey
Messages: 304
Registered: July 2009
Senior Member
Is that based on the OSGi core now? I recall the spec says that. But did
Eclipse do it that way prior as well, where only one plugin was selected? If
so, how does the runtime determine which one to choose? How does it avoid
compatibility issues or for that matter when an end user updates one plugin
that no longer works with other plugins the older version used to work with,
does the end user get shafted, or does the runtime revert to the old one, or
what? I thought it could load multiple versions of the same plugin and work
with them all?

I am curious why the built in serialVersionUID stuff to determine compatible
class versioning is not used? Is it too cumbersome for plugin developers to
learn how to use that mechanism?

"Pascal" <p@essi.fr> wrote in message news:c2d3g2$lq1$1@eclipse.org...
> For every plugin that declares extension, the runtime select one and
> only one version of that plugin. Therefore, there is not problem with
> extension / extension pointS.
>
> PaScaL
>
> spiderman wrote:
> > Nobody knows how versioning works between extension points and extension
> > plugins? Is it only for dependencies, or is it enforced at the EP and E
> > levels as well?
> >
> > "spiderman" <supreme_java_guru_1@yahoo.com> wrote in message
> > news:c25dok$as4$1@eclipse.org...
> >
> >>How does Eclipse resolve the issue where an extension of the same
name/uid
> >>from two different versions of the same plugin, is loaded? Does Eclipse
> >
> > even
> >
> >>care about version information in relation to extension points and
> >>extensions? Or is it only for plugin dependencies that versioning
matters?
> >>
> >>Does it adopt the versioning of OSGi now, where by the first one found
(or
> >>is it the latest version..??) is used and all others are ignored? If so,
> >
> > how
> >
> >>does it handle failures of resolving plugins that do not work against a
> >>version that the OSGi versioning code deems the one to use? For example,
a
> >>plugin with ant 1.0 and a plugin with ant 1.2, which ant gets used? It
was
> >
> > a
> >
> >>while back I read the OSGi spec in regards to this, but I thought it
takes
> >>the latest version of the library? Then again, how does it know what
> >
> > version
> >
> >>a library is? IS it based on the plugin's version information?
> >>
> >>Thanks.
> >>
> >>
> >
> >
> >
Previous Topic:replace, emacs-style
Next Topic:Need help understanding an error that I'm getting.
Goto Forum:
  


Current Time: Tue Jul 29 19:07:44 EDT 2014

Powered by FUDForum. Page generated in 0.03136 seconds