Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster dev » [buckminster-dev] Some SVN resolution issues
[buckminster-dev] Some SVN resolution issues [message #19674] Wed, 11 June 2008 13:11 Go to next message
Eclipse User
Originally posted by: ohurley.iona.com

I've been using the subclipse headless feature to check out
STP artifacts in our headless build. When I attempted a headless
build today, Buckminster was unable to resolve the location of
my CQUERY using the searchpath:

<searchPath name="stp.build.root">
<provider readerType="svn"
componentTypes="buckminster"
mutable="true" source="false">
<uri
format="http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/
{0}">
<bc:propertyRef key="buckminster.component" />
</uri>
</provider>
</searchPath>

Resolver output is:

[java] org.eclipse.stp.build.root: Using search path stp.build.root
[java] org.eclipse.stp.build.root: Trying provider
svn( http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/{ 0})
[java] org.eclipse.stp.build.root: Rejecting provider
svn(http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/
{0}):
No component match was found

If you go to the svn repo at :
http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/o rg.eclipse.stp.build.root/

the artifact is there as buckminster.cspec

This is one of those 'it worked last time I tried it' things. The
changed piece is that I download the latest of the PDE, Subclipse,
Core from

http://download.eclipse.org/tools/buckminster/updates-3.4/he adless-site.xml

perhaps something has changed somewhere in the resolution procedure?

I'm using the the product version 1.1.0.r09308. I will try a UI-based
build
next.

cheers
--oh

----------------------------
IONA Technologies PLC (registered in Ireland)
Registered Number: 171387
Registered Address: The IONA Building, Shelbourne Road, Dublin 4, Ireland
Re: [buckminster-dev] Some SVN resolution issues [message #19719 is a reply to message #19674] Wed, 11 June 2008 19:08 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3215
Registered: July 2009
Senior Member
Hi Oisin,
Are you using Subclipse or Subversive as the SVN provider?

- thomas

Oisin Hurley wrote:
> I've been using the subclipse headless feature to check out
> STP artifacts in our headless build. When I attempted a headless
> build today, Buckminster was unable to resolve the location of
> my CQUERY using the searchpath:
>
> <searchPath name="stp.build.root">
> <provider readerType="svn"
> componentTypes="buckminster"
> mutable="true" source="false">
> <uri
>
> format=" http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/{ 0}">
> <bc:propertyRef key="buckminster.component" />
> </uri>
> </provider>
> </searchPath>
>
> Resolver output is:
>
> [java] org.eclipse.stp.build.root: Using search path stp.build.root
> [java] org.eclipse.stp.build.root: Trying provider
> svn( http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/{ 0})
> [java] org.eclipse.stp.build.root: Rejecting provider
> svn( http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/{ 0}):
> No component match was found
>
> If you go to the svn repo at :
> http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/o rg.eclipse.stp.build.root/
>
>
> the artifact is there as buckminster.cspec
>
> This is one of those 'it worked last time I tried it' things. The
> changed piece is that I download the latest of the PDE, Subclipse,
> Core from
>
> http://download.eclipse.org/tools/buckminster/updates-3.4/he adless-site.xml
>
> perhaps something has changed somewhere in the resolution procedure?
>
> I'm using the the product version 1.1.0.r09308. I will try a UI-based build
> next.
>
> cheers
> --oh
>
> ----------------------------
> IONA Technologies PLC (registered in Ireland)
> Registered Number: 171387
> Registered Address: The IONA Building, Shelbourne Road, Dublin 4, Ireland
Re: [buckminster-dev] Some SVN resolution issues [message #19768 is a reply to message #19674] Wed, 11 June 2008 19:08 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3215
Registered: July 2009
Senior Member
Hi Oisin,
Are you using Subclipse or Subversive as the SVN provider?

- thomas

Oisin Hurley wrote:
> I've been using the subclipse headless feature to check out
> STP artifacts in our headless build. When I attempted a headless
> build today, Buckminster was unable to resolve the location of
> my CQUERY using the searchpath:
>
> <searchPath name="stp.build.root">
> <provider readerType="svn"
> componentTypes="buckminster"
> mutable="true" source="false">
> <uri
>
> format=" http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/{ 0}">
> <bc:propertyRef key="buckminster.component" />
> </uri>
> </provider>
> </searchPath>
>
> Resolver output is:
>
> [java] org.eclipse.stp.build.root: Using search path stp.build.root
> [java] org.eclipse.stp.build.root: Trying provider
> svn( http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/{ 0})
> [java] org.eclipse.stp.build.root: Rejecting provider
> svn( http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/{ 0}):
> No component match was found
>
> If you go to the svn repo at :
> http://dev.eclipse.org/svnroot/stp/build/trunk/buckminster/o rg.eclipse.stp.build.root/
>
>
> the artifact is there as buckminster.cspec
>
> This is one of those 'it worked last time I tried it' things. The
> changed piece is that I download the latest of the PDE, Subclipse,
> Core from
>
> http://download.eclipse.org/tools/buckminster/updates-3.4/he adless-site.xml
>
> perhaps something has changed somewhere in the resolution procedure?
>
> I'm using the the product version 1.1.0.r09308. I will try a UI-based build
> next.
>
> cheers
> --oh
>
> ----------------------------
> IONA Technologies PLC (registered in Ireland)
> Registered Number: 171387
> Registered Address: The IONA Building, Shelbourne Road, Dublin 4, Ireland
Re: [buckminster-dev] Some SVN resolution issues [message #19804 is a reply to message #19719] Wed, 11 June 2008 19:58 Go to previous message
Eclipse User
Originally posted by: ohurley.iona.com

> Are you using Subclipse or Subversive as the SVN provider?

I'm using Subclipse, but I did switch over briefly to Subversive.
The latter failed pretty much immediately with complaints about
the JavaHL (apologies, I forgot to keep the log) provider - at
which point I rushed off to do an IDE build, which worked fine.

cheers
--oh

----------------------------
IONA Technologies PLC (registered in Ireland)
Registered Number: 171387
Registered Address: The IONA Building, Shelbourne Road, Dublin 4, Ireland
Previous Topic:Headless Buckminster for 3.4
Next Topic:Subversive and Subclipse headless
Goto Forum:
  


Current Time: Sat Aug 02 00:53:26 EDT 2014

Powered by FUDForum. Page generated in 0.02289 seconds