Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » schema resolver
schema resolver [message #194727] Wed, 20 June 2007 09:40 Go to next message
kashif is currently offline kashifFriend
Messages: 16
Registered: July 2009
Junior Member
Hi All,

We are using WTP 1.0.3 XML editor for our product. we used URI resolver to
resolve URI for the schema we have. But I found that WTP 1.0.3 does have bug
in ValidatorHelper class which does not call external resolvers to resolve
the URI. This bug has been fixed in the later WTP 1.5.x.

Do we have any alternative for this to go on?? The main issue is we don't
want our user to use absolute schema path.

One solution is to have patch for WTP 1.0.3 which does have fix for the bug.
But I am not sure if we can modify the WTP component for our own use and
deliver it?? Though we don't have any problem to open the patched component.

The other one is to have our own plugin which extends the WTP 1.0.3
validation mechansim and provide a fix??

I would appriciate if anyone would give his/her valuable comments.

Thanks,
Kashif
Re: schema resolver [message #194797 is a reply to message #194727] Thu, 21 June 2007 17:26 Go to previous messageGo to next message
Craig Salter is currently offline Craig SalterFriend
Messages: 169
Registered: July 2009
Senior Member
I don't believe WTP is producing service release on the 1.0.x code base.
Your best bet will likely be to

(a) move up to a later version of WTP that contains the fix

-- or ---

(b) backport the fixes to apply your own private patches to WTP 1.0.x


hope that helps
Re: schema resolver [message #195168 is a reply to message #194797] Fri, 29 June 2007 12:35 Go to previous message
kashif is currently offline kashifFriend
Messages: 16
Registered: July 2009
Junior Member
Thanks Craig,
-Kashif
"craig" <csalter@ca.ibm.com> wrote in message
news:8056cf55f14e64f96d760a533c1a778f$1@www.eclipse.org...
>I don't believe WTP is producing service release on the 1.0.x code base.
>Your best bet will likely be to
> (a) move up to a later version of WTP that contains the fix
> -- or ---
>
> (b) backport the fixes to apply your own private patches to WTP 1.0.x
>
>
> hope that helps
>
Previous Topic:Using exported jars from j2ee module dependency
Next Topic:about that Web Browser icon on Eclipse ToolBar
Goto Forum:
  


Current Time: Wed Nov 26 18:54:24 GMT 2014

Powered by FUDForum. Page generated in 0.01869 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software