Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Debug problem.
Debug problem. [message #184710] Thu, 15 February 2007 12:20 Go to next message
Sergey Gomanyuk is currently offline Sergey Gomanyuk
Messages: 46
Registered: July 2009
Member
I'm very new with CDT and examined following problem:

1. I created managed C++ project
2. Then creates main.cpp file with printing "Hello, world!" functionality
3. Then run it with success
4.When I tried to debug project the execution stoped in main, but source
was not linked. I tried to edit lookup path but without any success.
the stack: 1 main() at
\cygdrive\m\Settings\Eclipse\3.2.1\workspace\Managed C++ Test\main.cpp:7
0x00401176

Please tell me how to link sources? My platform is Windows XP and last
cygwin.
Re: Debug problem. [message #184719 is a reply to message #184710] Thu, 15 February 2007 12:45 Go to previous messageGo to next message
Eclipse User
Originally posted by: dmsubs.NOSPAM.consertum.com

I think your problem is having a directory with spaces in the name: "Managed C++
Test" (AFAIK this is a limitation with Cygwin). Try again, with a non-spacey
directory name.

--
Derek


Sergey Gomanyuk wrote:
> I'm very new with CDT and examined following problem:
>
> 1. I created managed C++ project
> 2. Then creates main.cpp file with printing "Hello, world!" functionality
> 3. Then run it with success
> 4.When I tried to debug project the execution stoped in main, but source
> was not linked. I tried to edit lookup path but without any success.
> the stack: 1 main() at
> \cygdrive\m\Settings\Eclipse\3.2.1\workspace\Managed C++ Test\main.cpp:7
> 0x00401176
>
> Please tell me how to link sources? My platform is Windows XP and last
> cygwin.
>
>
Re: Debug problem. [message #184750 is a reply to message #184710] Thu, 15 February 2007 13:06 Go to previous messageGo to next message
Norbert Plött is currently offline Norbert Plött
Messages: 233
Registered: July 2009
Senior Member
Sergey,

in short words, you must create a pathentry mapping from /cygdrive/m to m:\

In the eclipse IDE, go to menu Window -> Preferences -> C/C++ -> Debug ->
Common Source Lookup Path -> Add.
From the list of lookup containers, choose Path Mapping and OK. You get a
New Mapping in the list.
Select the mapping and then Edit. In the Modify the path mappings dialog
select Add and then enter

/cygdrive/m as the compilation path and
m:\ as the local file system path.

This setting will apply to any debug sessions launched from this workspace.
You can also modify the settings in each individual launch configuration.

HTH


Norbert
Re: Debug problem. [message #184934 is a reply to message #184750] Fri, 16 February 2007 13:03 Go to previous message
Sergey Gomanyuk is currently offline Sergey Gomanyuk
Messages: 46
Registered: July 2009
Member
Thank you very much!
That works!

"Norbert Ploett" <norbert.ploett@siemens.com> wrote in message
news:1171544774.165549@baruth.khe.siemens.de...
> Sergey,
>
> in short words, you must create a pathentry mapping from /cygdrive/m to
> m:\
>
> In the eclipse IDE, go to menu Window -> Preferences -> C/C++ -> Debug ->
> Common Source Lookup Path -> Add.
> From the list of lookup containers, choose Path Mapping and OK. You get a
> New Mapping in the list.
> Select the mapping and then Edit. In the Modify the path mappings dialog
> select Add and then enter
>
> /cygdrive/m as the compilation path and
> m:\ as the local file system path.
>
> This setting will apply to any debug sessions launched from this
> workspace. You can also modify the settings in each individual launch
> configuration.
>
> HTH
>
>
> Norbert
>
>
Previous Topic:how to get Active Build Configuration?
Next Topic:Navigation...
Goto Forum:
  


Current Time: Tue Oct 21 00:31:34 GMT 2014

Powered by FUDForum. Page generated in 0.03136 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software