Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Is WebService => Test Client supposed to work?
Is WebService => Test Client supposed to work? [message #183429] Wed, 29 November 2006 06:57 Go to next message
Michael Moser is currently offline Michael Moser
Messages: 914
Registered: July 2009
Senior Member
I am trying something rather simple - or so I thought:

I have a WSDL file and I want to create a TestClient so that I can
continue from there (using the classes created for the test client as a
starting point) to build by web service application.

So, I create a project. Put the .wsdl file into its top directory, right
click on the .wsdl file and choose "Web Services => Generate Client".

In the appearing wizard I select Geronimo 1.1 as server, Apache Axis as
runtime and enter names for the client and client EAR project, then:
Next.

This creates a new project and brings up a second wizard page which
says, I should select "generate proxy" if I want to generate proxy for
my service. ??? Ahm - very telling! Well, the checkbox is already
selected and grayed out, so there isn't much choice anyway, so: Next

A second project, <name>EAR is created and another page tells me that
the server is currently not running and offers a button to start it. I
click that button and after a while the server is started and the Next
button gets enabled, so: Next.

The next page has two checkboxes that are already selected "Test the
generated proxy" and "Run test on server" and a list with all methods
defined in the WSDL selected. No Next but a Finish button, so I press
that.

The built-in web browser opens and I get a page telling me:

HTTP Status 404 -
/MyAppClient/sampleDemoConfigServiceProxy/TestClient.jsp
type: Status report
message: /MyAppClient/sampleDemoConfigServiceProxy/TestClient.jsp
description: The requested resource
(/MyAppClient/sampleDemoConfigServiceProxy/TestClient.jsp) is not
available.

??? I doubt that this is working as designed, but what did I wrong or
miss here so that it drove me against this wall?

This is on eclipse 3.2.1, WST R-1.5.2-200610261841 and Apache Geronimo
server adapter 1.2.0.

Michael
Re: Is WebService => Test Client supposed to work? [message #183676 is a reply to message #183429] Mon, 04 December 2006 16:14 Go to previous messageGo to next message
Kathy Chan is currently offline Kathy Chan
Messages: 93
Registered: July 2009
Member
Hi Michael,

Yes. Web services -> Generate Client is supposed to work on Geronimo.
Actually, I just tried WTP 1.5.2 with Geronimo v1.1.1 server and Geronimo
1.1 plugins. I was able to create a Web service client with the WSDL file
and use the sample JSP to test it by following the steps you used (created a
Web project first and let the wizard create an EAR for it and click Start
Server).

Based on the error you are getting, it looks like the EAR had not been added
to the server properly (the wizard should be doing it for you). Could you
please verify if the EAR had been added to the server? Could you also try
to publish a HTML file to the server by using the Run on Server popup menu?

Here are the Geronimo 1.1 plugins I have in my WTP 1.5.2 driver:

org.apache.geronimo.common.deployment.model.edit_1.1.0.jar
org.apache.geronimo.common.deployment.model_1.1.0.jar
org.apache.geronimo.deployment.model.edit_1.1.0.jar
org.apache.geronimo.deployment.model_1.1.0.jar
org.apache.geronimo.runtime.common_1.1.0
org.apache.geronimo.runtime.v11_1.1.0
org.apache.geronimo.runtime.v1_1.1.0
org.apache.geronimo.st.core_1.1.0.jar
org.apache.geronimo.st.ui_1.1.0.jar
org.apache.geronimo.st.v1.core_1.1.0.jar
org.apache.geronimo.st.v1.ui_1.1.0.jar
org.apache.geronimo.st.v11.core_1.1.0.jar
org.apache.geronimo.st.v11.ui_1.1.0.jar
org.apache.geronimo.v11.deployment.model.edit_1.1.0.jar
org.apache.geronimo.v11.deployment.model_1.1.0.jar

I got these Geronimo plugins by using the "Don't see your server listed?
Click here" link in the Server -> Installed runtime preference when adding a
runtime. I'm not able to get the Geronimo 1.2 server adapter plugin as you
mentioned.

Regards,
Kathy Chan

"Michael Moser" <mmo@zurich.ibm.com> wrote in message
news:ekjsiu$kbv$1@utils.eclipse.org...
>I am trying something rather simple - or so I thought:
>
> I have a WSDL file and I want to create a TestClient so that I can
> continue from there (using the classes created for the test client as a
> starting point) to build by web service application.
>
> So, I create a project. Put the .wsdl file into its top directory, right
> click on the .wsdl file and choose "Web Services => Generate Client".
>
> In the appearing wizard I select Geronimo 1.1 as server, Apache Axis as
> runtime and enter names for the client and client EAR project, then: Next.
>
> This creates a new project and brings up a second wizard page which says,
> I should select "generate proxy" if I want to generate proxy for my
> service. ??? Ahm - very telling! Well, the checkbox is already selected
> and grayed out, so there isn't much choice anyway, so: Next
>
> A second project, <name>EAR is created and another page tells me that the
> server is currently not running and offers a button to start it. I click
> that button and after a while the server is started and the Next button
> gets enabled, so: Next.
>
> The next page has two checkboxes that are already selected "Test the
> generated proxy" and "Run test on server" and a list with all methods
> defined in the WSDL selected. No Next but a Finish button, so I press
> that.
>
> The built-in web browser opens and I get a page telling me:
>
> HTTP Status 404 - /MyAppClient/sampleDemoConfigServiceProxy/TestClient.jsp
> type: Status report
> message: /MyAppClient/sampleDemoConfigServiceProxy/TestClient.jsp
> description: The requested resource
> (/MyAppClient/sampleDemoConfigServiceProxy/TestClient.jsp) is not
> available.
>
> ??? I doubt that this is working as designed, but what did I wrong or miss
> here so that it drove me against this wall?
>
> This is on eclipse 3.2.1, WST R-1.5.2-200610261841 and Apache Geronimo
> server adapter 1.2.0.
>
> Michael
>
Re: Is WebService => Test Client supposed to work? [message #183702 is a reply to message #183676] Tue, 05 December 2006 09:19 Go to previous message
Michael Moser is currently offline Michael Moser
Messages: 914
Registered: July 2009
Senior Member
Sorry that I didn't report this here earlier, but I got this resolved by
starting over, i.e. removing the old config directory (that's why I
always keep a virgin copy of it around... :-) ), starting all over by
adding the prereq's and WTP 1.5.2 to it again and then downloading the
Geronimo 1.1.1 plugin via the "Dont see..."-link.

Beats me, what I did different, but this time things worked like a
charm.

Cheers,
Michael


"Kathy Chan" <kathy@ca.ibm.com> wrote in message
news:el234b$d0v$1@utils.eclipse.org...
> Hi Michael,
>
> Yes. Web services -> Generate Client is supposed to work on Geronimo.
> Actually, I just tried WTP 1.5.2 with Geronimo v1.1.1 server and
> Geronimo 1.1 plugins. I was able to create a Web service client with
> the WSDL file and use the sample JSP to test it by following the steps
> you used (created a Web project first and let the wizard create an EAR
> for it and click Start Server).
>
> Based on the error you are getting, it looks like the EAR had not been
> added to the server properly (the wizard should be doing it for you).
> Could you please verify if the EAR had been added to the server?
> Could you also try to publish a HTML file to the server by using the
> Run on Server popup menu?
>
> Here are the Geronimo 1.1 plugins I have in my WTP 1.5.2 driver:
>
> org.apache.geronimo.common.deployment.model.edit_1.1.0.jar
> org.apache.geronimo.common.deployment.model_1.1.0.jar
> org.apache.geronimo.deployment.model.edit_1.1.0.jar
> org.apache.geronimo.deployment.model_1.1.0.jar
> org.apache.geronimo.runtime.common_1.1.0
> org.apache.geronimo.runtime.v11_1.1.0
> org.apache.geronimo.runtime.v1_1.1.0
> org.apache.geronimo.st.core_1.1.0.jar
> org.apache.geronimo.st.ui_1.1.0.jar
> org.apache.geronimo.st.v1.core_1.1.0.jar
> org.apache.geronimo.st.v1.ui_1.1.0.jar
> org.apache.geronimo.st.v11.core_1.1.0.jar
> org.apache.geronimo.st.v11.ui_1.1.0.jar
> org.apache.geronimo.v11.deployment.model.edit_1.1.0.jar
> org.apache.geronimo.v11.deployment.model_1.1.0.jar
>
> I got these Geronimo plugins by using the "Don't see your server
> listed? Click here" link in the Server -> Installed runtime preference
> when adding a runtime. I'm not able to get the Geronimo 1.2 server
> adapter plugin as you mentioned.
>
> Regards,
> Kathy Chan
>
> "Michael Moser" <mmo@zurich.ibm.com> wrote in message
> news:ekjsiu$kbv$1@utils.eclipse.org...
>>I am trying something rather simple - or so I thought:
>>
>> I have a WSDL file and I want to create a TestClient so that I can
>> continue from there (using the classes created for the test client as
>> a starting point) to build by web service application.
>>
>> So, I create a project. Put the .wsdl file into its top directory,
>> right click on the .wsdl file and choose "Web Services => Generate
>> Client".
>>
>> In the appearing wizard I select Geronimo 1.1 as server, Apache Axis
>> as runtime and enter names for the client and client EAR project,
>> then: Next.
>>
>> This creates a new project and brings up a second wizard page which
>> says, I should select "generate proxy" if I want to generate proxy
>> for my service. ??? Ahm - very telling! Well, the checkbox is already
>> selected and grayed out, so there isn't much choice anyway, so: Next
>>
>> A second project, <name>EAR is created and another page tells me that
>> the server is currently not running and offers a button to start it.
>> I click that button and after a while the server is started and the
>> Next button gets enabled, so: Next.
>>
>> The next page has two checkboxes that are already selected "Test the
>> generated proxy" and "Run test on server" and a list with all methods
>> defined in the WSDL selected. No Next but a Finish button, so I press
>> that.
>>
>> The built-in web browser opens and I get a page telling me:
>>
>> HTTP Status 404 -
>> /MyAppClient/sampleDemoConfigServiceProxy/TestClient.jsp
>> type: Status report
>> message: /MyAppClient/sampleDemoConfigServiceProxy/TestClient.jsp
>> description: The requested resource
>> (/MyAppClient/sampleDemoConfigServiceProxy/TestClient.jsp) is not
>> available.
>>
>> ??? I doubt that this is working as designed, but what did I wrong or
>> miss here so that it drove me against this wall?
>>
>> This is on eclipse 3.2.1, WST R-1.5.2-200610261841 and Apache
>> Geronimo server adapter 1.2.0.
>>
>> Michael
>>
>
>
Previous Topic:Facet Problem without facet
Next Topic:Basic WebTools problem?
Goto Forum:
  


Current Time: Wed Jul 30 03:10:23 EDT 2014

Powered by FUDForum. Page generated in 0.03057 seconds