Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Problem running JUnit tests
Problem running JUnit tests [message #180302] Wed, 15 November 2006 10:49 Go to next message
Eclipse User
Originally posted by: mboeckling.heiler.com

Hi!

I have a problem running unit-tests in Eclipse (3.2).
The tests are relatively simple, they don't need any special Eclipse
internals to execute.
The tests are in a seperate /test source folder in the plugin.
The project is a plugin project, but running the tests as "JUnit plugin
tests" brings up the same error message.
I tried putting the test packages in the "exported packages" section in the
manifest, but that didn't help.
I have the following entries in my manifest classpath:

Bundle-ClassPath: .,
src/,
test/

What could be wrong? Below is the stacktrace of a sample test that I get
when I try to run it.

Thank you,
Michael Böckling



Class not found
com.heiler.ppm.cms.core.impl.rql.api.commands.page.ListStruc turalElementsTest
java.lang.ClassNotFoundException:
com.heiler.ppm.cms.core.impl.rql.api.commands.page.ListStruc turalElementsTest
at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274 )
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadC lass(RemoteTestRunner.java:683)
at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadC lasses(RemoteTestRunner.java:425)
at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe sts(RemoteTestRunner.java:445)
at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe sts(RemoteTestRunner.java:673)
at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(R emoteTestRunner.java:386)
at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main( RemoteTestRunner.java:196)
Re: Problem running JUnit tests [message #180408 is a reply to message #180302] Wed, 15 November 2006 19:38 Go to previous message
Eclipse User
Originally posted by: wayne.beaton._NOSPAM_eclipse.org

Michael Böckling wrote:
> Hi!
>
> I have a problem running unit-tests in Eclipse (3.2).
> The tests are relatively simple, they don't need any special Eclipse
> internals to execute.
> The tests are in a seperate /test source folder in the plugin.
> The project is a plugin project, but running the tests as "JUnit plugin
> tests" brings up the same error message.
> I tried putting the test packages in the "exported packages" section in the
> manifest, but that didn't help.
> I have the following entries in my manifest classpath:
>
> Bundle-ClassPath: .,
> src/,
> test/
>
> What could be wrong? Below is the stacktrace of a sample test that I get
> when I try to run it.
>
> Thank you,
> Michael Böckling
>

Is the /test folder configured to be a Java source file? i.e. does it
have a little icon with a folder/package picture?

Wayne
Previous Topic:Host bundle XXX exists but is unresolved error?
Next Topic:cannot save in eclipse web tools
Goto Forum:
  


Current Time: Tue Sep 23 12:20:48 GMT 2014

Powered by FUDForum. Page generated in 0.11041 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software