Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » WebViewer with Internet Explorer(Using HTML5 features with IE)
WebViewer with Internet Explorer [message #1060589] Mon, 27 May 2013 04:09 Go to next message
donino donino is currently offline donino donino
Messages: 162
Registered: July 2011
Senior Member
Hi everyone,

When we run a webviewer 4.2 report with IE9 or IE10, it appears Internet Explorer is switching to a document-mode IE7 (we can see it with IE development tools). It prevents using native HTML5 features, such number or date input if we customize JSP or add html text within reports.

HTML5 in Webviewer works with all browsers except IE, do someone know why is it happening? Is there a way to avoid Internet Explorer to use this old document mode when it runs under IE9+? May be a JSP to modify, a javascript resource or something like this?

Thanks!

[Updated on: Mon, 27 May 2013 04:10]

Report message to a moderator

Re: WebViewer with Internet Explorer [message #1060880 is a reply to message #1060589] Tue, 28 May 2013 15:57 Go to previous messageGo to next message
Kristopher Clark is currently offline Kristopher Clark
Messages: 130
Registered: January 2013
Senior Member
Looking at the page source of the viewer it looks like it's because of this

<META HTTP-EQUIV="X-UA-Compatible" CONTENT="IE=EmulateIE7">

Using something like

<meta http-equiv="X-UA-Compatible" content="IE=9" />

Should keep it from doing that, there might be a setting in IE to prevent this though I haven't found it.
Re: WebViewer with Internet Explorer [message #1060909 is a reply to message #1060880] Wed, 29 May 2013 02:44 Go to previous messageGo to next message
donino donino is currently offline donino donino
Messages: 162
Registered: July 2011
Senior Member
Thank you Kristopher,

You are right this is what i was looking for. Though by switching to IE=9 it appears there are javascript errors. I was able to fix some of them, but there is still an issue with ajax calls. I will give it a try i think i should be able to make it work at least for the "run" servlet.

Thanks again!
Re: WebViewer with Internet Explorer [message #1061768 is a reply to message #1060909] Mon, 03 June 2013 16:57 Go to previous message
Boyd Nolan is currently offline Boyd Nolan
Messages: 16
Registered: June 2012
Junior Member
We've run into similar issues with an older version of Birt but in reverse...we have to put code in our struts java class to force IE8 mode so that the javascript errors don't prevent the parameters dialog from popping up. This works around the problem, but at the same time disables desirable CSS3 behavior in IE9 and IE10.

Is there any minimum version of Birt that will natively support IE9 and IE10 without these kludges?

Thanks in advance for any help or advice you might have.

Boyd
Previous Topic:Display Birt engine report on iPad
Next Topic:Reading resultset from ReportDesignHandle?
Goto Forum:
  


Current Time: Sat Aug 23 01:31:17 EDT 2014

Powered by FUDForum. Page generated in 0.02000 seconds