Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Missing templates in exported Eclipse(Exporting Eclipse 4.2.2 as new product the exported eclipse has no available themes)
Missing templates in exported Eclipse [message #1041541] Mon, 15 April 2013 08:22
Carlo Gimondi is currently offline Carlo GimondiFriend
Messages: 1
Registered: April 2013
Junior Member
Hi All,
I'm creating my Eclipse product from an Eclipse 4.2.2. When i try to export it everything is fine and my custom plugins work as expected.
Only one issue: when i click on "Preference -> General -> Appearance" i get this error:
"The currently displayed page contains invalid value" and in the log i have this:

!ENTRY org.eclipse.jface 4 2 2013-04-15 09:31:08.619
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.jface".
at org.eclipse.ui.internal.dialogs.ViewsPreferencePage.createContents(
at org.eclipse.jface.preference.PreferencePage.createControl(
at org.eclipse.jface.preference.PreferenceDialog.createPageControl(
at org.eclipse.jface.preference.PreferenceDialog$
at org.eclipse.ui.internal.JFaceUtil$
at org.eclipse.jface.preference.PreferenceDialog.showPage(
at org.eclipse.ui.internal.dialogs.FilteredPreferenceDialog.showPage(
at org.eclipse.jface.preference.PreferenceDialog$
at org.eclipse.swt.custom.BusyIndicator.showWhile(
at org.eclipse.jface.preference.PreferenceDialog$9.selectionChanged(
at org.eclipse.jface.viewers.StructuredViewer$
at org.eclipse.ui.internal.JFaceUtil$
at org.eclipse.jface.viewers.StructuredViewer.firePostSelectionChanged(
at org.eclipse.jface.viewers.StructuredViewer.handlePostSelect(
at org.eclipse.jface.viewers.StructuredViewer$5.widgetSelected(
at org.eclipse.jface.util.OpenStrategy.firePostSelectionEvent(
at org.eclipse.jface.util.OpenStrategy.access$5(
at org.eclipse.jface.util.OpenStrategy$
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(
at org.eclipse.swt.widgets.Display.runAsyncMessages(
at org.eclipse.swt.widgets.Display.readAndDispatch(
at org.eclipse.jface.window.Window.runEventLoop(

I insert in the product configuration all the org.eclipse.e4.ui.css.* plugins and also i try to insert "org.eclipse.e4.ui.css.swt.theme/themeid=org.eclipse.e4.ui.css.theme.e4_default6.1" in but it doesn't work

Any idea?
Previous Topic:Eclipse custom texteditor - marker annotation presentation issue
Next Topic:Plugins installed using aTarget Definition are not properly installed
Goto Forum:

Current Time: Mon Oct 05 04:25:28 GMT 2015

Powered by FUDForum. Page generated in 0.08517 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software