Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » getting "BUILD FAILED: java.lang.NoClassDefFoundError:org/apache/commons/net/ftp
getting "BUILD FAILED: java.lang.NoClassDefFoundError:org/apache/commons/net/ftp [message #152706] Tue, 16 May 2006 03:22 Go to next message
Eclipse UserFriend
Originally posted by: prakash.sada.gmail.com

When I am running the build file (build.ant) from eclipse I got the
following error.

"BUILD FAILED: java.lang.NoClassDefFoundError:
org/apache/commons/net/ftp/FTPClient"

The following is the xml descroptor.

<target name="ftp-del">
<ftp server="${ftp.server}"
remotedir="${ftp.remotedir}"
userid="${ftp.userid}" action="delete"
password="${ftp.password}"
verbose="yes">
<fileset>
<include name="filename.jar"/>

</fileset>
</ftp>
</target>

Pls provide me some help.

Thanks in advanse,
Prakash
Re: getting "BUILD FAILED: java.lang.NoClassDefFoundError:org/apache/commons/net/ftp [message #152712 is a reply to message #152706] Tue, 16 May 2006 04:04 Go to previous message
Darin Swanson is currently offline Darin SwansonFriend
Messages: 2386
Registered: July 2009
Senior Member
As with any Ant buildfile that uses ftp, you need the commons-net.jar on
your Ant runtime classpath.
See http://ant.apache.org/manual/install.html#librarydependencie s

In Eclipse you can easily add to the Ant runtime classpath via:
Window>Preferences>Ant>Runtime>Classpath>Global Entries>Add External JARs

HTH
Darins

"Prakash rao .Sadha" <prakash.sada@gmail.com> wrote in message
news:872324ca9223599a1b8c09496a7cae79$1@www.eclipse.org...
> When I am running the build file (build.ant) from eclipse I got the
> following error.
>
> "BUILD FAILED: java.lang.NoClassDefFoundError:
> org/apache/commons/net/ftp/FTPClient"
>
> The following is the xml descroptor.
>
> <target name="ftp-del">
> <ftp server="${ftp.server}"
> remotedir="${ftp.remotedir}"
> userid="${ftp.userid}" action="delete"
> password="${ftp.password}"
> verbose="yes">
> <fileset>
> <include name="filename.jar"/>
>
> </fileset> </ftp>
> </target>
> Pls provide me some help.
>
> Thanks in advanse,
> Prakash
>
Previous Topic:(CGI-Target)Could not connect to CGI-Proxy
Next Topic:Update - different in 3.01 than in 3.1.2?
Goto Forum:
  


Current Time: Sun Dec 21 16:38:31 GMT 2014

Powered by FUDForum. Page generated in 0.02101 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software