Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » [SOLVED]Wrong path while running file as PHP Web Application
icon5.gif  [SOLVED]Wrong path while running file as PHP Web Application [message #1030243] Sat, 30 March 2013 22:45 Go to next message
Philip Moon is currently offline Philip MoonFriend
Messages: 7
Registered: February 2012
Junior Member
Hi all,


I have an eclipse issue following the tutorial here : docs DOT joomla.org/Configuring_Eclipse_for_joomla_development#Setting_up_Xdebug at the 'Create and Run a PHP File' paragraph : I have create the project in the directory c:\xampp\htdocs\joomla_development\Test Debug and the test.php inside this last (Test Debug), however when I select the file "test.php" and right-click and select Run As PHP Web Page my version it is 'PHP Web Application' eclipse open a browser with a wrong url : localhost/Test Debug/test.php instead of localhost/joomla_development/Test Debug/test.php .

Thanks in advance for your help,

[Updated on: Fri, 12 April 2013 14:11]

Report message to a moderator

Re: Wrong path while running file as PHP Web Application [message #1030490 is a reply to message #1030243] Sun, 31 March 2013 08:01 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 355
Registered: July 2009
Location: Japan
Senior Member
You had to edit 'auto-generated url' if it is wrong when you're asked.
Also, you missed http://docs.joomla.org/Configuring_Eclipse_and_Xdebug#Set_Debug_Options - "PHP Servers" settings.(though the description is too late) It was necessary to set the url of the server. However, this is unavailable because the settings had been changed since PDT 3.0.

So, a workaround is...
Open project properties(right-click the project and select Properties).
Select "PHP Debug", check "Enable project specific settings", edit "Default Base URL" to "/joomla_development/Test Debug".
(Note that it is necessary to recreate the launch config. Run(main menu)->Run Configurations->delete your configuration or edit auto-generated url in it)
Re: Wrong path while running file as PHP Web Application [message #1030801 is a reply to message #1030490] Sun, 31 March 2013 19:50 Go to previous messageGo to next message
Philip Moon is currently offline Philip MoonFriend
Messages: 7
Registered: February 2012
Junior Member
Toshihiro Izumi wrote on Sun, 31 March 2013 04:01
You had to edit 'auto-generated url' if it is wrong when you're asked.
Also, you missed docs.joomla.org/Configuring_Eclipse_and_Xdebug#Set_Debug_Options - "PHP Servers" settings.(though the description is too late) It was necessary to set the url of the server. However, this is unavailable because the settings had been changed since PDT 3.0.


I am using Eclipse SDK 4.2.2 . I am not sure to have understood : Is it possible to do the setting if I create a new project or this feature is not available anymore from PDT 3.0?

When I go to Window/Preferences/General/Web Browser and select external browser + firefox (internal option works fine) it opens a windows with the path localhost/joomla_dvelopement/Test instead of localhost/joomla_dvelopement/Test Debug/test.php

[Updated on: Mon, 01 April 2013 02:06]

Report message to a moderator

Re: Wrong path while running file as PHP Web Application [message #1039730 is a reply to message #1030801] Fri, 12 April 2013 14:10 Go to previous message
Philip Moon is currently offline Philip MoonFriend
Messages: 7
Registered: February 2012
Junior Member
While I have change my eclipse version to eclipse-java-juno-SR2-win32, it seems that my error came from the fact my project name was different from its folder name.
Previous Topic:Which PDT * Feature do I select?
Next Topic:How to make eclipse faster?
Goto Forum:
  


Current Time: Sun Nov 23 22:27:19 GMT 2014

Powered by FUDForum. Page generated in 0.01832 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software