Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » WindowBuilder Install Fails Eclipse Juno 4.2(The installation appears to be partial, can't create a new project.)
WindowBuilder Install Fails Eclipse Juno 4.2 [message #1017970] Tue, 12 March 2013 18:05 Go to next message
Steve Morgan is currently offline Steve Morgan
Messages: 3
Registered: March 2013
Junior Member
Eclipse version Juno 4.2
Installed the appropriate WindowBuilder from Eclipse link.
Indications that I have installed WindowBuilder:
1) Window->Preferences->WindowBuilder...Code parsing, swing, SWT, UI Toolkits.
2) Window->Preferences->Web Toolkit->Designer...Absolute Layout, Code style, Event Handling.
3) File->New->WindowBuilder->GWT User Interface. (also contains project pallet, swing designer, SWT designer).

So I do File->New->WindowBuilder->GWT User Interface. I get the following dialog:

"Install GWT Toolkit"
"Create a new GWT interface. Requires loading additional WindowBuilder toolkits"
"Installing Toolkit..."

Brings up an additional dialog with 8 items: Google Plugin for Eclipse 3.7 (!), GWT designer (3 items), WindowBuilder (4 items)
Next or Finish buttons on the dialog have no effect. I can only cancel the dialog. If I unselect the Google Plugin for Eclipse 3.7 I can click install but the install fails.

So, something isn't working. I see there is currently a lot of activity moving WindowBuilder to Eclipse. The forums I have searched give mixed reviews on whether WindowBuilder works with Juno 4.2, or even works at all.

I have attached a screen print of the dialogs I am seeing.

Many thanks for your help!
  • Attachment: Capture.JPG
    (Size: 97.16KB, Downloaded 703 times)
  • Attachment: Capture2.JPG
    (Size: 30.63KB, Downloaded 410 times)
  • Attachment: Capture3.JPG
    (Size: 38.26KB, Downloaded 367 times)
Re: WindowBuilder Install Fails Eclipse Juno 4.2 [message #1018452 is a reply to message #1017970] Wed, 13 March 2013 17:16 Go to previous messageGo to next message
Eric Clayberg is currently offline Eric Clayberg
Messages: 832
Registered: July 2009
Location: Boston, MA
Senior Member
WIndowBuilder works great with both 4.2 and 4.3. The WB code from the Juno site is out of date by now, so you should install it from the WB update sites on the WB download page.

The Google GPE team is also working on an update to GWT Designer that will work with Juno and the latest WB update.
Re: WindowBuilder Install Fails Eclipse Juno 4.2 [message #1018523 is a reply to message #1018452] Wed, 13 March 2013 21:39 Go to previous messageGo to next message
Steve Morgan is currently offline Steve Morgan
Messages: 3
Registered: March 2013
Junior Member
I believe you Eric, but I have been unable to get it installed properly. I did a fresh install of everything, as described below but still ended up with no GWT option in the Preferences->WindowBuilder dialog.

Below is the procedure I followed. I am certain that I am not the only one having this problem so if you could point me to a resource that goes through the installation step by step I'd really appreciate it. I have also attached screen clips from how it should look (from the Eclipse Indigo WindowBuilder Pro documentation) and what I have.
Thanks

1) Fresh install of Eclipse Juno 4.2 from Eclipse website.
2) Install only Google Plugin for Eclipse 3.8/4.2(Juno) from "dl.google.com/eclipse/plugin/4.2"
3) Install WindowBuilder Pro from "download.eclipse.org/windowbuilder/WB/release/R201209281200/4.2/"
-- Swing Designer
-- SWT Designer
-- WindowBuilder Engine

Result:
Preferences->WindowBuilder
--Code Parsing
--Swing
--SWT
--UI Toolkits

4) Installed GWT SDK: dl.google.com/eclipse/plugin/4.2
-- Google Web Toolkit SDK 2.5.0

Result:
Same as above

  • Attachment: Capture.JPG
    (Size: 11.32KB, Downloaded 344 times)
  • Attachment: Capture2.JPG
    (Size: 10.84KB, Downloaded 286 times)
Re: WindowBuilder Install Fails Eclipse Juno 4.2 [message #1018530 is a reply to message #1018523] Wed, 13 March 2013 22:02 Go to previous message
Eric Clayberg is currently offline Eric Clayberg
Messages: 832
Registered: July 2009
Location: Boston, MA
Senior Member
You indicated that WIndowBuilder itself does not work with 4.2. WB is composed of SWT Designer and Swing Designer. Both of those work fine under 4.2.

I would always recommend using the latest WB build from the WB update site (the integration links).

I don't believe that the Google team has released a compatible version of GWT Designer that will work with the latest WB code yet. The version you tried to install definitely won't work. If you want to follow up with Google on the status of GWT Designer, I would recommend posting a question to Google's GPE forum. I know they are working on it, so hopefully they will post a new build soon.
Previous Topic:WindowBuilder Palette Issue
Next Topic:gwt designer doesn't work with gwt 2.5
Goto Forum:
  


Current Time: Sat Apr 19 02:58:01 EDT 2014

Powered by FUDForum. Page generated in 0.06976 seconds