Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Memory Analyzer » Custom MAT plugin not loaded on startup(Custom MAT plugin not loaded on startup)
Custom MAT plugin not loaded on startup [message #1016581] Thu, 07 March 2013 01:07 Go to next message
Robin Fernandes is currently offline Robin Fernandes
Messages: 5
Registered: July 2009
Junior Member
Hi all,

We recently wrote a MAT plugin with a custom query and report, with the aim of automatically extracting data from large numbers of dumps with a headless MAT using the ParseHeapDump script. We followed the instructions outlined in this thread, which is still an incredibly useful resource nearly 4 years on!

The resulting plugin works almost perfectly. The only problem is that our plugin is not loaded automatically on first startup after it is deployed to $MAT_HOME/plugins. For it to load, I have to spin up the UI and go to Help/About/Installation Details/Plug-ins, where the plugin is listed. After this, the plugin functionality is available, and it is loaded on subsequent restarts as well as when running headlessly.

Unfortunately, this step must be repeated whenever the plugin is re-deployed. The implication is that we cannot deploy new versions of the plugin to an entirely headless MAT.

Is there anything I need to set in the plugin or on the commandline invocation to ensure my custom plugin is loaded on startup?

We're on MAT 1.2.1.

Cheers,
Robin

[Updated on: Thu, 07 March 2013 23:49]

Report message to a moderator

Re: Custom MAT plugin not loaded on startup [message #1017935 is a reply to message #1016581] Tue, 12 March 2013 20:34 Go to previous messageGo to next message
Andrew Johnson is currently offline Andrew Johnson
Messages: 119
Registered: July 2009
Senior Member
Have you tried using the dropins folder?
http://wiki.eclipse.org/MemoryAnalyzer/Contributor_Reference#Writing_plugins_for_the_Memory_Analyzer

You might have to use the GUI version to do the console operation, but it seems to remember the started state of the p2.reconciler.drops bundle.
Re: Custom MAT plugin not loaded on startup [message #1017943 is a reply to message #1016581] Tue, 12 March 2013 20:37 Go to previous message
Andrew Johnson is currently offline Andrew Johnson
Messages: 119
Registered: July 2009
Senior Member
Have you tried using the dropins folder?
http://wiki.eclipse.org/MemoryAnalyzer/Contributor_Reference#Writing_plugins_for_the_Memory_Analyzer

You might have to use the GUI version once to run with the console and start the p2.reconciler.dropins plug-in, but the plug-in seems to still be active when Memory Analyzer is restarted.
Previous Topic:Problem with Memory Analyzer
Next Topic:how to Install Mat on Linux via Terminal
Goto Forum:
  


Current Time: Wed Oct 01 20:35:10 GMT 2014

Powered by FUDForum. Page generated in 0.11455 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software