Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » trouble configuring eclipse for Pydev ... linux for 32bit x586(IDE wants to open 'Ant' file in 'run' dialogue box with no option "pydev run")
icon5.gif  trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015485] Thu, 28 February 2013 17:25 Go to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
I have had issues running a simple "Hello World" py file in Eclipse. Initially I used the Linux software center to get an image of Eclipse and after numerous attempts to resolve, I tried to address the issues on the ubuntu forums. I removed all java files and downloaded JDK 7 and installed that via the terminal line. I then downloaded and installed Eclipse from the main site, installed in my home folder and used the help menu to download the Pydev software from pydev.org/updates. The Py file opens in the IDE, however when I try to run it the run window opens with only the option to run it as an 'Ant' file. Please can someone help me configure Eclipse for Pydev so it can edit and run files of this type?
Thanks for your consideration

[Updated on: Thu, 28 February 2013 19:23]

Report message to a moderator

Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015514 is a reply to message #1015485] Fri, 01 March 2013 01:25 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 02/28/2013 11:09 AM, Hugh Foster wrote:
> FOr the past 48 hours, I have had issues running a simple "Hello World"
> py file in Eclipse. Initially I used the Linux software center to get an
> image of Eclipse. After numerous and very time consuming issues, I tried
> to address the issues on the ubuntu forums however only got part of the
> answer I was looking for. So I consulted the Eclipse forum and carried
> out a few steps outlined therein. The IDE crashed and as a result I
> removed all java files and downloaded JDK 7 and installed that via the
> terminal line. I then downloaded and installed Eclipse from the main
> site, installed in my home folder and used the help menu to download the
> Pydev software from pydev.org/updates. The Py file opens in the IDE,
> however when I rty to run it the run window opens with only the option
> to run it as an 'Ant' file. Pleas can someone help me configure Eclipse
> for Pydev so it can edit and run files of this type?
> Thanks for your considerations.
> H :p

First, never ever obtain Eclipse through any Linux software distribution
center. Always get it from eclipse.org.

The PyDev site appears to encourage questions on stackoverflow.com using
the PyDev tag.

http://pydev.org/about.html
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015517 is a reply to message #1015514] Fri, 01 March 2013 02:50 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
thank you #Russel Bateman
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015519 is a reply to message #1015517] Fri, 01 March 2013 04:19 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
I had a look at stackoverflow and didnt see much, not to say that I didnt already try.. its a problem with java
# Problematic frame:
# C [ld-linux.so.2+0xb968] _dl_rtld_di_serinfo+0x2e48
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
this error occurred while trying to access the interactive help in the right side pane. what initially was meant to be a convenient study tool has become inconvenient Shocked

[Updated on: Fri, 01 March 2013 04:29]

Report message to a moderator

Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015676 is a reply to message #1015519] Fri, 01 March 2013 16:31 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
I wouldve thought there would be more interest in this error. it looks like a really great program but I guess since it has caused this much trouble I will just do what I shouldve done 3 days ago and go with another editor. I may decide to try again once it gets pertinnet to manage java or I have a beter vantage point on configuring it. Have a nice weekend, admin
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015680 is a reply to message #1015676] Fri, 01 March 2013 16:46 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 3/1/2013 9:31 AM, Hugh Foster wrote:
> I wouldve thought there would be more interest in this error. it looks
> like a really great program but I guess since it has caused this much
> trouble I will just do what I shouldve done 3 days ago and go with
> another editor. I may decide to try again once it gets pertinnet to
> manage java or I have a beter vantage point on configuring it. Have a
> nice weekend, admin

Eclipse isn't an editor. It's an IDE and, with respect to PyDev (Android
is another perfect example), it's a framework in which just about any
project can develop extensions to make their own IDE. Sometimes the
seams fray and show difficulty. How well problems are resolved is a
testimony to how much support there is for it.

Don't confuse PyDev with Eclipse (or Android Development with Eclipse).

I have not used PyDev and have no opinion about it. It's not supported
by this forum. So you're not judging it under adequate light.

I have used Android tools. They work pretty well all things considered,
but similarly this isn't the forum in which to ask about them and
judging them by this forum is unfair.

Etc.

Best of luck.
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015693 is a reply to message #1015680] Fri, 01 March 2013 19:06 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
Im not one to give up and it doesnt make sense to me why it would be so awkward to get up and running but maybe its a testimonial to my ability and I make no bones about it that I am a beginner at this. To have the IDE working would be the best case scenario so I will take my leave and once I have a better understanding of how this works I may be back. Thanks for your reply Russel and have a nice weekend
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015705 is a reply to message #1015693] Fri, 01 March 2013 20:33 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
the error it encountered was a Java error and this error isnt an Eclipse issue and I apologize for my impatience. What is the best way to install eclipse so that i do it the right way?
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015709 is a reply to message #1015705] Fri, 01 March 2013 20:44 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 3/1/2013 1:33 PM, Hugh Foster wrote:
> the error it encountered was a Java error and this error isnt an Eclipse
> issue and I apologize for my impatience. What is the best way to install
> eclipse so that i do it the right way?

Here's what I'd do. You can read ooey-gooey verbiage at

http://www.javahotchocolate.com/tutorials/eclipse-summary.html

if you want, but these are the steps you can follow if you know how.
Realize that this is how I do it. Others may do it differently. Also, my
instructions assume you're going to develop Java applications. This
won't hurt you if all you're going to do is Python.

1. Download and explode a private Sun JDK (from java.sun.com).

2. Download and explode Eclipse somewhere under /home/hugh.

Which package is best for Python? Beats me, but I'm sure
Eclipse IDE for Java Developers will not hurt you any.

3. Edit eclipse.ini by examining http://wiki.eclipse.org/Eclipse.ini.

You'll want to add the following:

...
-vm
/home/hugh/where-I-put-my-JDK/bin/java
-vmargs
...

4. If you want to create a launcher, do that:
a. Create launcher.
b. Filesystem path is /home/hugh/.../eclipse/eclipse.
c. For icon, use /home/hugh/.../eclipse/icon.xpm

5. Launch Eclipse.

6. Trouble? Come back here.
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015710 is a reply to message #1015709] Fri, 01 March 2013 20:47 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 3/1/2013 1:44 PM, Russell Bateman wrote:
> On 3/1/2013 1:33 PM, Hugh Foster wrote:
>> the error it encountered was a Java error and this error isnt an Eclipse
>> issue and I apologize for my impatience. What is the best way to install
>> eclipse so that i do it the right way?
>
> [snip]
>
> 6. Trouble? Come back here.

Oh yeah, I forgot, now for the PyDev bit...

Once Eclipse is up and running, you'll use Help -> Eclipse Marketplace.

In Find: type pydev

You can take it from here. I think you just click on the Install button
at the bottom right of PyDev - Python IDE for Eclipse.


Best of luck,

Russ
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015811 is a reply to message #1015710] Sun, 03 March 2013 07:02 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
Thanks Russ, I have java sorted out with the plugins in the right spot with a fresh perspective and Im ready to try again Very Happy
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015815 is a reply to message #1015710] Sun, 03 March 2013 07:02 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
Thanks Russ, I have java sorted out with the plugins in the right spot with a fresh perspective and Im ready to try again :d
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015817 is a reply to message #1015710] Sun, 03 March 2013 07:02 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
Thanks Russ, I have java sorted out with the plugins in the right spot with a fresh perspective and Im ready to try again :d
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015819 is a reply to message #1015710] Sun, 03 March 2013 07:02 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
Thanks Russ, I have java sorted out with the plugins in the right spot with a fresh perspective and Im ready to try again :d
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015843 is a reply to message #1015811] Sun, 03 March 2013 17:24 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
I grabbed jre1.6.20 and moved it to a folder 'jre' inside eclipse. So now I guess I have to edit the ini;
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.200.v20120913-144807
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
/Home/eclipse/jre
-vmargs
-Xms40m
-Xmx512m
for the launcher not exactly sure how to 'create launcher'.. some advice on getting this going would help
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015852 is a reply to message #1015843] Sun, 03 March 2013 18:55 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
btw pls forgive my flagrant overuse of the post reply button on my previous message, lol. not sure how to delete those
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015864 is a reply to message #1015852] Sun, 03 March 2013 23:20 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
it couldnt find -vm but that is probably because I didnt unpack it and make it executable.... what is the way to unpack it to the correct directory?
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015874 is a reply to message #1015864] Mon, 04 March 2013 05:40 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 03/03/2013 04:20 PM, Hugh Foster wrote:
> it couldnt find -vm but that is probably because I didnt unpack it and
> make it executable.... what is the way to unpack it to the correct
> directory?

(You were on Linux, right?)

eclipse.ini doesn't come with the -vm option in it. When you run Eclipse
without it, it just runs on whatever JRE happens to be available on the
search path.

You pick the directory you want and explode the tarball you downloaded
from eclipse.org there. For instance:

/home/hugh $ tar -zxf eclipse....tgz
/home/hugh $ cd eclipse
/home/hugh/eclipse $ vim eclipse.ini
....
-vm
/home/hugh/jdk1.0.6_20/bin/java
....
:wq

/home/hugh/eclipse $ ./eclipse

....and you're running.
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1015875 is a reply to message #1015874] Mon, 04 March 2013 05:45 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 03/03/2013 10:42 PM, Russell Bateman wrote:
> On 03/03/2013 04:20 PM, Hugh Foster wrote:
>> it couldnt find -vm but that is probably because I didnt unpack it and
>> make it executable.... what is the way to unpack it to the correct
>> directory?
>
> (You were on Linux, right?)
>
> eclipse.ini doesn't come with the -vm option in it. When you run Eclipse
> without it, it just runs on whatever JRE happens to be available on the
> search path.
>
> You pick the directory you want and explode the tarball you downloaded
> from eclipse.org there. For instance:
>
> /home/hugh $ tar -zxf eclipse....tgz
> /home/hugh $ cd eclipse
> /home/hugh/eclipse $ vim eclipse.ini
> ...
> -vm
> /home/hugh/jdk1.0.6_20/bin/java
> ...
> :wq
>
> /home/hugh/eclipse $ ./eclipse
>
> ...and you're running.

Oh, yeah, I forgot, you moved Java to under eclipse. That wasn't
necessary, but it is a way to solve the problem. In that case, you don't
need to add the -vm option.
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016116 is a reply to message #1015875] Tue, 05 March 2013 06:40 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
SIGBUS error again.. # SIGBUS (0x7) at pc=0xb7772968, pid=4277, tid=3075995328
#
# JRE version: 7.0_15-b20
# Java VM: OpenJDK Client VM (23.7-b01 mixed mode, sharing linux-x86 )
# Problematic frame:
# C [ld-linux.so.2+0xb968] _dl_rtld_di_serinfo+0x2e48
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016266 is a reply to message #1016116] Tue, 05 March 2013 18:05 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
I moved the .bin file up a directory from inside eclipse in the Home folder. Obviously I am new to lINUX and Im noting that the LIGHTNING folder, the one you have referred to as 'hugh' is essentially the same name as 'Home'.I tried to open the workspace I configured for py files and I get this huge error...org.eclipse.core.runtime.CoreException: Cannot create extension
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016268 is a reply to message #1016266] Tue, 05 March 2013 18:12 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 3/5/2013 11:05 AM, Hugh Foster wrote:
> I moved the .bin file up a directory from inside eclipse in the Home
> folder. Obviously I am new to lINUX and Im noting that the LIGHTNING
> folder, the one you have referred to as 'hugh' is essentially the same
> name as 'Home'.I tried to open the workspace I configured for py files
> and I get this huge error...org.eclipse.core.runtime.CoreException:
> Cannot create extension

The problem is that this has to do with PyDev in Eclipse, which isn't
supported by any Eclipse forum. According to the PyDev web page, their
idea of support is to ask the question in stackoverflow.com carefully
applying the PyDev tag. I've found stackoverflow to be hugely successful
and lightning fast (no pun intended) for answers, especially as compared
to other forums I hang out in.

Best of luck,

Russ
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016287 is a reply to message #1016268] Tue, 05 March 2013 20:16 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
OK Russell. I am going back to stackoverflow . Thanks for all your help.. I will return to this thread with my triumphant solution / denoument (that I get from someone else) Wink
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016295 is a reply to message #1016287] Tue, 05 March 2013 21:32 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
So, if I get a fatal error from trying to access the welcome command in the help dialogue, that is a Pydev issue? I went to stackoverflow and got a Pydev zip file installed in the right place, I can see the file in the IDE but it wants to run it as an ANT file. not sure if this is a Pydev issue either. ?
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016312 is a reply to message #1016295] Wed, 06 March 2013 00:23 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
I got it working
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016314 is a reply to message #1016312] Wed, 06 March 2013 00:31 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 3/5/2013 5:23 PM, Hugh Foster wrote:
> I got it working

Ah, we're all a-quiver. If you understand why, please say what was wrong
and how you fixed it. The next guy will discover this via Google.
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016332 is a reply to message #1016314] Wed, 06 March 2013 05:41 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
I thought you would be pleased.... It was mostly due to the zip file I downloaded from the Pydev site due to a similar query from stackoverflow by framing the question and looking at the results. I also moved the jre bin file from the folder I made for it and left it in the Home folder.... that seemed to clear up the core dump errors, although Im not altogether ceertain that eclipse is using jre1 6 20. Also, I ditched the old workspace file I had been using and decided to run the robots test and I managed tyo get most of the thing running smoothly. Im sure once my python ability improves the true values of the IDE will shine through, The next thing for me wouyld naturally begin learning to use this platform to develop java. can you recommend a good tutorial I can have a look at to get the IDE configuredfor java and maybe crank out an app?
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016337 is a reply to message #1016332] Wed, 06 March 2013 06:09 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 03/05/2013 10:41 PM, Hugh Foster wrote:
> I thought you would be pleased.... It was mostly due to the zip file I
> downloaded from the Pydev site due to a similar query from stackoverflow
> by framing the question and looking at the results. I also moved the jre
> bin file from the folder I made for it and left it in the Home
> folder.... that seemed to clear up the core dump errors, although Im not
> altogether ceertain that eclipse is using jre1 6 20. Also, I ditched the
> old workspace file I had been using and decided to run the robots test
> and I managed tyo get most of the thing running smoothly. Im sure once
> my python ability improves the true values of the IDE will shine
> through, The next thing for me wouyld naturally begin learning to use
> this platform to develop java. can you recommend a good tutorial I can
> have a look at to get the IDE configuredfor java and maybe crank out an
> app?

They are legion.

In particular, I suggest http://www.vogella.de.
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016552 is a reply to message #1016337] Wed, 06 March 2013 21:16 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
Indeed,
Thanks for that.
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016555 is a reply to message #1016552] Wed, 06 March 2013 21:47 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 3/6/2013 2:16 PM, Hugh Foster wrote:
> Indeed, Thanks for that.

I don't get paid for recommending Lars' or any other sites. His has just
grown to be my favorite over the years. I also find mkyong.com useful
sometimes.
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016836 is a reply to message #1016555] Thu, 07 March 2013 20:45 Go to previous messageGo to next message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
well so far I have managed to create my first java file but I am having a problem exporting to the terminal....
lightning@rigel5:~$ java -options
Unrecognized option: -options
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit
wt...?
hope ur having a splendid day Very Happy

[Updated on: Thu, 07 March 2013 20:46]

Report message to a moderator

Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016841 is a reply to message #1016836] Thu, 07 March 2013 21:00 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3221
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 3/7/2013 1:45 PM, Hugh Foster wrote:
> well so far I have manged to create my first java file but I am having a
> problem exporting to the terminal....
> lightning@rigel5:~$ java -options
> Unrecognized option: -options
> Error: Could not create the Java Virtual Machine.
> Error: A fatal exception has occurred. Program will exit
> wt...?

(You should probably start a new forum thread.)

Do you mean you want to execute the Java code you wrote from the command
line? If so, that means you are looking to create a runnable JAR and
this might help:

http://www.javahotchocolate.com/tutorials/jars-and-wars.html#runnable
Re: trouble configuring eclipse for Pydev ... linux for 32bit x586 [message #1016844 is a reply to message #1016841] Thu, 07 March 2013 21:12 Go to previous message
Hugh Foster is currently offline Hugh Foster
Messages: 33
Registered: February 2013
Member
yeah was going to do that but I wanted to check with you first.. was goign to put it in the eclipse juno thread or just make a new one maybe
Previous Topic:Java Window opening with Eclipse after changing the JRE
Next Topic:Cannot find installed plugin on Eclipse Indigo
Goto Forum:
  


Current Time: Thu Oct 23 16:44:45 GMT 2014

Powered by FUDForum. Page generated in 0.03030 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software