Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to install Scala IDE plug-in for Eclipse Juno
Unable to install Scala IDE plug-in for Eclipse Juno [message #1014727] Tue, 26 February 2013 05:57 Go to next message
Missing name Mising name is currently offline Missing name Mising name
Messages: 2
Registered: October 2010
Junior Member
I tried installing the following plugin for Eclipse Juno M20120914-1800:

nightly-scala-ide-3.0.x-210x from the official Scala IDE website.

Am running Mountain Lion (OS X 10.8.2) and my Java & Scala versions are as follows:

java version "1.6.0_41"
Java(TM) SE Runtime Environment (build 1.6.0_41-b02-445-11M4107)
Java HotSpot(TM) 64-Bit Server VM (build 20.14-b01-445, mixed mode)

Scala code runner version 2.10.0 -- Copyright 2002-2012, LAMP/EPFL


When I tried installing the Scala IDE plug-in, the process was prevented and Eclipse displayed this error:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Scala IDE for Eclipse 3.0.0.nightly-2_10-201302251757-3951e3e 
(org.scala-ide.sdt.feature.feature.group 3.0.0.nightly-2_10-201302251757-3951e3e)

 Only one of the following can be installed at once: 

    Object Teams Development Tooling Core 3.8.1.v_OTDT_r210_201206090452 
    (org.eclipse.jdt.core 3.8.1.v_OTDT_r210_201206090452)
    Java Development Tools Core 3.8.1.v20120531-0637 (org.eclipse.jdt.core 3.8.1.v20120531-0637)
    Java Development Tools Core 3.7.3.v20120119-1537 (org.eclipse.jdt.core 3.7.3.v20120119-1537)
    Object Teams Development Tooling Core 3.8.2.v_OTDT_r211_201209011847 (org.eclipse.jdt.core 

3.8.2.v_OTDT_r211_201209011847)
    Java Development Tools Core 3.8.2.v20120814-155456 
   (org.eclipse.jdt.core 3.8.2.v20120814-155456)

  Cannot satisfy dependency:

    From: JDI Debug UI 3.6.100.v20120530-1425 
    (org.eclipse.jdt.debug.ui 3.6.100.v20120530-1425)
    To: bundle org.eclipse.jdt.launching [3.6.100,4.0.0)

  Cannot satisfy dependency:

    From: Java Development Tools Launching Support 3.6.100.v20120523-1953 (org.eclipse.jdt.launching 3.6.100.v20120523-1953)
    To: bundle org.eclipse.jdt.core [3.8.0,4.0.0)

  Cannot satisfy dependency:

    From: Scala Plugin 3.0.0.nightly-2_10-201302251757-3951e3e (org.scala-ide.sdt.core 3.0.0.nightly-2_10-201302251757-3951e3e)
    To: bundle org.eclipse.jdt.core [3.6.0,3.7.10)
  Cannot satisfy dependency:

    From: Scala IDE for Eclipse 3.0.0.nightly-2_10-201302251757-3951e3e (org.scala-ide.sdt.feature.feature.group 3.0.0.nightly-2_10-201302251757-3951e3e)
    To: org.eclipse.jdt.debug.ui 0.0.0

  Cannot satisfy dependency:

    From: Scala IDE for Eclipse 3.0.0.nightly-2_10-201302251757-3951e3e (org.scala-ide.sdt.feature.feature.group 3.0.0.nightly-2_10-201302251757-3951e3e)
    To: org.scala-ide.sdt.core [3.0.0.nightly-2_10-201302251757-3951e3e]


Would really appreciate if someone could help...

-James
Re: Unable to install Scala IDE plug-in for Eclipse Juno [message #1015559 is a reply to message #1014727] Fri, 01 March 2013 04:01 Go to previous message
Stephane Begaudeau is currently offline Stephane Begaudeau
Messages: 406
Registered: April 2010
Location: Nantes (France)
Senior Member

Hi,

You problem is simple:

Only one of the following can be installed at once: 

    Object Teams Development Tooling Core 3.8.1.v_OTDT_r210_201206090452 
    (org.eclipse.jdt.core 3.8.1.v_OTDT_r210_201206090452)
    Java Development Tools Core 3.8.1.v20120531-0637 (org.eclipse.jdt.core 3.8.1.v20120531-0637)
    Java Development Tools Core 3.7.3.v20120119-1537 (org.eclipse.jdt.core 3.7.3.v20120119-1537)
    Object Teams Development Tooling Core 3.8.2.v_OTDT_r211_201209011847 (org.eclipse.jdt.core 


You are trying to have the Java Developement Tools in version 3.8.x and 3.7.x. The 3.8.x version has been released for Eclipse Juno (Eclipse 3.8/4.2), the 3.7.x version has been released for Eclipse Indigo (Eclipse 3.7). Your Eclipse installation comes with the Java Development Tools 3.8.x but the version of the Scala IDE that you are trying to install wants the Java Development Tools from Eclipse Indigo:
Cannot satisfy dependency:

    From: Scala Plugin 3.0.0.nightly-2_10-201302251757-3951e3e (org.scala-ide.sdt.core 3.0.0.nightly-2_10-201302251757-3951e3e)
    To: bundle org.eclipse.jdt.core [3.6.0,3.7.10)


You are trying to install a plugin for Eclipse 3.7 Indigo on Eclipse 3.8/4.2 Juno. You can find on the Scala IDE website the proper version for Eclipse 3.8/4.2 Juno.

Regards,

Stephane Begaudeau, Obeo

--
Twitter: @sbegaudeau
Google+: +stephane.begaudeau
Blog: http://stephanebegaudeau.tumblr.com | Eclipse Java Development Tools Tips and Tricks



Previous Topic:Source / Build-Instructions for Eclipse Distributions
Next Topic:Eclipse Juno, Window not working
Goto Forum:
  


Current Time: Wed Jul 30 11:09:56 EDT 2014

Powered by FUDForum. Page generated in 0.15828 seconds