Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGL Development Tools » Connection profile issue in 0.8.2(Same issue as in 0.8.1.)
Connection profile issue in 0.8.2 [message #1003739] Mon, 21 January 2013 22:47 Go to next message
Dan Darnell is currently offline Dan DarnellFriend
Messages: 145
Registered: November 2011
Location: Arkansas
Senior Member
For details, see the old 0.8.1 thread:

http://www.eclipse.org/forums/index.php/t/378205/

Target database is DB2 on IBM i.

In an SQL binding, when working with connection profiles, we want to end up with a connection URL like this:

jdbc:as400:www.xxxxxxxxxxxxxxx.com;libraries=ddarnelldt;prompt=false

or (optionally)

jdbc:as400:www.xxxxxxxxxxxxxxx.com;naming=system;libraries=ddarnelldt;prompt=false

In driver properties I can create a connection URL that looks like those above but it is ignored in the connection profile.

In the connection profile I can specify a default schema but it is also apparently ignored.

In the connection profile the "Connection URL" is read-only.

The net result is that we cannot use connection profiles with DB2 on IBM i. We have to use the "Specify connection information" option and key in the details of every connection.

Bug? Enhancement request?

--Dan
Re: Connection profile issue in 0.8.2 [message #1004618 is a reply to message #1003739] Wed, 23 January 2013 14:53 Go to previous messageGo to next message
Justin Spadea is currently offline Justin SpadeaFriend
Messages: 66
Registered: July 2009
Member
Hi Dan,

I tried to use the optional properties under "Driver Properties", but they weren't being appended to the URL. I didn't see any way to modify this URL in the connection profile dialog (mind you I don't have IBMi so I was using DB2 on Linux). Since we just get the URL from the connection profile and don't mess with it, I suggest asking on the datatools forum to see if someone there knows how to append to the URL.

-Justin
Re: Connection profile issue in 0.8.2 [message #1004753 is a reply to message #1004618] Wed, 23 January 2013 20:06 Go to previous messageGo to next message
Dan Darnell is currently offline Dan DarnellFriend
Messages: 145
Registered: November 2011
Location: Arkansas
Senior Member
Hi Justin,

I think I understand where you are coming from. So this aspect of the tooling is not an EDT thing -- you are just leveraging what is coming out of the datatools effort. Correct?

--Dan
Re: Connection profile issue in 0.8.2 [message #1004755 is a reply to message #1004753] Wed, 23 January 2013 20:11 Go to previous message
Justin Spadea is currently offline Justin SpadeaFriend
Messages: 66
Registered: July 2009
Member
That's right, we're just using what's already part of Eclipse.

-Justin
Previous Topic:Error Using sysLib.wait(2);
Next Topic:@MVC
Goto Forum:
  


Current Time: Wed Dec 17 20:04:27 GMT 2014

Powered by FUDForum. Page generated in 0.01835 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software