Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » egit upgrade fails due to conflicting dependency
egit upgrade fails due to conflicting dependency [message #1001567] Wed, 16 January 2013 19:30 Go to next message
Loren Rosen is currently offline Loren Rosen
Messages: 2
Registered: January 2013
Junior Member
On Juno, I attempted to upgrage egit to 2.2, but this failed. Here's the error message
Your original request has been modified.
"Eclipse EGit" is already installed, so an update will be performed instead.
"Eclipse JGit" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse EGit 2.2.0.201212191850-r (org.eclipse.egit.feature.group 2.2.0.201212191850-r)
Software currently installed: Eclipse EGit Mylyn GitHub Feature 2.1.0.201209190230-r (org.eclipse.mylyn.github.feature.feature.group 2.1.0.201209190230-r)
Only one of the following can be installed at once:
Git Team Provider UI 2.2.0.201212191850-r (org.eclipse.egit.ui 2.2.0.201212191850-r)
Git Team Provider UI 2.1.0.201209190230-r (org.eclipse.egit.ui 2.1.0.201209190230-r)
Cannot satisfy dependency:
From: Eclipse EGit 2.2.0.201212191850-r (org.eclipse.egit.feature.group 2.2.0.201212191850-r)
To: org.eclipse.egit.ui
Cannot satisfy dependency:
From: Eclipse EGit Mylyn GitHub Feature 2.1.0.201209190230-r (org.eclipse.mylyn.github.feature.feature.group 2.1.0.201209190230-r)
To: org.eclipse.mylyn.github.ui [2.1.0.201209190230-r]
Cannot satisfy dependency:
From: Mylyn GitHub Connector UI 2.1.0.201209190230-r (org.eclipse.mylyn.github.ui 2.1.0.201209190230-r)
To: package org.eclipse.egit.ui [2.1.0,2.2.0)
Re: egit upgrade fails due to conflicting dependency [message #1004254 is a reply to message #1001567] Tue, 22 January 2013 16:44 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias Sohn
Messages: 543
Registered: July 2009
Senior Member
You've also installed the GitHub connector 2.1 which wants org.eclipse.egit.ui 2.1. So either update both
EGit and the GitHub connector to 2.2 at the same time or uninstall the Github connector, update EGit and
then reinstall the Github connector.
Re: egit upgrade fails due to conflicting dependency [message #1006327 is a reply to message #1004254] Wed, 30 January 2013 15:46 Go to previous messageGo to next message
Loren Rosen is currently offline Loren Rosen
Messages: 2
Registered: January 2013
Junior Member
I have no idea how to upgrade both at the same time. So I uninstalled both of them (as per the insructions at http://wiki.eclipse.org/FAQ_How_do_I_remove_a_plug-in%3F), then reinstalled them via the eclipse marketplace.
Re: egit upgrade fails due to conflicting dependency [message #1008359 is a reply to message #1001567] Tue, 12 February 2013 02:50 Go to previous messageGo to next message
Frank Neblung is currently offline Frank Neblung
Messages: 5
Registered: July 2009
Junior Member
Is there a way to upgrade Eclipse for RCP and RAP Developers Version: Juno Service Release 1 to EGit 2.2?
Neither Install New Software nor Uninstalling does work for me.
Installing EGit 2.2 fails exactly the same way as Loren described.
When trying to uninstall EGit/JGit 2.1 via "Help->About Eclipse" I find the Uninstall... button disabled.
Re: egit upgrade fails due to conflicting dependency [message #1015488 is a reply to message #1001567] Thu, 28 February 2013 12:44 Go to previous message
Cesc Grimalt is currently offline Cesc Grimalt
Messages: 1
Registered: February 2013
Junior Member
Same problem here.

Solved adding new "update site"

http://download.eclipse.org/egit/github/updates-2.3

teh just use "check for updates" without reinstalling anything. It worked for me.

Hope it helps
Previous Topic:Older releases of EGit.
Next Topic:How to list files affected in a commit ?[SOLVED]
Goto Forum:
  


Current Time: Thu Jul 24 16:02:00 EDT 2014

Powered by FUDForum. Page generated in 0.02636 seconds