Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sapphire » Changing minimum requirement from Helios/3.6 to Indigo/3.7
Changing minimum requirement from Helios/3.6 to Indigo/3.7 [message #997879] Tue, 08 January 2013 23:08 Go to next message
Konstantin Komissarchik is currently offline Konstantin Komissarchik
Messages: 941
Registered: July 2009
Senior Member
Currently, Sapphire is compatible with all versions of Eclipse going back to Helios/3.6 release. As part of improvements to the diagram editor functionality, we are running into GEF limitations in Helios/3.6 release that would be cumbersome to workaround. Moving the minimum requirement to Indigo/3.7 would allow us to use GEF API introduced in that release.

We are moving forward with this change for the 0.7 release. The 0.6.x releases will continue to support Helios. If you are a Sapphire adopter and will be significantly adversely affected by this change, speak quickly so that we can discuss alternatives.

- Konstantin
Re: Changing minimum requirement from Helios/3.6 to Indigo/3.7 [message #997881 is a reply to message #997879] Tue, 08 January 2013 23:09 Go to previous message
Konstantin Komissarchik is currently offline Konstantin Komissarchik
Messages: 941
Registered: July 2009
Senior Member
Forgot to reference the tracking bugzilla entry:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=397724
Previous Topic:On-demand compilation of model elements
Next Topic:Time to wrap up 0.5.4 and 0.6.1 releases
Goto Forum:
  


Current Time: Tue Oct 21 07:13:35 GMT 2014

Powered by FUDForum. Page generated in 0.06421 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software