Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » UI tests for pure-e4 apps (no compatibility layer)
UI tests for pure-e4 apps (no compatibility layer) [message #994461] Thu, 27 December 2012 11:18 Go to next message
Mickael Istria is currently offline Mickael Istria
Messages: 765
Registered: July 2009
Location: Grenoble, France
Senior Member
Hi all,

I also posted some questions on the e4 forum.
I've been trying to fix this issue about running SWTBot tests on an e4
application: https://bugs.eclipse.org/bugs/show_bug.cgi?id=391802 . As
reported in the bug, wen starting the JUnit Test Plugin using a pure e4
application without compatibility layer, I can see the application
starting, but no tests are run.
But it seems to me that this issue is not specific to SWTBot. I've tried
running a simple UI test, without SWTBot, and noticed the same behavior.
Running tests on an e4 application using PDE Test laucher seems broken.
Did anyone experienced something similar? Did anyone ever succeed to run
UI tests on an E4 application with PDE? Is there a ug related to this issue?

Cheers,
--
Mickael Istria
JBoss, by Red Hat
My blog: http://mickaelistria.wordpress.com
My Tweets: http://twitter.com/mickaelistria
Re: UI tests for pure-e4 apps (no compatibility layer) [message #996958 is a reply to message #994461] Thu, 03 January 2013 09:38 Go to previous messageGo to next message
Mickael Istria is currently offline Mickael Istria
Messages: 765
Registered: July 2009
Location: Grenoble, France
Senior Member
This ticket reports the issue:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=296599

--
Mickael Istria
JBoss, by Red Hat
My blog: http://mickaelistria.wordpress.com
My Tweets: http://twitter.com/mickaelistria
Re: UI tests for pure-e4 apps (no compatibility layer) [message #999161 is a reply to message #994461] Fri, 11 January 2013 13:32 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo Bettini
Messages: 1370
Registered: July 2009
Senior Member
On 12/27/2012 12:18 PM, Mickael Istria wrote:
> Hi all,
>
> I also posted some questions on the e4 forum.
> I've been trying to fix this issue about running SWTBot tests on an e4
> application: https://bugs.eclipse.org/bugs/show_bug.cgi?id=391802 . As
> reported in the bug, wen starting the JUnit Test Plugin using a pure e4
> application without compatibility layer, I can see the application
> starting, but no tests are run.
> But it seems to me that this issue is not specific to SWTBot. I've tried
> running a simple UI test, without SWTBot, and noticed the same behavior.
> Running tests on an e4 application using PDE Test laucher seems broken.
> Did anyone experienced something similar? Did anyone ever succeed to run
> UI tests on an E4 application with PDE? Is there a ug related to this
> issue?
>
> Cheers,

just for curiosity: how pure e4 applications are usually tested then?

cheers
Lorenzo

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
ICQ# lbetto, 16080134 (GNU/Linux User # 158233)
HOME: http://www.lorenzobettini.it MUSIC: http://www.purplesucker.com
http://www.myspace.com/supertrouperabba
BLOGS: http://tronprog.blogspot.com http://longlivemusic.blogspot.com
http://www.gnu.org/software/src-highlite
http://www.gnu.org/software/gengetopt
http://www.gnu.org/software/gengen http://doublecpp.sourceforge.net
Re: UI tests for pure-e4 apps (no compatibility layer) [message #1000795 is a reply to message #999161] Tue, 15 January 2013 12:47 Go to previous message
Mickael Istria is currently offline Mickael Istria
Messages: 765
Registered: July 2009
Location: Grenoble, France
Senior Member
On 01/11/2013 02:32 PM, Lorenzo Bettini wrote:
> just for curiosity: how pure e4 applications are usually tested then?

You can still use Maven. But the fact that were was no complaint before
means IMO that the number of application based on e4 is close to 0.


--
Mickael Istria
JBoss, by Red Hat
My blog: http://mickaelistria.wordpress.com
My Tweets: http://twitter.com/mickaelistria
Previous Topic:Managing several versions of the same plugin into one workspace
Next Topic:Tutorials on plugin development
Goto Forum:
  


Current Time: Sun Oct 26 04:41:53 GMT 2014

Powered by FUDForum. Page generated in 0.02117 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software