Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » problem with cross-platform
problem with cross-platform [message #987555] Tue, 27 November 2012 06:56 Go to next message
li kai is currently offline li kai
Messages: 3
Registered: November 2012
Junior Member
i use jubula 1.2.1 stand alone version.
i start AUTAgent at a Linux host at port 60001.
and i write cases in windows ITE,and connecting to and execution on the Linux AUTAgent is ok.
but my project need command line support.so, i use autrun.exe on my windows host, try to start AUT on the remote linux host.but jubula cannot start the aut and report error.log is :
!SESSION 2012-11-27 10:46:37.843 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_18
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=zh_CN
Framework arguments: -application org.eclipse.jubula.app.autrun -a 10.74.165.1 -p 60001 -swing -i uep4xtest_1 -e /datafile/uep4x_version/uitest/cn_4.11.10.P2B4_SP002/setup.sh -w /datafile/uep4x_version/uitest/cn_4.11.10.P2B4_SP002
Command-line arguments: -clean -application org.eclipse.jubula.app.autrun -a 10.74.165.1 -p 60001 -swing -i uep4xtest_1 -e /datafile/uep4x_version/uitest/cn_4.11.10.P2B4_SP002/setup.sh -w /datafile/uep4x_version/uitest/cn_4.11.10.P2B4_SP002

!ENTRY org.eclipse.osgi 2 0 2012-11-27 10:46:49.812
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-27 10:46:49.812
!MESSAGE Bundle org.eclipse.core.net.linux.x86_1.1.200.I20110419-0800 [53] was not resolved.
!SUBENTRY 2 org.eclipse.core.net.linux.x86 2 0 2012-11-27 10:46:49.812
!MESSAGE Platform filter did not match: (& (osgi.os=linux) (osgi.arch=x86))
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-27 10:46:49.812
!MESSAGE Bundle org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.101.v20120109-1504 [82] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.cocoa.macosx.x86_64 2 0 2012-11-27 10:46:49.812
!MESSAGE Platform filter did not match: (& (osgi.ws=cocoa) (osgi.os=macosx) (osgi.arch=x86_64) )
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-27 10:46:49.812
!MESSAGE Bundle org.eclipse.equinox.launcher.gtk.linux.x86_1.1.100.v20110505 [83] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2012-11-27 10:46:49.812
!MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-27 10:46:49.812
!MESSAGE Bundle org.eclipse.equinox.security.macosx_1.100.100.v20100503 [112] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.security.macosx 2 0 2012-11-27 10:46:49.812
!MESSAGE Platform filter did not match: (& (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=x86_64)(osgi.arch=ppc)) )
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-27 10:46:49.812
!MESSAGE Bundle org.eclipse.swt.cocoa.macosx.x86_64_3.7.2.v3740f [179] was not resolved.
!SUBENTRY 2 org.eclipse.swt.cocoa.macosx.x86_64 2 0 2012-11-27 10:46:49.812
!MESSAGE Platform filter did not match: (& (osgi.ws=cocoa) (osgi.os=macosx) (osgi.arch=x86_64) )
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-27 10:46:49.812
!MESSAGE Bundle org.eclipse.swt.gtk.linux.x86_3.7.2.v3740f [180] was not resolved.
!SUBENTRY 2 org.eclipse.swt.gtk.linux.x86 2 0 2012-11-27 10:46:49.812
!MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-27 10:46:49.812
!MESSAGE Bundle org.eclipse.ui.cocoa_1.1.0.I20101109-0800 [188] was not resolved.
!SUBENTRY 2 org.eclipse.ui.cocoa 2 0 2012-11-27 10:46:49.812
!MESSAGE Platform filter did not match: (osgi.ws=cocoa)

!ENTRY org.eclipse.osgi 4 0 2012-11-27 10:46:49.812
!MESSAGE Application error
!STACK 1
java.io.IOException: Cannot run program "/datafile/uep4x_version/uitest/cn_4.11.10.P2B4_SP002/setup.sh": CreateProcess error=3, ϵͳÕҲ»µ½
at java.lang.ProcessBuilder.start(Unknown Source)
at java.lang.Runtime.exec(Unknown Source)
at org.eclipse.jubula.autagent.commands.AbstractStartToolkitAut.executeCommand(AbstractStartToolkitAut.java:198)
at org.eclipse.jubula.autagent.commands.AbstractStartToolkitAut.startAut(AbstractStartToolkitAut.java:90)
at org.eclipse.jubula.app.autrun.AutRunner.run(AutRunner.java:163)
at org.eclipse.jubula.app.autrun.AutRunApplication.start(AutRunApplication.java:374)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
at com.exe4j.runtime.WinLauncher.main(Unknown Source)
Caused by: java.io.IOException: CreateProcess error=3, ϵͳÕҲ»µ½
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.<init>(Unknown Source)
at java.lang.ProcessImpl.start(Unknown Source)
... 25 more



how to solve it?? thanks.
Re: problem with cross-platform [message #987783 is a reply to message #987555] Wed, 28 November 2012 07:32 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Hi,

I'm not sure what's going on with autrun there, but I'm also quite sure you don't need to use autrun. If you are just testing one AUT, then use testexec - it will start the AUT for you using a configuration from within the project. More information on testexec is in the documentation.

HTH,
Alex
Re: problem with cross-platform [message #987795 is a reply to message #987555] Wed, 28 November 2012 08:32 Go to previous messageGo to next message
Achim Loerke is currently offline Achim Loerke
Messages: 349
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

autagent, autrun and of course the AUT are easiest to use when running all on the same machine. If I did understand your setup you are trying to start the AUT via autrun from a windows machine to run on a linux box. That won't work. autrun starts the AUT on the local machine.

- Achim
Re: problem with cross-platform [message #987815 is a reply to message #987795] Wed, 28 November 2012 09:29 Go to previous messageGo to next message
li kai is currently offline li kai
Messages: 3
Registered: November 2012
Junior Member
thanks all.
i start aut(at linux host) via ITE (at windows),and start execute test via ite(win) remotely, all thing is ok.
but via autrun.exe cannot work.my chinese god...

Re: problem with cross-platform [message #988231 is a reply to message #987795] Thu, 29 November 2012 01:33 Go to previous message
li kai is currently offline li kai
Messages: 3
Registered: November 2012
Junior Member
i start testexec follow your replay,but another problem occured:my aut is a little big,when starting ,the aut will unzip many files.when i use testexec - c file.xml,when it connecting the aut,my aut is not started completely.
how to sovle it,thanks.
Previous Topic:Problems with Tab selection by value or index
Next Topic:best way to enter data into data sets? (Problems with data sets))
Goto Forum:
  


Current Time: Tue Oct 21 07:27:45 GMT 2014

Powered by FUDForum. Page generated in 0.01865 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software