Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » rwt standalone rap 1.5 deployed in jboss occror error like Not installing optional component!
rwt standalone rap 1.5 deployed in jboss occror error like Not installing optional component! [message #983868] Wed, 14 November 2012 07:57
Song David is currently offline Song David
Messages: 187
Registered: April 2011
Senior Member
hi,
I desploy rwt 2.0 standalone app to jboss and an error occors;

WARN  [org.jboss.as.ee] (MSC service thread 1-6) JBAS011006: Not installing optional component org.eclipse.rap.rwt.engine.RWTServletContextListener due to exception: java.lang.ClassNotFoundException: org.eclipse.rap.rwt.engine.RWTServletContextListener from [Module "deployment.ROOT.war:main" from Service Module Loader]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120) [jboss-modules.jar:1.1.1.GA]
	at java.lang.Class.forName0(Native Method) [rt.jar:1.7.0_06]
	at java.lang.Class.forName(Class.java:264) [rt.jar:1.7.0_06]
	at org.jboss.as.server.deployment.reflect.DeploymentClassIndex.classIndex(DeploymentClassIndex.java:54) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
	at org.jboss.as.ee.component.deployers.EEModuleConfigurationProcessor.deploy(EEModuleConfigurationProcessor.java:79)
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_06]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_06]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_06]


any help?
thanks
David
Previous Topic:FilteredTree not working correctly for custom TreeViewer
Next Topic:Label SWT.WRAP will not work with RWT.MARKUP_ENABLED
Goto Forum:
  


Current Time: Wed Oct 01 20:37:48 GMT 2014

Powered by FUDForum. Page generated in 0.01864 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software