Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Problem referencing another emf project
Problem referencing another emf project [message #982020] Mon, 12 November 2012 22:08 Go to next message
Eyal Heinemann is currently offline Eyal HeinemannFriend
Messages: 7
Registered: October 2012
Junior Member
Hi again,

I have two emf projects, the first I got an outer package (meaning i cant change it) and another is my own.
The first one has a "MainContainer" item which is usually the object in which the rest take place in.
In my project I need to hold in one of my projects two "MainContainer"s.
So I added in my ecorediag an EDataType that reference the interface of "MainContainer".
Since it's an EDataType I cant create an EReference to it only an EAttribute.
Also when I try to save my object it doesn't save all the data but just writes something as an attribute that can't be parsed. Any advise on the situation?

I tried reading about it and got to something that is "BaseType" but eclipse gives only the option of making the interface the base type so I'm not sure what to do.

Thanks

Re: Problem referencing another emf project [message #982391 is a reply to message #982020] Tue, 13 November 2012 05:12 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 26289
Registered: July 2009
Senior Member
Eyal,

Comments below.

On 12/11/2012 11:08 PM, Eyal Heinemann wrote:
> Hi again,
>
> I have two emf projects, the first I got an outer package (meaning i
> cant change it) and another is my own.
> The first one has a "MainContainer" item which is usually the object
> in which the rest take place in.
> In my project I need to hold in one of my projects two "MainContainer"s.
> So I added in my ecorediag an EDataType that reference the interface
> of "MainContainer".
> Since it's an EDataType I cant create an EReference to it only an
> EAttribute.
Yes. So you really want an EClass? Isn't MainContainer already an EClass?
> Also when I try to save my object it doesn't save all the data but
> just writes something as an attribute that can't be parsed. Any advise
> on the situation?
It needs to be an an EClass.
>
> I tried reading about it and got to something that is "BaseType" but
> eclipse gives only the option of making the interface the base type so
> I'm not sure what to do.
What exactly is MainContainer? Something you hand wrote in Java?
>
> Thanks
>
>
Re: Problem referencing another emf project [message #983079 is a reply to message #982391] Tue, 13 November 2012 16:59 Go to previous messageGo to next message
Eyal Heinemann is currently offline Eyal HeinemannFriend
Messages: 7
Registered: October 2012
Junior Member


The MainContainer is an EClass that came from a different EMF project (what i called the first)
The problem is in order to have it in my new EMF project i can only use it as EDataType.
Is there any way to use it as an EClass?

Thanks again
Re: Problem referencing another emf project [message #983090 is a reply to message #983079] Tue, 13 November 2012 17:11 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 26289
Registered: July 2009
Senior Member
Eyal,

Comments below.

On 13/11/2012 5:59 PM, Eyal Heinemann wrote:
>
>
> The MainContainer is an EClass that came from a different EMF project
> (what i called the first)
> The problem is in order to have it in my new EMF project i can only
> use it as EDataType.
Why?
> Is there any way to use it as an EClass?
Just load the resource containing MainContainer in the editor where you
need it and start using it.
>
> Thanks again
Re: Problem referencing another emf project [message #983331 is a reply to message #983090] Tue, 13 November 2012 21:24 Go to previous messageGo to next message
Eyal Heinemann is currently offline Eyal HeinemannFriend
Messages: 7
Registered: October 2012
Junior Member
Worked Great!!!! thank you so much
BTW - do i need to mark your replay as answer at some way?
Re: Problem referencing another emf project [message #983739 is a reply to message #983331] Wed, 14 November 2012 05:31 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 26289
Registered: July 2009
Senior Member
Eyal,

No, there's no mechanism for marking posts. I guess the last or second
to last post is usually the answer...

On 13/11/2012 10:24 PM, Eyal Heinemann wrote:
> Worked Great!!!! thank you so much
> BTW - do i need to mark your replay as answer at some way?
Previous Topic:[EMF Transaction] Buglist still correct ?
Next Topic:[XSD2Ecore] is removing removing underscore from EEnumLiteral name and not setting literal
Goto Forum:
  


Current Time: Mon Dec 22 17:01:15 GMT 2014

Powered by FUDForum. Page generated in 0.02585 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software