Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Error w/ 1.5 beta Installed
Error w/ 1.5 beta Installed [message #139777] Fri, 06 February 2004 16:48 Go to next message
Eclipse UserFriend
Originally posted by: geoffrobinson.yahoo.com

Hello All,

I was getting a weird error message in Eclipse after I installed the JDK
1.5 beta. It was telling me that the compiler had an error and I should
submit a bug report to Sun, but with no further details were given. And
that is not going to fly with a bug report to Sun. Even with the error
message everything worked normally.

I uninstalled the new JDK and everything is fine. Is anyone else getting
this? Should this be a bug report for Eclipse?

thanks for your time,
Geoff
Re: Error w/ 1.5 beta Installed [message #139921 is a reply to message #139777] Sun, 08 February 2004 09:10 Go to previous messageGo to next message
Johan Compagner is currently offline Johan CompagnerFriend
Messages: 148
Registered: July 2009
Senior Member
for me 1.5 works fine (i am running eclipse on it even with the first
not so public release last year)

i only have problems with my own (Swing/Webstart)applications... :(

johan


Geoff Robinson wrote:
> Hello All,
>
> I was getting a weird error message in Eclipse after I installed the JDK
> 1.5 beta. It was telling me that the compiler had an error and I should
> submit a bug report to Sun, but with no further details were given. And
> that is not going to fly with a bug report to Sun. Even with the error
> message everything worked normally.
>
> I uninstalled the new JDK and everything is fine. Is anyone else getting
> this? Should this be a bug report for Eclipse?
>
> thanks for your time,
> Geoff
>
Re: Error w/ 1.5 beta Installed [message #140129 is a reply to message #139777] Mon, 09 February 2004 10:25 Go to previous messageGo to next message
shmuel siegel is currently offline shmuel siegelFriend
Messages: 75
Registered: July 2009
Member
"Geoff Robinson" <geoffrobinson@yahoo.com> wrote in message
news:c00ggs$v5j$1@eclipse.org...
> Hello All,
>
> I was getting a weird error message in Eclipse after I installed the JDK
> 1.5 beta. It was telling me that the compiler had an error and I should
> submit a bug report to Sun, but with no further details were given.

That is a weird error message. Many people have been begging to be able to
use the JDK compiler. How did you even manage to invoke it? What version of
Eclipse are you using? JDK 1.5 works fine for me for 3.0 M6 on Win2k.


---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.580 / Virus Database: 367 - Release Date: 2/6/2004
Re: Error w/ 1.5 beta Installed [message #140163 is a reply to message #140129] Mon, 09 February 2004 13:14 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: geoffrobinson.yahoo.com

shmuel siegel wrote:

> "Geoff Robinson" <geoffrobinson@yahoo.com> wrote in message
> news:c00ggs$v5j$1@eclipse.org...
> > Hello All,
> >
> > I was getting a weird error message in Eclipse after I installed the JDK
> > 1.5 beta. It was telling me that the compiler had an error and I should
> > submit a bug report to Sun, but with no further details were given.

> That is a weird error message. Many people have been begging to be able to
> use the JDK compiler. How did you even manage to invoke it? What version of
> Eclipse are you using? JDK 1.5 works fine for me for 3.0 M6 on Win2k.


I am running Eclipse 2.1.2 on Windows 2000. I downloaded the new JDK and
then ran Eclipse again. Got the error. Uninstalled and everything worked
fine.

Let me know what you think.

thanks,
Geoff
Re: Error w/ 1.5 beta Installed [message #140444 is a reply to message #140163] Mon, 09 February 2004 17:08 Go to previous messageGo to next message
Darin Swanson is currently offline Darin SwansonFriend
Messages: 2386
Registered: July 2009
Senior Member
Sounds to me like Geoff was using the 1.5 beta to run Eclipse but that has
no impact on the compiler used within Eclipse...it is always the internal
Eclipse compiler.
You can disable the Java builder for a particular project and set up an Ant
build to use the 1.5 compiler.
See the project properties and the Builders page.

HTH
Darins

"Geoff Robinson" <geoffrobinson@yahoo.com> wrote in message
news:c0814d$2aa$1@eclipse.org...
> shmuel siegel wrote:
>
> > "Geoff Robinson" <geoffrobinson@yahoo.com> wrote in message
> > news:c00ggs$v5j$1@eclipse.org...
> > > Hello All,
> > >
> > > I was getting a weird error message in Eclipse after I installed the
JDK
> > > 1.5 beta. It was telling me that the compiler had an error and I
should
> > > submit a bug report to Sun, but with no further details were given.
>
> > That is a weird error message. Many people have been begging to be able
to
> > use the JDK compiler. How did you even manage to invoke it? What version
of
> > Eclipse are you using? JDK 1.5 works fine for me for 3.0 M6 on Win2k.
>
>
> I am running Eclipse 2.1.2 on Windows 2000. I downloaded the new JDK and
> then ran Eclipse again. Got the error. Uninstalled and everything worked
> fine.
>
> Let me know what you think.
>
> thanks,
> Geoff
>
Re: Error w/ 1.5 beta Installed [message #141147 is a reply to message #140444] Wed, 11 February 2004 21:47 Go to previous messageGo to next message
shmuel siegel is currently offline shmuel siegelFriend
Messages: 75
Registered: July 2009
Member
"Darin Swanson" <Darin_Swanson@us.ibm.com> wrote in message
news:c08ef0$kpf$1@eclipse.org...
> Sounds to me like Geoff was using the 1.5 beta to run Eclipse but that has
> no impact on the compiler used within Eclipse...it is always the internal
> Eclipse compiler.
> You can disable the Java builder for a particular project and set up an
Ant
> build to use the 1.5 compiler.
> See the project properties and the Builders page.
>
> HTH
> Darins
This I know which is why I found his error message so strange. Eclipse
shouldn't be saying that there was a compiler error that should be submitted
to Sun.
Re: Error w/ 1.5 beta Installed [message #141177 is a reply to message #141147] Wed, 11 February 2004 22:01 Go to previous message
Darin Swanson is currently offline Darin SwansonFriend
Messages: 2386
Registered: July 2009
Senior Member
"shmuel siegel" <hard2@writeme.com> wrote in message
news:c0e7os$lhf$1@eclipse.org...
>
> "Darin Swanson" <Darin_Swanson@us.ibm.com> wrote in message
> news:c08ef0$kpf$1@eclipse.org...
> > Sounds to me like Geoff was using the 1.5 beta to run Eclipse but that
has
> > no impact on the compiler used within Eclipse...it is always the
internal
> > Eclipse compiler.
> > You can disable the Java builder for a particular project and set up an
> Ant
> > build to use the 1.5 compiler.
> > See the project properties and the Builders page.
> >
> > HTH
> > Darins
> This I know which is why I found his error message so strange. Eclipse
> shouldn't be saying that there was a compiler error that should be
submitted
> to Sun.
>
>
Seeing the full error message may help
Previous Topic:[CodeFormatter] Enable Comment Formatting
Next Topic:How to change cursor in Java editor
Goto Forum:
  


Current Time: Thu Nov 27 08:44:39 GMT 2014

Powered by FUDForum. Page generated in 0.03090 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software