Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » an error when generate gmfgen model from gmfmap model
an error when generate gmfgen model from gmfmap model [message #135807] Wed, 13 June 2007 15:30 Go to next message
Eclipse User
Originally posted by: hanzhaogang.gmail.com

when i generate gmfgen model from my gmfmap model,
an really strange error comes up. it writes
"An internal error occurred during: "Create generator model..."."
and the event details said that:(it seems that the gmf can't find my ecore
model, or ,the package in my ecore model)(the error pickture is in the
appendence):


java.lang.IllegalStateException: Can't find genPackage for
org.eclipse.emf.ecore.impl.EPackageImpl@1a37b1 (name: resourcepackage)
(nsURI: http:///vpml/resourcepackage.ecore, nsPrefix: vpml.resourcepackage)
at
org.eclipse.gmf.internal.bridge.genmodel.GenModelMatcher.fin dGenClass(GenModelMatcher.java:74)
at
org.eclipse.gmf.internal.bridge.genmodel.DiagramGenModelTran sformer.findGenClass(DiagramGenModelTransformer.java:716)
at
org.eclipse.gmf.internal.bridge.genmodel.DiagramGenModelTran sformer.process(DiagramGenModelTransformer.java:249)
at
org.eclipse.gmf.internal.bridge.genmodel.MappingTransformer. transform(MappingTransformer.java:30)
at
org.eclipse.gmf.internal.codegen.popup.actions.TransformToGe nModelOperation$2.process(TransformToGenModelOperation.java: 341)
at
org.eclipse.gmf.internal.codegen.popup.actions.TransformToGe nModelOperation$1.run(TransformToGenModelOperation.java:252)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)






  • Attachment: error.JPG
    (Size: 95.36KB, Downloaded 39 times)
Re: an error when generate gmfgen model from gmfmap model [message #136661 is a reply to message #135807] Sat, 16 June 2007 03:14 Go to previous messageGo to next message
Eclipse User
Originally posted by: hanzhaogang.gmail.com

is anyone knows that?
"hanzhaogang" <hanzhaogang@gmail.com> ะด
Re: an error when generate gmfgen model from gmfmap model [message #139567 is a reply to message #136661] Tue, 26 June 2007 17:43 Go to previous message
Alexander Shatalin is currently offline Alexander Shatalin
Messages: 2928
Registered: July 2009
Senior Member
Hello hanzhaogang,

I found following thread by googling this exception: http://dev.eclipse.org/newslists/news.eclipse.modeling.gmf/m sg01836.html

Try it - looks like you have outdated genmodel..

-----------------
Alex Shatalin
Previous Topic:Problem with GMF
Next Topic:ClassCastException in NavigatorContentProvider
Goto Forum:
  


Current Time: Sun Sep 21 10:13:19 GMT 2014

Powered by FUDForum. Page generated in 0.03079 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software