Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Toolbar corrupted: how to reset?
Toolbar corrupted: how to reset? [message #954727] Tue, 23 October 2012 07:40 Go to next message
Mauro Molinari is currently offline Mauro Molinari
Messages: 278
Registered: July 2009
Senior Member
Hello all,
I have a problem with Juno.
My toolbar got in some way "corrupted": that is, many buttons are
missing and the toolbar is crowded with separators with empty space
between them.

See a screenshot here:
https://www.dropbox.com/s/cg6ncskngz19wvy/juno-screenshot.png

I don't know how such a problem could occur (never happened with Eclipse
3.x). My suspect is that it was caused by many keybinding conflicts that
were present in Juno, however now I upgraded all the plugins to Juno
SR-1 but the problem persists.

I can't find a way to "reset" the toolbar: there's the menu function to
reset the perspective, but this seems to have no effect on the toolbar.

Any help would be greatly appreciated.

Mauro.
Re: Toolbar corrupted: how to reset? [message #954737 is a reply to message #954727] Tue, 23 October 2012 07:52 Go to previous messageGo to next message
Mauro Molinari is currently offline Mauro Molinari
Messages: 278
Registered: July 2009
Senior Member
Il 23/10/2012 09:40, Mauro Molinari ha scritto:
> I can't find a way to "reset" the toolbar: there's the menu function to
> reset the perspective, but this seems to have no effect on the toolbar.

This bug is related to the problem that "reset perspective" does not
reset the toolbar:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=383569

However I still need a workaround to reset my toolbar...

Any help would be greatly appreciated.

Mauro.
Re: Toolbar corrupted: how to reset? [message #961942 is a reply to message #954727] Sun, 28 October 2012 18:37 Go to previous messageGo to next message
Mauro Molinari is currently offline Mauro Molinari
Messages: 278
Registered: July 2009
Senior Member
Il 23/10/2012 09:40, Mauro Molinari ha scritto:
> See a screenshot here:
> https://www.dropbox.com/s/cg6ncskngz19wvy/juno-screenshot.png

Can anybody explain what could have caused my situation and how I can
fix it?

Thanks,
Mauro.
Re: Toolbar corrupted: how to reset? [message #962208 is a reply to message #961942] Sun, 28 October 2012 23:43 Go to previous messageGo to next message
Kyle Fox is currently offline Kyle Fox
Messages: 3
Registered: July 2010
Junior Member
I'm having the same problem. =(

After taking the latest Juno updates via the Help >> Check for Updates menu, I started having problems switching between tabs. I realized the issue was related to the debug perspective, and therefore, tried to reset it. After the reset, I ended up with a mixed up toolbar that I can't seem to repair.

As a side-note, there does appear to be a problem with the debug perspective for me. When I open eclipse in the Java EE perspective, I'm able to switch between tabs (files) with no lag. Immediately after opening the debug perspective (even if I switch back to Java EE), I get a 5-10 second lag switching tabs. The only resolution is to close and re-open eclipse.

I'm not sure if the issues are related.
Re: Toolbar corrupted: how to reset? [message #962280 is a reply to message #954727] Mon, 29 October 2012 01:05 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 348
Registered: July 2009
Location: Japan
Senior Member
Eclipse Community Forums: Eclipse 4 ยป Must have screwed up

I'm using a way of removing workspace/.metadata/.plugins/org.eclipse.e4.workbench/workbench.xmi to reset workbench ui. (there is no way to reset toolbars only)
Re: Toolbar corrupted: how to reset? [message #965825 is a reply to message #962208] Wed, 31 October 2012 14:29 Go to previous messageGo to next message
Mauro Molinari is currently offline Mauro Molinari
Messages: 278
Registered: July 2009
Senior Member
Il 29/10/2012 00:43, Kyle Fox ha scritto:
> As a side-note, there does appear to be a problem with the debug
> perspective for me. When I open eclipse in the Java EE perspective, I'm
> able to switch between tabs (files) with no lag. Immediately after
> opening the debug perspective (even if I switch back to Java EE), I get
> a 5-10 second lag switching tabs. The only resolution is to close and
> re-open eclipse.

Take a look at https://bugs.eclipse.org/bugs/show_bug.cgi?id=385272 and
related bugs.

Mauro.
Re: Toolbar corrupted: how to reset? [message #965882 is a reply to message #962280] Wed, 31 October 2012 15:20 Go to previous message
Mauro Molinari is currently offline Mauro Molinari
Messages: 278
Registered: July 2009
Senior Member
Il 29/10/2012 02:05, Toshihiro Izumi ha scritto:
> I'm using a way of removing
> workspace/.metadata/.plugins/org.eclipse.e4.workbench/workbench.xmi to
> reset workbench ui. (there is no way to reset toolbars only)

Thanks for the hint. However, even after deleting the workbench.xmi file
I still have toolbars with many "holes" (i.e.: missing buttons).

Is it normal?

Mauro.
Previous Topic:[expressions] toolbar dynamic contribution and visibleWhen expression
Next Topic:Can't recover offscreen windows
Goto Forum:
  


Current Time: Wed Oct 01 16:20:39 GMT 2014

Powered by FUDForum. Page generated in 0.09038 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software