Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » Install Error - UML Designer BeoNetwords in Indigo(Can't Install UML Designer in Indigo - Errors)
Install Error - UML Designer BeoNetwords in Indigo [message #953845] Mon, 22 October 2012 15:27 Go to next message
Alex Kerezy is currently offline Alex KerezyFriend
Messages: 3
Registered: October 2012
Junior Member
Hi,
I am new to the eclipse framework/platform and .....well..... I can't say I have much good to say about my experiences.

I want to create a component model and corresponding class diagrams. I installed Version: Indigo Service Release 2 Build id: 20120216-1857 - currently installed.

I am trying to install the UML Designer (Indigo version) 1.4 and I get a bunch of errors shown below.

Any Help Would be GREATLY Appreciated!!

Alex

Cannot complete the install because of a conflicting dependency.
Software being installed: UML Designer (based on Obeo Designer) 1.4.0.201208281448 (org.obeonetwork.dsl.feature.uml2.feature.group 1.4.0.201208281448)
Software currently installed: Eclipse Modeling Tools 1.4.2.20120213-0813 (epp.package.modeling 1.4.2.20120213-0813)
Only one of the following can be installed at once:
Acceleo Ecore Module Runtime Plug-in 1.1.1.201206051542 (org.eclipse.emf.eef.codegen.ecore 1.1.1.201206051542)
Acceleo Ecore Module Runtime Plug-in 1.0.0.v20110608-0819 (org.eclipse.emf.eef.codegen.ecore 1.0.0.v20110608-0819)
Acceleo Ecore Module Runtime Plug-in 1.0.1.v20110912-0930 (org.eclipse.emf.eef.codegen.ecore 1.0.1.v20110912-0930)
Acceleo Ecore Module Runtime Plug-in 1.0.2.v20120216-1513 (org.eclipse.emf.eef.codegen.ecore 1.0.2.v20120216-1513)
Cannot satisfy dependency:
From: Eclipse Modeling Tools 1.4.2.20120213-0813 (epp.package.modeling 1.4.2.20120213-0813)
To: org.eclipse.epp.package.modeling.feature.feature.group [1.4.2.20120213-0813]
Cannot satisfy dependency:
From: Obeo Designer 6.0.2.201208210959 (fr.obeo.dsl.feature.designer.architect.feature.group 6.0.2.201208210959)
To: org.eclipse.emf.eef.sdk-feature.feature.group [1.1.0,2.0.0)
Cannot satisfy dependency:
From: Extended Editing Framework - EMF Edit generation using Acceleo 1.1.1.201206051542 (org.eclipse.emf.eef.codegen.ecore-feature.feature.group 1.1.1.201206051542)
To: org.eclipse.emf.eef.codegen.ecore [1.1.1.201206051542]
Cannot satisfy dependency:
From: Extended Editing Framework - EMF Edit generation using Acceleo 1.0.0.v20110608-0819 (org.eclipse.emf.eef.codegen.ecore.feature.group 1.0.0.v20110608-0819)
To: org.eclipse.emf.eef.codegen.ecore [1.0.0.v20110608-0819]
Cannot satisfy dependency:
From: Extended Editing Framework - EMF Edit generation using Acceleo 1.0.1.v20110912-0930 (org.eclipse.emf.eef.codegen.ecore.feature.group 1.0.1.v20110912-0930)
To: org.eclipse.emf.eef.codegen.ecore [1.0.1.v20110912-0930]
Cannot satisfy dependency:
From: Extended Editing Framework - EMF Edit generation using Acceleo 1.0.2.v20120216-1513 (org.eclipse.emf.eef.codegen.ecore.feature.group 1.0.2.v20120216-1513)
To: org.eclipse.emf.eef.codegen.ecore [1.0.2.v20120216-1513]
Cannot satisfy dependency:
From: Extended Editing Framework - SDK 1.1.1.201206051542 (org.eclipse.emf.eef.sdk-feature.feature.group 1.1.1.201206051542)
To: org.eclipse.emf.eef.codegen.ecore-feature.feature.group [1.1.1.201206051542]
Cannot satisfy dependency:
From: EPP Modeling Feature 1.4.2.20120213-0813 (org.eclipse.epp.package.modeling.feature.feature.group 1.4.2.20120213-0813)
To: org.eclipse.emf.eef.codegen.ecore.feature.group 0.0.0
Cannot satisfy dependency:
From: UML Designer (based on Obeo Designer) 1.4.0.201208281448 (org.obeonetwork.dsl.feature.uml2.feature.group 1.4.0.201208281448)
To: fr.obeo.dsl.feature.designer.architect.feature.group 6.0.0

Re: Install Error - UML Designer BeoNetwords in Indigo [message #953950 is a reply to message #953845] Mon, 22 October 2012 17:09 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4155
Registered: July 2009
Senior Member
Hi

You are using a proprietary product based upon Eclipse. The problems are
clearly associated with that product. Please consult the vendor.

Regards

Ed Willink


On 22/10/2012 17:47, Alex Kerezy wrote:
> Hi,
> I am new to the eclipse framework/platform and .....well..... I can't
> say I have much good to say about my experiences.
>
> I want to create a component model and corresponding class diagrams. I
> installed Version: Indigo Service Release 2 Build id: 20120216-1857 -
> currently installed.
> I am trying to install the UML Designer (Indigo version) 1.4 and I get
> a bunch of errors shown below.
>
> Any Help Would be GREATLY Appreciated!!
>
> Alex
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: UML Designer (based on Obeo Designer)
> 1.4.0.201208281448 (org.obeonetwork.dsl.feature.uml2.feature.group
> 1.4.0.201208281448)
> Software currently installed: Eclipse Modeling Tools
> 1.4.2.20120213-0813 (epp.package.modeling 1.4.2.20120213-0813)
> Only one of the following can be installed at once: Acceleo Ecore
> Module Runtime Plug-in 1.1.1.201206051542
> (org.eclipse.emf.eef.codegen.ecore 1.1.1.201206051542)
> Acceleo Ecore Module Runtime Plug-in 1.0.0.v20110608-0819
> (org.eclipse.emf.eef.codegen.ecore 1.0.0.v20110608-0819)
> Acceleo Ecore Module Runtime Plug-in 1.0.1.v20110912-0930
> (org.eclipse.emf.eef.codegen.ecore 1.0.1.v20110912-0930)
> Acceleo Ecore Module Runtime Plug-in 1.0.2.v20120216-1513
> (org.eclipse.emf.eef.codegen.ecore 1.0.2.v20120216-1513)
> Cannot satisfy dependency:
> From: Eclipse Modeling Tools 1.4.2.20120213-0813
> (epp.package.modeling 1.4.2.20120213-0813)
> To: org.eclipse.epp.package.modeling.feature.feature.group
> [1.4.2.20120213-0813]
> Cannot satisfy dependency:
> From: Obeo Designer 6.0.2.201208210959
> (fr.obeo.dsl.feature.designer.architect.feature.group 6.0.2.201208210959)
> To: org.eclipse.emf.eef.sdk-feature.feature.group [1.1.0,2.0.0)
> Cannot satisfy dependency:
> From: Extended Editing Framework - EMF Edit generation using
> Acceleo 1.1.1.201206051542
> (org.eclipse.emf.eef.codegen.ecore-feature.feature.group
> 1.1.1.201206051542)
> To: org.eclipse.emf.eef.codegen.ecore [1.1.1.201206051542]
> Cannot satisfy dependency:
> From: Extended Editing Framework - EMF Edit generation using
> Acceleo 1.0.0.v20110608-0819
> (org.eclipse.emf.eef.codegen.ecore.feature.group 1.0.0.v20110608-0819)
> To: org.eclipse.emf.eef.codegen.ecore [1.0.0.v20110608-0819]
> Cannot satisfy dependency:
> From: Extended Editing Framework - EMF Edit generation using
> Acceleo 1.0.1.v20110912-0930
> (org.eclipse.emf.eef.codegen.ecore.feature.group 1.0.1.v20110912-0930)
> To: org.eclipse.emf.eef.codegen.ecore [1.0.1.v20110912-0930]
> Cannot satisfy dependency:
> From: Extended Editing Framework - EMF Edit generation using
> Acceleo 1.0.2.v20120216-1513
> (org.eclipse.emf.eef.codegen.ecore.feature.group 1.0.2.v20120216-1513)
> To: org.eclipse.emf.eef.codegen.ecore [1.0.2.v20120216-1513]
> Cannot satisfy dependency:
> From: Extended Editing Framework - SDK 1.1.1.201206051542
> (org.eclipse.emf.eef.sdk-feature.feature.group 1.1.1.201206051542)
> To: org.eclipse.emf.eef.codegen.ecore-feature.feature.group
> [1.1.1.201206051542]
> Cannot satisfy dependency:
> From: EPP Modeling Feature 1.4.2.20120213-0813
> (org.eclipse.epp.package.modeling.feature.feature.group
> 1.4.2.20120213-0813)
> To: org.eclipse.emf.eef.codegen.ecore.feature.group 0.0.0
> Cannot satisfy dependency:
> From: UML Designer (based on Obeo Designer) 1.4.0.201208281448
> (org.obeonetwork.dsl.feature.uml2.feature.group 1.4.0.201208281448)
> To: fr.obeo.dsl.feature.designer.architect.feature.group 6.0.0
>
>
Re: Install Error - UML Designer BeoNetwords in Indigo [message #954197 is a reply to message #953950] Mon, 22 October 2012 21:29 Go to previous messageGo to next message
Alex Kerezy is currently offline Alex KerezyFriend
Messages: 3
Registered: October 2012
Junior Member
Thanks for the reply,
Uhhhh..... is there an Eclipse 'preferred'/'approved' or 'native' UML modeling plugin or product?
Thanks
Alex
Re: Install Error - UML Designer BeoNetwords in Indigo [message #954732 is a reply to message #954197] Tue, 23 October 2012 07:47 Go to previous message
Peter  is currently offline Peter Friend
Messages: 85
Registered: July 2009
Member
Have a look at http://www.eclipse.org/modeling/mdt/papyrus/

Am 22.10.2012 23:29, schrieb Alex Kerezy:
> Thanks for the reply,
> Uhhhh..... is there an Eclipse 'preferred'/'approved' or 'native' UML
> modeling plugin or product?
> Thanks
> Alex
Previous Topic:Please help ( deployment diagram)
Next Topic:How to visualize graphically .UML file
Goto Forum:
  


Current Time: Sat Nov 29 10:11:34 GMT 2014

Powered by FUDForum. Page generated in 0.01705 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software