Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Serving Eclipse version-specific features from a single p2 update site?
Serving Eclipse version-specific features from a single p2 update site? [message #133361] Thu, 18 June 2009 18:08
Jason Parekh is currently offline Jason Parekh
Messages: 1
Registered: July 2009
Junior Member
Hey guys,

We have different compiled bits of our Eclipse plugin for each version of
Eclipse (we used internal APIs that changed across versions). Is there a
clean way of giving users a single update site URL which would only show
features applicable to the user's version of Eclipse?

I read somewhere that P2 hits content/artifacts first, and in its absence
falls back on site.xml. Given this, it seems we can achieve this single
URL to separate 3.3 from 3.4+3.5. However, users of 3.4 and 3.5 would see
both versions of our features. Is there any metadata I could stick on the
IU to have the non-applicable features be omitted from P2 UI?

Thanks,
jason
Previous Topic:finding fragment contributing to extension point how?
Next Topic:Issues importing package in code but not in manifest
Goto Forum:
  


Current Time: Sat Sep 20 04:05:25 GMT 2014

Powered by FUDForum. Page generated in 0.01498 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software