Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » MS Excel data connection to BIRT report not working => SOLVED!!(MS Excel with BIRT report data connection)
MS Excel data connection to BIRT report not working => SOLVED!! [message #938069] Tue, 09 October 2012 10:14 Go to next message
ton oostveen is currently offline ton oostveen
Messages: 3
Registered: October 2012
Junior Member
I have a BIRT 3.7.1 report which returns about 7000 records from an Oracle database into a simple html table.
This reports takes about 1 minute and works within a web browser.

I can create a data link in a new MS Excel 2010 worksheet to this report.
Altough when I refresh this report I only get:

Exception	
	
	Show Exception Stack Trace
	Hide Exception Stack Trace
	Stack Trace:
	
Parameter	
Close	
	
There are no parameters for this report.	
	
	
Processing, please wait ... 	
Progress Bar Image	


The data never arrives.

I also tried another way to automate this report with wget.

wget "BIRT report URL" -O test.html

This way I only get de javascript / html code, but no data.


Any tips welcome to get this working..

[Updated on: Thu, 11 October 2012 03:34]

Report message to a moderator

Re: MS Excel data connection to BIRT report not working [message #938299 is a reply to message #938069] Tue, 09 October 2012 14:52 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

What url are you using? try /preview instead of /frameset

Jason
Re: MS Excel data connection to BIRT report not working [message #938986 is a reply to message #938299] Wed, 10 October 2012 06:24 Go to previous messageGo to next message
ton oostveen is currently offline ton oostveen
Messages: 3
Registered: October 2012
Junior Member
Not the frameset, to be exact:

machine_name:8080/birt/run?__report=report/baan/baan_prod_service_dashboard_ret_data.rptdesign
Re: MS Excel data connection to BIRT report not working [message #939847 is a reply to message #938986] Thu, 11 October 2012 00:54 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Can you try /preview? The run mapping still uses AJAX, where the preview mapping does not.

Jason
Re: MS Excel data connection to BIRT report not working [message #939970 is a reply to message #939847] Thu, 11 October 2012 03:33 Go to previous messageGo to next message
ton oostveen is currently offline ton oostveen
Messages: 3
Registered: October 2012
Junior Member
YES, this works!!

Thanks, I was getting desperate looking for a solution, never had seen this '/preview' in the many hits I found on this subject.

If there is any 'Thanx' button on this forum I would instantly hit it Wink
Re: MS Excel data connection to BIRT report not working [message #941652 is a reply to message #939970] Fri, 12 October 2012 14:55 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

I am glad it is working for you.

Jason
Previous Topic:Show/Hide Chart with Radio Button
Next Topic:New User :)
Goto Forum:
  


Current Time: Fri Aug 29 08:17:39 EDT 2014

Powered by FUDForum. Page generated in 0.01606 seconds