Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Content Assist doesn't work 100% for tagx
Content Assist doesn't work 100% for tagx [message #935960] Sun, 07 October 2012 10:09 Go to next message
Brian Sanders is currently offline Brian Sanders
Messages: 2
Registered: October 2012
Junior Member
I recently started using Spring Roo. When creating the web UI, tagx/jspx files are generated. If I open the jspx file using the JSP editor, the content assist acknowledges all declared namespaces/tags. However, the same does not hold true for tagx files (except for jsp). If I rename the tagx file with a jspx extension, I see all the namespaces. Is there a reason that tagx files are treated differently? Aside from renaming the file (which would get rather cumbersome), is there any sort of workaround? This affects Indigo & Juno. One other issue which actually applies to both file types... there are certain tags (ie. jsp:output) which do not appear in the content list. Is there a reason for that?
Re: Content Assist doesn't work 100% for tagx [message #936568 is a reply to message #935960] Mon, 08 October 2012 01:42 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2253
Registered: July 2009
Senior Member
Can you open a bug report, and attach an example?

---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Content Assist doesn't work 100% for tagx [message #936893 is a reply to message #936568] Mon, 08 October 2012 08:59 Go to previous messageGo to next message
Brian Sanders is currently offline Brian Sanders
Messages: 2
Registered: October 2012
Junior Member
Sure. I'm assuming I go to bugs.eclipse.org? Where should I file it (classification)? What do you mean by "attach an example"? Like, a screenshot?
Re: Content Assist doesn't work 100% for tagx [message #948148 is a reply to message #936893] Wed, 17 October 2012 16:11 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2253
Registered: July 2009
Senior Member
Yes, https://bugs.eclipse.org/bugs/enter_bug.cgi?product=WTP Source Editing&component=jst.jsp and the tagx file itself.

---
Nitin Dahyabhai
Eclipse WTP, IBM

[Updated on: Wed, 17 October 2012 16:12]

Report message to a moderator

Previous Topic:use emf model to create SOAP Request
Next Topic:Problem generating Axis2 web service client - Element QName is null for TestServiceTestException
Goto Forum:
  


Current Time: Mon Sep 01 10:02:13 EDT 2014

Powered by FUDForum. Page generated in 0.03393 seconds