Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » TPTP idle(unable to undersand servicelog messages)
TPTP idle [message #929141] Mon, 01 October 2012 08:54 Go to next message
Jean Le Fur is currently offline Jean Le Fur
Messages: 5
Registered: September 2012
Junior Member
Hello,
I try to profile an application with TPTP. The profiler starts ok however, it soon becomes idle.
The servicelog.log display tenths of message of the kind below.
is there any direction where I can search for the problem ?
sincerely,
Jean

message form servicelog.log :
=============================
<CommonBaseEvent creationTime="2012-10-01T08:42:18.234000Z" globalInstanceId="AA62FE87CD3C44B0A9FA566BCAC02938" msg="Socket: Failed to send data on connection ID 5014" severity="50" version="1.0.1">
<sourceComponentId component="AgentController" componentIdType="TPTPComponent" executionEnvironment=".\SocketListener.c, line 1458" instanceId="1000" location="d7400_jlefur" locationType="IPV4" processId="5292" subComponent="Socket TL" threadId="4712" componentType="Eclipse_TPTP"/>
<situation categoryName="ReportSituation">
<situationType xmlns:xsi="www.w3.org/2001/XMLSchema-instance" xsi:type="ReportSituation" reasoningScope="INTERNAL" reportCategory="LOG"/>
</situation>
</CommonBaseEvent>
Re: TPTP idle [message #929275 is a reply to message #929141] Mon, 01 October 2012 10:34 Go to previous message
Heiner Westphal is currently offline Heiner Westphal
Messages: 18
Registered: July 2009
Junior Member
Hello Jean,

looks like the Agent Controller cannot send its data back to eclipe.

Does the log contain any hint, which port is used by "connection ID
5014"? This would be the one to open firewall wise.

If not, look into the service config in
$TPTP_DIR/config/serviceconfig.xml.
From your log I guess the disfunctional port is configured like this:

<TransportLayer loadlib="socketTL" type="TPTP_SOCKET">
....

This may be a firewall issue.


Hope this helps a bit,

Heiner

Am 01.10.2012 10:54, schrieb Jean Le Fur:
> Hello,
> I try to profile an application with TPTP. The profiler starts ok
> however, it soon becomes idle.
> The servicelog.log display tenths of message of the kind below.
> is there any direction where I can search for the problem ?
> sincerely,
> Jean
>
> message form servicelog.log :
> =============================
> <CommonBaseEvent creationTime="2012-10-01T08:42:18.234000Z"
> globalInstanceId="AA62FE87CD3C44B0A9FA566BCAC02938" msg="Socket: Failed
> to send data on connection ID 5014" severity="50" version="1.0.1">
> <sourceComponentId component="AgentController"
> componentIdType="TPTPComponent"
> executionEnvironment=".\SocketListener.c, line 1458" instanceId="1000"
> location="d7400_jlefur" locationType="IPV4" processId="5292"
> subComponent="Socket TL" threadId="4712" componentType="Eclipse_TPTP"/>
> <situation categoryName="ReportSituation">
> <situationType xmlns:xsi="www.w3.org/2001/XMLSchema-instance"
> xsi:type="ReportSituation" reasoningScope="INTERNAL" reportCategory="LOG"/>
> </situation>
> </CommonBaseEvent>
Previous Topic:string index error when launching app within TPTP profiler
Next Topic:Error is throwing while run the test classes, Run as JUnit
Goto Forum:
  


Current Time: Sun Oct 26 07:46:15 GMT 2014

Powered by FUDForum. Page generated in 0.01588 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software