Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » AJDT 2.2.1 with STS 3.0 on Eclipse 4.2/3.8: AspectJ Load-Time Weaving Application
AJDT 2.2.1 with STS 3.0 on Eclipse 4.2/3.8: AspectJ Load-Time Weaving Application [message #928028] Sun, 30 September 2012 07:52 Go to next message
Holger Brands is currently offline Holger Brands
Messages: 11
Registered: September 2012
Junior Member
Dear Community,

are there any known problems with STS 3.0, AJDT 2.2.1 on Eclipse Juno (3.8 or 4.2)?

An "AspectJ load-time Weaving App" launch configuration that worked in Eclipse Helios wirh STS 2.5.0 and AJDT 2.1.1 does not work anymore on Eclipse Juno 4.2 or 3.8. I'm running on Win 7 with JDK 6u35.

Here is the error I get on the console when trying to launch the configuration:
Error occurred during initialization of VM
java.lang.IllegalStateException: recursive invocation
	at java.lang.ClassLoader.initSystemClassLoader(ClassLoader.java:1336)
	at java.lang.ClassLoader.getSystemClassLoader(ClassLoader.java:1319)
	at sun.security.jca.ProviderConfig$1.run(ProviderConfig.java:64)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.security.jca.ProviderConfig.getLock(ProviderConfig.java:62)
	at sun.security.jca.ProviderConfig.getProvider(ProviderConfig.java:187)
	at sun.security.jca.ProviderList.getProvider(ProviderList.java:215)
	at sun.security.jca.ProviderList.getService(ProviderList.java:313)
	at sun.security.jca.GetInstance.getInstance(GetInstance.java:140)
	at java.security.cert.CertificateFactory.getInstance(CertificateFactory.java:148)
	at sun.security.pkcs.PKCS7.parseSignedData(PKCS7.java:244)
	at sun.security.pkcs.PKCS7.parse(PKCS7.java:141)
	at sun.security.pkcs.PKCS7.parse(PKCS7.java:110)
	at sun.security.pkcs.PKCS7.<init>(PKCS7.java:92)
	at sun.security.util.SignatureFileVerifier.<init>(SignatureFileVerifier.java:80)
	at java.util.jar.JarVerifier.processEntry(JarVerifier.java:267)
	at java.util.jar.JarVerifier.update(JarVerifier.java:199)
	at java.util.jar.JarFile.initializeVerifier(JarFile.java:323)
	at java.util.jar.JarFile.getInputStream(JarFile.java:388)
	at sun.misc.URLClassPath$JarLoader$2.getInputStream(URLClassPath.java:692)
	at sun.misc.Resource.cachedInputStream(Resource.java:61)
	at sun.misc.Resource.getByteBuffer(Resource.java:144)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:256)
	at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:247)
	at java.lang.SystemClassLoaderAction.run(ClassLoader.java:2071)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.lang.ClassLoader.initSystemClassLoader(ClassLoader.java:1344)
	at java.lang.ClassLoader.getSystemClassLoader(ClassLoader.java:1319)#


In the log file of the workspace I see this exception:

!MESSAGE Servers does not exist
!STACK 1
Java Model Exception: Java Model Status [Servers does not exist]
	at org.eclipse.jdt.internal.core.JavaElement.newNotPresentException(JavaElement.java:495)
	at org.eclipse.jdt.internal.core.JavaModelManager.getPerProjectInfoCheckExistence(JavaModelManager.java:2285)
	at org.eclipse.jdt.internal.core.JavaProject.getPerProjectInfo(JavaProject.java:1907)
	at org.eclipse.jdt.internal.core.JavaProject.getOutputLocation(JavaProject.java:1734)
	at org.eclipse.jdt.internal.launching.RuntimeClasspathEntry.getLocation(RuntimeClasspathEntry.java:435)
	at org.eclipse.ajdt.internal.launching.LTWApplicationLaunchConfigurationDelegate.generateAOPConfigFiles(LTWApplicationLaunchConfigurationDelegate.java:164)
	at org.eclipse.ajdt.internal.launching.LTWApplicationLaunchConfigurationDelegate.launch(LTWApplicationLaunchConfigurationDelegate.java:75)
	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:855)
	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:704)
	at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1047)
	at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1251)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)


Any clues what's going on?

Please let me know if you need more information.

Thanks,
Holger
Re: AJDT 2.2.1 with STS 3.0 on Eclipse 4.2/3.8: AspectJ Load-Time Weaving Application [message #928914 is a reply to message #928028] Mon, 01 October 2012 04:19 Go to previous messageGo to next message
Andrew Eisenberg is currently offline Andrew Eisenberg
Messages: 369
Registered: July 2009
Senior Member
I think I already answered your question here:

http://forum.springsource.org/showthread.php?130611-STS-3-0-on-Eclipse-4-2-3-8-AspectJ-Load-Time-Weaving-Application

But just to be sure, this is a bug that is fixed in AJDT 2.2.1. Please update to the latest release. Update site is here:

http://download.eclipse.org/tools/ajdt/42/update/
Re: AJDT 2.2.1 with STS 3.0 on Eclipse 4.2/3.8: AspectJ Load-Time Weaving Application [message #929595 is a reply to message #928914] Mon, 01 October 2012 15:40 Go to previous message
Holger Brands is currently offline Holger Brands
Messages: 11
Registered: September 2012
Junior Member
Yes, AJDT version 2.2.1.e42x-RELEASE-20120921-1400
fixed the problem!

Many thanks,
Holger
Previous Topic:AJDT slooooow/hanging on clean rebuild
Next Topic:Convert to AspectJ project menu missing
Goto Forum:
  


Current Time: Sat Oct 25 22:06:49 GMT 2014

Powered by FUDForum. Page generated in 0.04223 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software