Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » eclipse won't launch (error log attached)
eclipse won't launch (error log attached) [message #917052] Wed, 19 September 2012 15:23 Go to next message
T McI is currently offline T McI
Messages: 1
Registered: September 2012
Junior Member
Hi,
I run Eclipse Indigo on Ubuntu 12.04. In order to start developing Android apps, I read that you should install Sun Java rather than OpenJava.
I removed OpenJava and installed Sun Java and altered the .ini file in Eclipse to point to my Java vm.
However, Eclipse won't launch. I get this error file:

!SESSION 2012-09-19 20:03:34.627 -----------------------------------------------
eclipse.buildId=I20110613-1736
java.version=1.7.0_07
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_GB
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2012-09-19 20:03:47.281
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: 
	no swt-gtk-3740 in java.library.path
	no swt-gtk in java.library.path
	Can't load library: /home/tim/.swt/lib/linux/x86_64/libswt-gtk-3740.so
	Can't load library: /home/tim/.swt/lib/linux/x86_64/libswt-gtk.so

	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:285)
	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:194)
	at org.eclipse.swt.internal.C.<clinit>(C.java:21)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
	at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
	at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:695)
	at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
	at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:153)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1386)



I haven't used eclipse for a while and am unsure if this error is linked to the changes I met, or are unrelated. Any help from you Eclipse experts out there would be appreciated!

Thanks,

Tim
Re: eclipse won't launch (error log attached) [message #921720 is a reply to message #917052] Mon, 24 September 2012 07:23 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2250
Registered: July 2009
Senior Member
Did you install a 32-bit -r 64-bit Java? Is your GTK+ also 64-bit?

---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:Can I program in JAVA if I downloaded Eclipse for C/C++?
Next Topic:XML Build Error
Goto Forum:
  


Current Time: Fri Aug 22 13:55:20 EDT 2014

Powered by FUDForum. Page generated in 0.02368 seconds