Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Equinox exceptions, eclipse doesn't run java applications(Eclipse stop working and now it can not run java and the working environment is giving errors)
Equinox exceptions, eclipse doesn't run java applications [message #916621] Wed, 19 September 2012 08:38 Go to next message
Julian Garrido is currently offline Julian GarridoFriend
Messages: 2
Registered: September 2012
Junior Member
I tried yesterday to compile and run an old project and I realized that my eclipse indigo was not working. I don't know if the problem comes from some update or another software I have installed but once month ago it was working perfectly.

Some symptoms are:
- I guess it compiles (it detects errors in the code) but I cannot run a project (not even a hello world).
- If I click on project properties then a dialog shows "The currently displayed page contains invalid values".
- I can not insert a toogle breakpoint, it says: "the chosen operation is not enabled".

What I have done at the very moment is:

- I downloaded eclipse juno in a different folder and created a HelloWorld project in a different workspace --> I have the same problems
- I reinstalled openjdk packages (6 and 7) using synaptic in a ubuntu 12. --> I have the same problems
- I run eclipse with -clean option --> I have the same problems
- I installed eclipse indigo using synaptic --> I have the same problems
- I changed eclipse.ini to specify the vm I want to use --> I have the same problems

If I run eclipse juno with the options "-consoleLog -debug" and its original eclipse.ini, I try to run a helloWorld project and I close eclipse I got the log that is attached. It seems there is some problem with equinox but I don't know real problem.


Please, I would appreciate any help.


Julian


  • Attachment: log.txt
    (Size: 155.53KB, Downloaded 149 times)
Re: Equinox exceptions, eclipse doesn't run java applications [message #916828 is a reply to message #916621] Wed, 19 September 2012 14:17 Go to previous messageGo to next message
David Wegener is currently offline David WegenerFriend
Messages: 1351
Registered: July 2009
Senior Member
You may be running into a bug in openjdk created by Ubuntu with there latest package update.

The fix is to re-install tzdata-java.
Re: Equinox exceptions, eclipse doesn't run java applications [message #917516 is a reply to message #916828] Thu, 20 September 2012 06:44 Go to previous message
Julian Garrido is currently offline Julian GarridoFriend
Messages: 2
Registered: September 2012
Junior Member
Thank you very much David! it worked perfectly and now it is running normally.

You have saved me a lot of problems Smile

best regards, Julian
Previous Topic:Several issues after JRE-6 (OpenJDK) upgrade
Next Topic:Force.com IDE installation trouble
Goto Forum:
  


Current Time: Thu Dec 18 15:36:00 GMT 2014

Powered by FUDForum. Page generated in 0.02153 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software