Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » Metadata Class not generated by CanonicalModelProcessor(a orm.xml configured class does not get a metadata class generated)
Metadata Class not generated by CanonicalModelProcessor [message #915432] Mon, 17 September 2012 05:01 Go to next message
Alexander Bätz is currently offline Alexander Bätz
Messages: 6
Registered: August 2012
Junior Member
I'm generating metadata classes at compile time with maven and the CanonicalModelProcessor. This works for all my classes (all are @entity annotated and configured in the persistence.xml).

For Practical reasons one of this classes inherits a framework base class. i cant annotate this class so i configured the mappedsuperclass in an orm.xml.

The CanonicalModelProcessor does not create a metadata class for the mappedsuperclass but it adds
OAuth2ClientDetails_ extends BaseClientDetails_
to my subclass meta.

What can i do to fix this?

Here is my maven config:

<!-- Metamodel generation for JPA criteria api -->
            <plugin>
                <groupId>org.bsc.maven</groupId>
                <artifactId>maven-processor-plugin</artifactId>
                <version>1.3.5</version>
                <executions>
                    <execution>
                        <id>process</id>
                        <goals>
                            <goal>process</goal>
                        </goals>
                        <phase>generate-sources</phase>
                        <configuration>
                            <outputDirectory>${project.build.directory}/generated-sources/metamodel</outputDirectory>
                            <compilerArguments>
                                -Aeclipselink.persistencexml=${project.basedir}/src/main/resources/META-INF/persistence.xml
                            </compilerArguments>
                            <processors>
                                <processor>org.eclipse.persistence.internal.jpa.modelgen.CanonicalModelProcessor
                                </processor>
                            </processors>
                        </configuration>
                    </execution>
                </executions>
            </plugin>
Re: Metadata Class not generated by CanonicalModelProcessor [message #916063 is a reply to message #915432] Tue, 18 September 2012 09:25 Go to previous message
James Sutherland is currently offline James Sutherland
Messages: 1939
Registered: July 2009
Location: Ottawa, Canada
Senior Member

Odd. Is the superclass on the classpath given to the generator? Try including it in the same jar file given to the generator.

Sounds like it may be a bug, so please log the issue.

You could create the BaseClientDetails_ yourself, or use another metamodel generator, such as the one in Eclipse JPA (Dali).


James : Wiki : Book : Blog : Twitter
Previous Topic:Problem filtering with NOT IN clause
Next Topic:JTA/XA
Goto Forum:
  


Current Time: Sat Jul 26 15:33:41 EDT 2014

Powered by FUDForum. Page generated in 0.02461 seconds