Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Bundlor: No value found for placeholder 'xy'
Bundlor: No value found for placeholder 'xy' [message #913583] Sat, 15 September 2012 19:38 Go to next message
Jean-Pierre Bergamin is currently offline Jean-Pierre Bergamin
Messages: 51
Registered: March 2011
Location: Zürich, CH
Member
Hello everyone

I'm trying to get our multi module maven project up and running on STS 3.0 with Virgo 3.5 and Bundlor 1.1.1.
When I'm trying to generate the MANIFEST.MF file by right clicking a project and choosing "Virgo > Run Generation of MANIFEST.MF File", nothing happens and the following error shows up in the error log (with different values for the placeholder):

java.lang.RuntimeException: No value found for placeholder 'spring.version'
	at org.eclipse.virgo.util.common.PropertyPlaceholderResolver.resolve(PropertyPlaceholderResolver.java:117)
	at org.eclipse.virgo.util.common.PropertyPlaceholderResolver.resolve(PropertyPlaceholderResolver.java:129)
	at org.eclipse.virgo.util.common.PropertyPlaceholderResolver.resolveProperty(PropertyPlaceholderResolver.java:109)
	at org.eclipse.virgo.util.common.PropertyPlaceholderResolver.resolve(PropertyPlaceholderResolver.java:102)
	at org.eclipse.virgo.bundlor.support.propertysubstitution.PlaceholderManifestAndTemplateModifier.modify(PlaceholderManifestAndTemplateModifier.java:50)
	at org.eclipse.virgo.bundlor.support.StandardManifestGenerator.generate(StandardManifestGenerator.java:49)
	at org.eclipse.virgo.ide.bundlor.internal.core.BundlorProjectBuilder.generateManifest(BundlorProjectBuilder.java:549)
	at org.eclipse.virgo.ide.bundlor.internal.core.BundlorProjectBuilder.build(BundlorProjectBuilder.java:220)
	at org.eclipse.virgo.ide.bundlor.internal.core.BundlorProjectBuilder.build(BundlorProjectBuilder.java:154)
	at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:728)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:199)
	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:321)
	at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:396)
	at org.eclipse.core.internal.resources.Project$1.run(Project.java:618)
	at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2344)
	at org.eclipse.core.internal.resources.Project.internalBuild(Project.java:597)
	at org.eclipse.core.internal.resources.Project.build(Project.java:124)
	at org.eclipse.virgo.ide.bundlor.ui.BundlorUiPlugin$RunBundlorJob.run(BundlorUiPlugin.java:99)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)


We are using maven properties in our template.mf files like:
org.springframework.*;version="[${spring.version}, ${spring.version}]"


Those version properties (e.g. "spring.version") are defined in the top level maven project, but seem not to be found. The same setup worked with STS 2.7, the old Spring DM tooling and Bundlor 1.0.0.
Any chances to fix this on our side of is this a bug of the new tooling?



Best regards,
James
Re: Bundlor: No value found for placeholder 'xy' [message #916850 is a reply to message #913583] Wed, 19 September 2012 10:53 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
I'm not sure whether anyone answered any of the duplicated threads. It's probably best to capture that problem in a bugzilla with some simple setup to reproduce.
Re: Bundlor: No value found for placeholder 'xy' [message #940669 is a reply to message #916850] Thu, 11 October 2012 17:37 Go to previous messageGo to next message
Jean-Pierre Bergamin is currently offline Jean-Pierre Bergamin
Messages: 51
Registered: March 2011
Location: Zürich, CH
Member
I opened a ticket for this: https://bugs.eclipse.org/bugs/show_bug.cgi?id=391725
This sample project shows this behaviour: https://bitbucket.org/ractive/virgo-tools-bug
Re: Bundlor: No value found for placeholder 'xy' [message #940769 is a reply to message #940669] Thu, 11 October 2012 20:09 Go to previous message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Thanks for capturing the bug.
Previous Topic: Virgo Tomcat Server 3.5.0 repository host returns 404
Next Topic:Can you describe how you are using Virgo?
Goto Forum:
  


Current Time: Sat Apr 19 16:03:38 EDT 2014

Powered by FUDForum. Page generated in 0.03742 seconds