Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Lua Development Tools » How to setup LTD with own executable?
icon5.gif  How to setup LTD with own executable? [message #912987] Fri, 14 September 2012 14:46 Go to next message
O M is currently offline O MFriend
Messages: 4
Registered: September 2012
Junior Member
I have a lua vm compiled into main executable created in C++ with Microsoft Visual Studio. Lua files a called later from it. Could you please help to find out how to setup LDT in this situation?
Thanks in advance!
Re: How to setup LTD with own executable? [message #915488 is a reply to message #912987] Mon, 17 September 2012 11:51 Go to previous messageGo to next message
Kevin KIN-FOO is currently offline Kevin KIN-FOOFriend
Messages: 50
Registered: January 2010
Member
Hi,

I am not sure to understand exactly your use case. Did you compiled Lua by yourself and want to configure Koneki LDT to use this interpreter to run your projects?
What is your version of Koneki LDT?

Cheers
Re: How to setup LTD with own executable? [message #915490 is a reply to message #915488] Mon, 17 September 2012 11:57 Go to previous messageGo to next message
O M is currently offline O MFriend
Messages: 4
Registered: September 2012
Junior Member
I compiled Lua as static lib and linked into my Visual Studio C++ project. This project creates exe file, which calls Lua functions. So the entry point is the my exe file, not lua file.
The version of Koneki LDT is 0.9M1, downloaded from official site.
Re: How to setup LTD with own executable? [message #915499 is a reply to message #915490] Mon, 17 September 2012 12:19 Go to previous message
Kevin KIN-FOO is currently offline Kevin KIN-FOOFriend
Messages: 50
Registered: January 2010
Member
So you might be interested interested by remote debug[1], which will enable you to debug the Lua of your application.
Please do no hesitate to ask us about further needs.

[1] http://wiki.eclipse.org/Koneki/LDT/Developer_Area/User_Guides/User_Guide_0.8#Remote_Debug
Previous Topic:Can't Update
Next Topic:Can't update Nightly build 0.9.0.201209141432
Goto Forum:
  


Current Time: Wed Nov 26 22:07:58 GMT 2014

Powered by FUDForum. Page generated in 0.01553 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software