Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Is SVN Authentication working in buckmisnter?
Is SVN Authentication working in buckmisnter? [message #909069] Thu, 06 September 2012 09:39 Go to next message
David Casas is currently offline David Casas
Messages: 58
Registered: November 2011
Location: Barcelona
Member

Hi guys,

I am trying to configure the buckminster svn client to access to a encripted repository. I do introduce the url as http://user:pwd@repository but i receive the following errors in the headless version:

Subclipse:
ERROR   [0001] : No suitable provider for component xx.xx.xx.xx.feature:eclipse.feature was found in resourceMap file:/home/kasas/Workspaces/BuckminsterWorkspace/xxx.xxx.xxx.xxx/x.rmap
  ERROR   [0001] : No suitable provider for component esa.ssa.dpc.hmi.feature:eclipse.feature was found in searchPath esa.ssa.dpc.hmi
    ERROR   [0001] : Rejecting provider svn(https://user:pwd@repository{0}[https://user:pwd@repo/plugin]): No component match was found
      ERROR   org.tigris.subversion.svnclientadapter.SVNClientException: org.apache.subversion.javahl.ClientException: svn: E175002: unknown host
svn: E175002: PROPFIND request failed on 'XXXXXXX'
  ERROR   [0001] : No suitable provider for component esa.ssa.dpc.hmi.feature:eclipse.feature was found in searchPath org.eclipse.nebula
    ERROR   [0001] : Rejecting provider p2(http://download.eclipse.org/technology/nebula/snapshot[http://download.eclipse.org/technology/nebula/snapshot]): No component match was found
  ERROR   [0001] : No suitable provider for component esa.ssa.dpc.hmi.feature:eclipse.feature was found in searchPath org.eclipse.platform
    ERROR   [0001] : Rejecting provider p2(http://download.eclipse.org/eclipse/updates/3.7[http://download.eclipse.org/eclipse/updates/3.7]): No component match was found
  ERROR   [0001] : No suitable provider for component esa.ssa.dpc.hmi.feature:eclipse.feature was found in searchPath org.eclipse.indigo
    ERROR   [0001] : Rejecting provider p2(http://download.eclipse.org/releases/indigo[http://download.eclipse.org/releases/indigo]): No component match was found
INFO:  TAG-ID 0001 = Query for esa.ssa.dpc.hmi.feature:eclipse.feature


Subversive:
    ERROR   [0001] : Rejecting provider svn(https://user:pwd@repo{0}[https://user:pwd@repo/xx.xx.xx.xx.feature]): No component match was found
      ERROR   org.eclipse.team.svn.core.connector.SVNConnectorAuthenticationException: svn: E170001: Authentication required for '<https://xxx:446> Subversion repository'


Integrating them into the Eclipse IDE I can access to the repository via subclipse if I introduce my user and password everything goes fine. The problem is I want to automate the building with hudson and I dont find the solution.

Thanxs in advance

[Updated on: Thu, 06 September 2012 09:45]

Report message to a moderator

Re: Is SVN Authentication working in buckmisnter? [message #924999 is a reply to message #909069] Thu, 27 September 2012 05:51 Go to previous message
Matthew Webber is currently offline Matthew Webber
Messages: 198
Registered: December 2010
Senior Member
Try checking out something from the subversion repository at the command line, using the same url etc as Buckminster would use, and see if it works there. Do this as the same userid that is failing (eg, the hudson userid), which might be different from the username that you are trying to authenticate to subversion as.

I have see Buckminster headless materialize fail if, e.g. there is a prompt for a certificate to be accepted.

Also, what version of Buckminster are you using?

Matthew
Previous Topic:Debugging the resolution of a CVS provider based on a tag?
Next Topic:Unnecessary searching for source bundles
Goto Forum:
  


Current Time: Thu Jul 24 06:47:48 EDT 2014

Powered by FUDForum. Page generated in 0.04087 seconds