Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » arm-none-eabi-gcc not found
arm-none-eabi-gcc not found [message #908739] Wed, 05 September 2012 23:25 Go to next message
dbg vdb is currently offline dbg vdbFriend
Messages: 1
Registered: September 2012
Junior Member
Hello there,

I am trying to setup the tools for debugging and ARM-Cortex M3 microcontroller using Eclipse. I have the project laid out with a custom Makefile and if I build it by simply calling make in the project directory, everything compiles; I flash the binary and it works.

Now, the Makefile uses CodeSourcery Lite tools and explicitly calls for arm-none-eabi-gcc, arm-none-eabi-ld etc. I installed them to /opt/CodeSourcery and modified the PATH so that:

$ echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/bin/arm:/opt/CodeSourcery/bin

$ ls /opt/CodeSourcery/bin
arm-none-eabi-addr2line arm-none-eabi-gcc-4.5.2 arm-none-eabi-ranlib
arm-none-eabi-ar arm-none-eabi-gcov arm-none-eabi-readelf
arm-none-eabi-as arm-none-eabi-gdb arm-none-eabi-run
arm-none-eabi-c++ arm-none-eabi-gdbtui arm-none-eabi-size
arm-none-eabi-c++filt arm-none-eabi-gprof arm-none-eabi-sprite
arm-none-eabi-cpp arm-none-eabi-ld arm-none-eabi-strings
arm-none-eabi-elfedit arm-none-eabi-nm arm-none-eabi-strip
arm-none-eabi-g++ arm-none-eabi-objcopy
arm-none-eabi-gcc arm-none-eabi-objdump

Now, I cannot understand why Eclipse wouldn't pick up the compiler since the PATH points to the dir where it is.

The error from Eclipse is:
make: arm-none-eabi-gcc: Command not found
Re: arm-none-eabi-gcc not found [message #909464 is a reply to message #908739] Fri, 07 September 2012 07:29 Go to previous messageGo to next message
Robert Brusa is currently offline Robert BrusaFriend
Messages: 54
Registered: July 2009
Member
Check the variable TOOLCHAIN_AT in (select your project, then rightclick) properties > Resource > Linked Resources

I bet the problem is there - TOOLCHAIN_AT pointing to a location where no tools are. I have the same problem - see also my post under "Access to GNU-Tools"

[Updated on: Fri, 07 September 2012 15:53]

Report message to a moderator

Re: arm-none-eabi-gcc not found [message #911063 is a reply to message #909464] Mon, 10 September 2012 22:48 Go to previous message
Marjon Zubiri is currently offline Marjon ZubiriFriend
Messages: 5
Registered: September 2012
Junior Member
Just my two cents, when the installer for CodeSourcery runs, it usually defaulted to the /home/<user>/ directory. Not sure if that is what's keeping the toolchain from being discovered by Eclipse. Might want to try a remove, then reinstall of the CodeSourcery toolchain, this time in the /home/<user>/ directory.
Previous Topic:Eclipse could not resolve 'strcasecmp'
Next Topic:Eclipse Juno C/C++ Mac Error 127, please help
Goto Forum:
  


Current Time: Sun Dec 21 15:21:19 GMT 2014

Powered by FUDForum. Page generated in 0.01658 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software