Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Faceted Project Problem: Target runtime jre7 is not defined.
Faceted Project Problem: Target runtime jre7 is not defined. [message #903943] Mon, 27 August 2012 07:38 Go to next message
Christian Schwarz is currently offline Christian Schwarz
Messages: 31
Registered: July 2009
Member
I got a error icon on one of our projects. The Problem-View shows "Faceted Project Problem: Target runtime jre7 is not defined.".
How can i solve the problem ? JRE7 is configured for my workspace, so i have no clue what the problem is.

Thanks!
Re: Faceted Project Problem: Target runtime jre7 is not defined. [message #904023 is a reply to message #903943] Mon, 27 August 2012 11:22 Go to previous messageGo to next message
Roberto Sanchez Herrera is currently offline Roberto Sanchez Herrera
Messages: 28
Registered: January 2011
Junior Member
Have you tried to go to the project's property page called Targeted runtimes? There you can see the current target runtime, and if you select "Show all runtimes" you can see all the runtimes installed in your workspace.
Re: Faceted Project Problem: Target runtime jre7 is not defined. [message #904439 is a reply to message #904023] Tue, 28 August 2012 08:30 Go to previous messageGo to next message
Christian Schwarz is currently offline Christian Schwarz
Messages: 31
Registered: July 2009
Member
The build path was set to JDK6, now i changed it to workspace default JDK7 (Project Properties|Java Build Path| Libraries|Edit|Workspace Default), but the problem remains.

Btw. my project got no property page called "Targeted runtimes" (maybe because it's an Plugin-Project?).
http://www.eclipse.org/forums/index.php/fa/11313/0/
Re: Faceted Project Problem: Target runtime jre7 is not defined. [message #974955 is a reply to message #904439] Wed, 07 November 2012 08:24 Go to previous message
Christian Schwarz is currently offline Christian Schwarz
Messages: 31
Registered: July 2009
Member
For the record:
The Problem can be fixed, by deleting <project>/.settings/org.eclipse.wst.common.facet.core.xml, and clicking on "Update classpath setting" in the manifest editor. Et-Voila no compile-errors!
Previous Topic:How to have a tomcat server added that is already running/started outside of eclipse?
Next Topic:Exporting static web project
Goto Forum:
  


Current Time: Sat Aug 30 16:33:48 EDT 2014

Powered by FUDForum. Page generated in 0.06581 seconds