Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Moved: Dependency satisfaction with different bundle versions
Moved: Dependency satisfaction with different bundle versions [message #903563] Fri, 24 August 2012 11:03 Go to next message
Kevin Milburn is currently offline Kevin Milburn
Messages: 13
Registered: July 2012
Junior Member
I'm trying integrate some features into and RCP application and have hit a dependency issue with my target platform.

Cannot resolve project dependencies:
   Software being installed: org.apache.xerces 2.11.0
   Only one of the following can be installed at once: [org.apache.xerces 2.11.0, org.apache.xerces 2.9.0]
   Cannot satisfy dependency: org.eclipse.wst.xml_core.feature.feature.group 3.4.0 depends on: org.apache.xerces [2.9.0]



How can I get around this problem?

[Updated on: Fri, 31 August 2012 10:39]

Report message to a moderator

Re: Dependency satisfaction with different bundle versions [message #904434 is a reply to message #903563] Tue, 28 August 2012 12:26 Go to previous messageGo to next message
Joseph Carroll is currently offline Joseph Carroll
Messages: 174
Registered: May 2012
Location: Milwaukee, WI
Senior Member

I would need a little more information to give a definitive answer, but make sure you have defined a target for you application and that you are using that as your active target.

http://www.vogella.com/articles/EclipseTargetPlatform/article.html

JD
Re: Dependency satisfaction with different bundle versions [message #904476 is a reply to message #904434] Tue, 28 August 2012 13:45 Go to previous messageGo to next message
Kevin Milburn is currently offline Kevin Milburn
Messages: 13
Registered: July 2012
Junior Member
I have a target platform definition, which looks something like this:

<target name="eclipse 4.2 (juno)" sequenceNumber="2">
<locations>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.apache.xerces" version="2.11.0"/>
<repository location="localserver/repository/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="planner" includeSource="true" type="InstallableUnit">
...
<unit id="org.eclipse.wst.xml_xml_core.feature.feature.group" version="3.4.0.v201111021744-7C7OFm4F7RZHQRIpOz-P2Xk"/>
<repository location="eclipse/releases/juno"/>
</location>
</locations>
</target>


When loading the file in the Target Editor, I get the above 'Cannot resolve project dependencies' messages, which prevents it's use as the active target.

From what I gather, the problem is that the wst.xml_core feature specifies org.apache.xerces 2.9.0 as an included plugin, and I'm trying to include version 2.11.0 of the same plugin.

When the platform is being resolved, somthing within p2 is deciding that it cannot have both 2.9.0 and 2.11.0 of the same plugin, and because it wants to install 2.11.0 it cannot satify the dependency for 2.9.0.

In this instance, I could repackage the plugin with a different name and all would be well (including the existences of differing versions of the same packages), however, this seems like a arbitrary workaround to a problem that shouldn't exist.
And what would I do if I was including different features I was not in control of which results in the same problem.
Re: Dependency satisfaction with different bundle versions [message #904530 is a reply to message #904476] Tue, 28 August 2012 16:03 Go to previous messageGo to next message
Martin Skorsky is currently offline Martin Skorsky
Messages: 112
Registered: July 2009
Senior Member
> When the platform is being resolved, somthing within p2 is deciding that it cannot have both 2.9.0 and 2.11.0 of the same plugin, and because it wants to install 2.11.0 it cannot satify the dependency for 2.9.0.

May be this is caused by the 'singleton:=true' directive in the bundle manifest. Then OSGi can run only one version of this bundle.
Re: Dependency satisfaction with different bundle versions [message #904541 is a reply to message #904530] Tue, 28 August 2012 16:36 Go to previous messageGo to next message
Kevin Milburn is currently offline Kevin Milburn
Messages: 13
Registered: July 2012
Junior Member
neither bundle specifies the singleton directive.
Re: Dependency satisfaction with different bundle versions [message #905938 is a reply to message #904541] Fri, 31 August 2012 10:40 Go to previous message
Kevin Milburn is currently offline Kevin Milburn
Messages: 13
Registered: July 2012
Junior Member
I've reposted this in the P2 forum as it seems more appropriate... http://www.eclipse.org/forums/index.php/m/905932/#msg_905932
Previous Topic:Problem
Next Topic:Question on StatET Eclipse
Goto Forum:
  


Current Time: Mon Sep 15 09:48:37 GMT 2014

Powered by FUDForum. Page generated in 0.02144 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software