Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » p2 - fragments for IU
p2 - fragments for IU [message #120090] Thu, 23 October 2008 14:35
Anaïk TRIHOREAU is currently offline Anaïk TRIHOREAUFriend
Messages: 1
Registered: July 2009
Junior Member
Hi everyone,

I am trying to test the following :

Create a metadata repository MR-A.
It contains a very simple installable unit that requires only
org.eclipse.sdk.ide, and which is a "group". Its name is 'common'.
It contains also an other IU, as fragment, to create a folder 'myFolder'
(it is not a group).

have used the latest integration build for p2 agent
(equinox-p2-agent-I20081021-0905-win32).
So now, when I dragNdrop the fragment from MR-A to a profile, a new
folder 'myFolder' is created.

But if I dragNdrop 'common' alone, the fragment is not considered, no
'myFolder' is created.
I suppose that the fragment should be considered, as it is in the same
metadata repository and it requires 'comon'.
Did I miss something ?
Has anyone tried to create such a fragment with success ?

Here is a copy of my content.xml file.
Anaik

<?xml version='1.0' encoding='UTF-8'?>
<?metadataRepository
class='org.eclipse.equinox.internal.p2.metadata.repository.L ocalMetadataRepository'
version='1.0.0'?>
<repository name='p2.demo.repositoryA'
type='org.eclipse.equinox.internal.p2.metadata.repository.Lo calMetadataRepository'
version='1'>
<properties size='1'>
<property name='p2.timestamp' value='1224690029147'/>
</properties>
<units size='3'>
<unit id='common' version='1.0.0' >
<properties size='2'>
<property name='org.eclipse.equinox.p2.name' value='common'/>
<property name='org.eclipse.equinox.p2.type.group' value='true'/>
</properties>
<provides size='1'>
<provided namespace='org.eclipse.equinox.p2.iu' name='common'
version='1.0.0'/>
</provides>
<requires size='1'>
<required namespace='org.eclipse.equinox.p2.iu'
name='org.eclipse.sdk.ide' range='[3.4.0,3.5.0)'/>
</requires>
<touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>
<licenses size='1'>
<license></license>
</licenses>
<copyright></copyright>
</unit>
<unit id='fragment' version='1.0.1' singleton='false'>
<hostRequirements size='1'>
<required namespace='org.eclipse.equinox.p2.iu' name='common'
version='1.0.0'/>
</hostRequirements>
<properties size='1'>
<property name='org.eclipse.equinox.p2.type.fragment'
value='true'/>
</properties>
<provides size='1'>
<provided namespace='org.eclipse.equinox.p2.iu' name='fragment'
version='1.0.1'/>
</provides>
<<requires size='1'>
<required namespace='org.eclipse.equinox.p2.iu' name='common'
version='1.0.0'/>
</requires>
<touchpoint id='org.eclipse.equinox.p2.osgi' version='1.0.0'/>
<touchpointData size='1'>
<instructions size='3'>
<instruction key='configure'>

addJvmArg(jvmArg:-DGWT_HOME=C:\USERS\Anaik\Paprika\gwt-windo ws-1.5.2);
</instruction>
<instruction key='install'>
mkdir(path:${installFolder}/myFolder);
</instruction>
<instruction key='uninstall'>
rmdir(path:${installFolder}/myFolder);
</instruction>
</instructions>
</touchpointData>
<licenses size='1'>
<license></license>
</licenses>
<copyright></copyright>
</unit>
</units>
</repository>
Previous Topic:ThreadDeath - Servicelistener ???
Next Topic:Re: P2 Installation of feature fails because of unsatisfied capability
Goto Forum:
  


Current Time: Sun Dec 21 04:54:06 GMT 2014

Powered by FUDForum. Page generated in 0.01594 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software