Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orion » Load Timeout for Plugins(Getting Load timeout for plugins on both orionhub and local orion)
Load Timeout for Plugins [message #902062] Wed, 15 August 2012 17:18 Go to next message
Pete Allen is currently offline Pete Allen
Messages: 2
Registered: August 2012
Junior Member
Hello All,

I wonder if anyone can shed light on my plugin installing issue,
I am getting "Load timeout for plugin: http:<address-of-plugin>.html" on any plugin I try to install, this happens on both orionhub and on a local Orion server, and happens whichever way I try to install plugins (i.e via URL directly or the settings > plugins panel)

I have even gotten this message from the simple plugin example (reverses selected text) given in the Orion documentation.

I have tried installing from a remote site and an Orion page-as-site but to no avail, the plugin.js file is referenced correctly in all cases and I have also tried with the contents of plugin.js pasted into a <script> block, also to no avail.

What could I be missing or doing incorrectly? (entirely possible I'm just being dumb)

Thank You

Edit: Clarity

[Updated on: Wed, 15 August 2012 19:37]

Report message to a moderator

Re: Load Timeout for Plugins [message #902086 is a reply to message #902062] Wed, 15 August 2012 19:07 Go to previous messageGo to next message
Pete Allen is currently offline Pete Allen
Messages: 2
Registered: August 2012
Junior Member
Ok I have found a way to get around this.

If I make a copy one of the html plugin files in C:\orion\eclipse\plugins\org.eclipse.client.core<...>\web\plugins and just overwrite the relevant parts with what I want then I can install the plugin using: http:// localhost:8080/plugins/whatever.html via Orion settings > plugins > install

Edit: on my local Orion on Windows. Should've pointed that out originally.

Ta.

[Updated on: Wed, 15 August 2012 19:11]

Report message to a moderator

Re: Load Timeout for Plugins [message #916234 is a reply to message #902062] Tue, 18 September 2012 19:27 Go to previous message
John Arthorne is currently offline John Arthorne
Messages: 174
Registered: July 2009
Senior Member
You shouldn't have to hack the built in Orion plugins to get this working. I don't know what is causing it, but you could look at some of the examples of "external" plugins in this catalog:

http://mamacdon.github.com/

All of these plugins will install into a remote Orion, either localhost or hosted elsewhere. Note you should have a copy of the plugin.js in your plugin and not rely on some external script location.

John
Previous Topic:Embedded in the Eclipse IDE Editor What should I do?
Next Topic:The ABCs of workspace organization
Goto Forum:
  


Current Time: Thu Oct 30 15:13:19 GMT 2014

Powered by FUDForum. Page generated in 0.35168 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software