Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Juno performance is slow(Indigo to Juno update resulted in big UI performance hit)
Juno performance is slow [message #901301] Fri, 10 August 2012 16:42 Go to next message
Harry Mantheakis is currently offline Harry Mantheakis
Messages: 8
Registered: August 2012
Junior Member
Some feedback, as a grateful long-standing user and admirer of the Eclipse IDE for Java projects.

I updated from Indigo to Juno, and the user-interface performance dropped off a cliff. The UI has become incredibly sluggish: sometimes several seconds pass when switching between editor windows, views, etc.

I am running Juno on a 64-bit system with Windows 7 and JDK 6.

I have switched OFF all "Validation" checks except "Classpath Dependencies".

The only plugins I use are Subclipse, Sysdeo for Tomcat, and AnyEdit Tool.

My "eclipse.ini" is set as follows:

-vm
C:/Program Files/Java/jdk1.6.0_30/bin
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20120522-1813
-product
org.eclipse.epp.package.reporting.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-server
-Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-Xmn128m
-Xms1024m
-Xmx1024m
-Xss2m
-XX:PermSize=256m
-XX:MaxPermSize=256m
-XX:+UseParNewGC
-XX:+UseConcMarkSweepGC
-XX:+CMSClassUnloadingEnabled
-Xverify:none

Indigo was (and is) really fast - so I have gone back to it for the meantime.

Sincerely

Harry Mantheakis
Re: Juno performance is slow [message #901312 is a reply to message #901301] Fri, 10 August 2012 17:27 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de Alwis
Messages: 242
Registered: July 2009
Senior Member
We've seen a couple of reports like this, and I've witnessed it happen to another developer too on an fast 8-CPU machine with oodles of memory. It's definitely a real problem for some people, but the cause not clear. We need you to take some stack traces or fire up JVIsualVM and get some snapshots of the slow behaviour -- we can't reproduce it locally.

See the following URL for tips on what to do to report information:

http://wiki.eclipse.org/How_to_report_a_deadlock

Brian.
Re: Juno performance is slow [message #901315 is a reply to message #901312] Fri, 10 August 2012 18:01 Go to previous messageGo to next message
Harry Mantheakis is currently offline Harry Mantheakis
Messages: 8
Registered: August 2012
Junior Member
Thanks. I have 8-CPU machine with 4 GB of memory, which is adequate.

I will follow up on this, and try to help if I can, next week.

Harry
Re: Juno performance is slow [message #901349 is a reply to message #901315] Sat, 11 August 2012 07:18 Go to previous messageGo to next message
Mengxin Zhu is currently offline Mengxin Zhu
Messages: 2
Registered: July 2009
Junior Member
Is there any existing bug report already?
Re: Juno performance is slow [message #901395 is a reply to message #901349] Sat, 11 August 2012 17:58 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de Alwis
Messages: 242
Registered: July 2009
Senior Member
https://bugs.eclipse.org/bugs/show_bug.cgi?id=385272
Re: Juno performance is slow [message #939969 is a reply to message #901301] Thu, 11 October 2012 07:33 Go to previous messageGo to next message
Serhiy Palamarchuk is currently offline Serhiy Palamarchuk
Messages: 1
Registered: October 2012
Junior Member
I'm fan of Eclipse and Juno but it is really sluggish for me as well. My hardware is 4-cores CPU and 12Gb of memory. Also I noticed that JSPs are opened really slowly. If you have several opened JSP it start annoying.
Re: Juno performance is slow [message #959532 is a reply to message #901301] Fri, 26 October 2012 20:02 Go to previous messageGo to next message
J L is currently offline J L
Messages: 7
Registered: April 2012
Junior Member
+1

Juno is very slow for me too. I'm back to Indigo for now.

Re: Juno performance is slow [message #987531 is a reply to message #959532] Tue, 27 November 2012 00:44 Go to previous messageGo to next message
Mariano Ruiz is currently offline Mariano Ruiz
Messages: 1
Registered: November 2012
Junior Member
+1

Very very slow. With the previous version running the same tasks in the same machine much faster.

Back to Indigo too.
Re: Juno performance is slow [message #989147 is a reply to message #987531] Tue, 04 December 2012 20:11 Go to previous messageGo to next message
Paul Mander is currently offline Paul Mander
Messages: 1
Registered: December 2012
Junior Member
Just installed Juno 64-bit on a Quad-core i7, 16GB memmory, ssd. Very slow performance.
icon9.gif  Re: Juno performance is slow [message #989164 is a reply to message #901301] Tue, 04 December 2012 22:59 Go to previous messageGo to next message
Patrick Tucker is currently offline Patrick Tucker
Messages: 2
Registered: December 2012
Junior Member
Slow here too, Alienware with dual i7s and 24 gigs of RAM.

The UI is sometimes, but not always, really slow when an XML editor is open. I've also noticed that at times the refresh dependencies icon flashes really fast for a little while.
Re: Juno performance is slow [message #989170 is a reply to message #989147] Tue, 04 December 2012 23:55 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5422
Registered: July 2009
Senior Member
Please install the feature patch mentionned in
https://bugs.eclipse.org/bugs/show_bug.cgi?id=385272#c212 this should
solve most of your problems hopefully

Tom

Am 04.12.12 21:39, schrieb Paul Mander:
> Just installed Juno 64-bit on a Quad-core i7, 16GB memmory, ssd. Very
> slow performance.
Re: Juno performance is slow [message #989191 is a reply to message #989164] Wed, 05 December 2012 07:03 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5422
Registered: July 2009
Senior Member
Please see my other reply. This XML slowness is fixed with the feature
patch or if you use one of the latest 4.2.2 builds.

Tom

Am 05.12.12 01:48, schrieb Patrick Tucker:
> Slow here too, Alienware with dual i7s and 24 gigs of RAM.
>
> The UI is sometimes, but not always, really slow when an XML editor is
> open. I've also noticed that at times the refresh dependencies icon
> flashes really fast for a little while.
icon6.gif  Re: Juno performance is slow [message #989548 is a reply to message #989170] Thu, 06 December 2012 17:07 Go to previous messageGo to next message
Patrick Tucker is currently offline Patrick Tucker
Messages: 2
Registered: December 2012
Junior Member
Eclipse is working much better now! I can open multiple XML files with no performance impact.

Thanks!
Re: Juno performance is slow [message #990935 is a reply to message #901301] Sat, 15 December 2012 03:04 Go to previous messageGo to next message
harry sheng is currently offline harry sheng
Messages: 41
Registered: July 2009
Member
Used Juno in a new project for about a month.
Working with .jsp and .xml file is insanely slow. It takes more than a few seconds to switch from or to a .jsp/.xml file. When I switch to a .xml (springframework configure) file, I can see from the status bar that Eclipse is loading the .dtd or .xsd files. Yes, it's SWITCH, not OPEN; the file is already open in Juno.

In one case, I saw six eclipse.exe processes (each with 2MB memory in size) in the task manager when I was really annoyed by its slowness.

Now I'm switching back to Indigo.
Re: Juno performance is slow [message #991456 is a reply to message #990935] Wed, 19 December 2012 09:22 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de Alwis
Messages: 191
Registered: January 2012
Senior Member

Harry, I'd you try using the performance fixes? See the following link fr details on how to install:

http://wiki.eclipse.org/Platform_UI/Juno_Performance_Investigation


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: Juno performance is slow [message #1069015 is a reply to message #991456] Mon, 15 July 2013 01:18 Go to previous message
J L is currently offline J L
Messages: 7
Registered: April 2012
Junior Member
Way better in Kepler! Thanks.
Previous Topic:How can I download and zip a plugin?
Next Topic:Mirror eclipse welcome\Intro page
Goto Forum:
  


Current Time: Sat Oct 25 13:25:05 GMT 2014

Powered by FUDForum. Page generated in 0.02643 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software