Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Compile Papyrus
Compile Papyrus [message #894348] Sun, 08 July 2012 10:53 Go to next message
Kenia Santos is currently offline Kenia Santos
Messages: 4
Registered: July 2012
Junior Member
Hi,
I need to compile Papyrus but I dont have much experience so I need help.
I would like to receive a step by step how to compile the code.
The source code must be imported what kind of project?
I need to insert some diagrams in SysML. This is very important work for me.
Please help me.

Best regards
Kênia
Re: Compile Papyrus [message #894437 is a reply to message #894348] Mon, 09 July 2012 05:06 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 422
Registered: February 2011
Senior Member
Hello Kênia,


First of all, you will need to install all the Papyrus Dependencies:

- EMF
- GMF
- EMF Facet
- MoDisco
- QVTo
- X-Text

(You can also install Papyrus ; it will automatically install all the required dependencies)

Then, you should check out the sources from the Papyrus repository, using this Project Set File:

http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/trunk/plugins_http.psf (From http://wiki.eclipse.org/Papyrus_Developer_Guide#Retrieve_code)

This psf file is generated automatically from the Papyrus SVN Repository ; it contains a few plug-ins which are actually not included in the Papyrus distribution (And which may not compile). I won't list all the plug-ins which should or should not compile correctly, but here are a few tips:

- Errors on *.qvto, *.uiCustom, *.facet, *.querySet files are not a problem.
- Developer plug-ins (From the "developer" working set) are included in the *.psf file, but are not required. They may or may not compile, depending on what you've installed.
- The following plug-ins are not included in the Papyrus distribution, and may not compile. You can simply close them:

  • {oep}.views.documentation.*
  • {oep}.uml.documentation
  • {oep}.uml.properties.tabbedproperties.comments
  • {oep}.customization


Papyrus is supposed to compile on Eclipse 4.2 ; a few plug-ins won't compile on Eclipse 3.8.

If you still meet some errors, tell me which plug-ins are affected and the kind of error you meet.


Regards,
Camille
Re: Compile Papyrus [message #894439 is a reply to message #894348] Mon, 09 July 2012 05:10 Go to previous messageGo to next message
Noelia as is currently offline Noelia as
Messages: 13
Registered: June 2012
Junior Member
Hello Kenia,

I had the same problem, and this topic helped me. If you need more help tell me because I had solved it, although I worked with diagrams UML

http://www.eclipse.org/forums/index.php/t/359610/
Re: Compile Papyrus [message #894781 is a reply to message #894439] Tue, 10 July 2012 10:05 Go to previous messageGo to next message
Kenia Santos is currently offline Kenia Santos
Messages: 4
Registered: July 2012
Junior Member
Thanks Camille and Noelia for attention.

I've installed papyrus. Until this point all right.

I had downloaded the code from
http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/

but now I was a little confused

Should I download from
http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/trunk/plugins_http.psf
?

Should I run from which file?

I have not found a main executable.


Regards
Kênia
Re: Compile Papyrus [message #894784 is a reply to message #894781] Tue, 10 July 2012 10:11 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 422
Registered: February 2011
Senior Member
Hello Kênia,


The psf (Project Set File) is a helper to download a set of projects from a team repository.

Due to the hierarchy of the Papyrus SVN Repository, it can be complicated to checkout the sources manually. So, you should use the PSF file. To use the psf file, in Eclipse, use Import > Team > Team Project Set, and use the psf URL (http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/trunk/plugins_http.psf)

It will checkout all Papyrus plug-ins from the SVN repository, and store them in Eclipse Working Sets. That's the simplest way to checkout the Papyrus sources.

Of course, if you've already checkout the sources manually, you don't need to use the PSF. That's just an alternative way.


Regards,
Camille
Re: Compile Papyrus [message #895336 is a reply to message #894784] Thu, 12 July 2012 09:43 Go to previous messageGo to next message
Kenia Santos is currently offline Kenia Santos
Messages: 4
Registered: July 2012
Junior Member
Hi.

I'm not getting run Papyrus.

I need to follow the steps below. Rigth?

Update the GMFGen
In your GMFGen, you have to update two properties to take into account the specific Papyrus templates. In the node GenEditor of your gmfgen files, you have to setup the following properties :
Dynamic Templates to true
Template Directory to /org.eclipse.papyrus.def/dynamic-templates3.5/codegen

Run the generation
To run the transformation, rigth click on your gmfgen file and select the menu Generate Papyrus Diagram.

I can not find the file gmfgen. Where is it?

Regards
Kênia
Re: Compile Papyrus [message #895337 is a reply to message #895336] Thu, 12 July 2012 09:45 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 422
Registered: February 2011
Senior Member
Hello Kênia,

These steps are required to (re)generate a Papyrus Diagram (e.g. the Class Diagram). You don't need that to compile the Papyrus sources, as the diagrams have already been generated.


Regards,
Camille
Re: Compile Papyrus [message #896184 is a reply to message #895337] Tue, 17 July 2012 10:06 Go to previous messageGo to next message
Dave Akehurst is currently offline Dave Akehurst
Messages: 12
Registered: July 2009
Junior Member
I too am trying to compile the papyrus sources.
I do want to make a change to a diagram, and hence regenerate the diagram code.

However I have problems with the .gmfgen files, I get the following errors:

ClassNotFoundException: Class 'PapyrusExtensionRootNode' is not found or is abstract. (platform:/resource/org.eclipse.papyrus.uml.diagram.clazz/model/classdiagram.gmfgen, 7356, 46)

and

PackageNotFoundException: Package with uri 'http://www.eclipse.org/papyrus/2009/papyrusgmfgenextension' not found. (platform:/resource/org.eclipse.papyrus.uml.diagram.clazz/model/classdiagram.gmfgen, 7356, 46)

any help to get past these problems much appreciated
Re: Compile Papyrus [message #896214 is a reply to message #896184] Tue, 17 July 2012 11:21 Go to previous messageGo to next message
Dave Akehurst is currently offline Dave Akehurst
Messages: 12
Registered: July 2009
Junior Member
OK. so I read the instructions

http://wiki.eclipse.org/Papyrus_Developer_Guide/Papyrus_diagram_generation

"The generation has to be run in a runtime application. "

however I am still getting errors/issues so any help from some one who has done this would still bbe appreciated.

If I run an eclipse application as per the instructions (I think) I get:-


Errors running builder 'Acceleo Builder' on project 'org.eclipse.papyrus.domaincontextcodegen'.

??
Re: Compile Papyrus [message #902078 is a reply to message #896214] Wed, 15 August 2012 14:19 Go to previous messageGo to next message
Kenia Santos is currently offline Kenia Santos
Messages: 4
Registered: July 2012
Junior Member
Hi.
I had stopped with my work but now returned.
I'm with errors in the following plugins:

org.eclipse.papyrus.codegen
org.eclipse.papyrus.customization
org.eclipse.papyrus.customization.properties.generation
org.eclipse.papyrus.customization.properties.model.xwt
org.eclipse.papyrus.domaincodegen.ui
org.eclipse.papyrus.domaincontextcodegen
org.eclipse.papyrus.gmfgenextension
org.eclipse.papyrus.infra.gmfdiag.css
org.eclipse.papyrus.infra.gmfdiag.css.xtext.ui
org.eclipse.papyrus.infra.xtext.widgets
org.eclipse.papyrus.sysml.diagram.parametric
org.eclipse.papyrus.sysml.sysmloveruml.codegen
org.eclipse.papyrus.uml.properties.tabbedproperties.comments
org.eclipse.papyrus.views.documentation.view
org.eclipse.papyrus.views.documentation.view.papyrus

If someone still can help me I am grateful.

Best Regards

Kênia
Re: Compile Papyrus [message #902698 is a reply to message #894437] Sun, 19 August 2012 16:54 Go to previous messageGo to next message
ibrahim beicker is currently offline ibrahim beicker
Messages: 1
Registered: August 2012
Junior Member
Camille Letavernier wrote on Mon, 09 July 2012 05:06
Hello Kênia,


First of all, you will need to install all the Papyrus Dependencies:

- EMF
- GMF
- EMF Facet
- MoDisco
- QVTo
- X-Text

(You can also install Papyrus ; it will automatically install all the required dependencies)

Then, you should check out the sources from the Papyrus repository, using this Project Set File:

http://download.eclipse.org/modeling/mdt/papyrus/psf/subclipse/trunk/plugins_http.psf (From http://wiki.eclipse.org/Papyrus_Developer_Guide#Retrieve_code)

This psf file is generated automatically from the Papyrus SVN Repository ; it contains a few plug-ins which are actually not included in the Papyrus distribution (And which may not compile). I won't list all the plug-ins which should or should not compile correctly, but here are a few tips:

- Errors on *.qvto, *.uiCustom, *.facet, *.querySet files are not a problem.
- Developer plug-ins (From the "developer" working set) are included in the *.psf file, but are not required. They may or may not compile, depending on what you've installed.
- The following plug-ins are not included in the Papyrus distribution, and may not compile. You can simply close them:

  • {oep}.views.documentation.*
  • {oep}.uml.documentation
  • {oep}.uml.properties.tabbedproperties.comments
  • {oep}.customization


Papyrus is supposed to compile on Eclipse 4.2 ; a few plug-ins won't compile on Eclipse 3.8.

If you still meet some errors, tell me which plug-ins are affected and the kind of error you meet.


Regards,
Camille


Hello

I've installed all the dependencies and downloaded the code through the Project Set File, but there's one project with errors

the project org.eclipse.papyrus.sysml.diagram.parametric have the following dependencies missing

org.eclipse.papyrus.resource (0.9.0)
org.eclipse.papyrus.resource.edit (0.9.0)
org.eclipse.papyrus.parsers (0.9.0)

these folders are not present on the source, what should I do?
Re: Compile Papyrus [message #902739 is a reply to message #894348] Mon, 20 August 2012 04:30 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 422
Registered: February 2011
Senior Member
Hello,

The SysML Parametric Diagram currently does not compile, and has been removed from the Papyrus Juno build. You should simply ignore it.


Regards,
Camille
Re: Compile Papyrus [message #999887 is a reply to message #902739] Sun, 13 January 2013 05:19 Go to previous messageGo to next message
Carlos Gomez is currently offline Carlos Gomez
Messages: 22
Registered: October 2010
Junior Member
Hi Camille,

Do you know when we will have parametric diagram in Juno?

Cordially,

CarlosG
Re: Compile Papyrus [message #1000202 is a reply to message #999887] Mon, 14 January 2013 03:52 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 422
Registered: February 2011
Senior Member
Hello Carlos,


As far as I know, Parametric Diagrams are not planed to be supported in Juno. They should be available in the next release (Papyrus 0.10 / Eclipse Kepler), in June.


Regards,
Camille
Re: Compile Papyrus [message #1000234 is a reply to message #1000202] Mon, 14 January 2013 05:20 Go to previous message
Carlos Gomez is currently offline Carlos Gomez
Messages: 22
Registered: October 2010
Junior Member
Thank you for your quick answer!!!!
Previous Topic:diffrence between NFP and NFPType in Marte
Next Topic:Papyrus palette customization
Goto Forum:
  


Current Time: Sat Aug 02 04:48:41 EDT 2014

Powered by FUDForum. Page generated in 0.02751 seconds