Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » org.eclipse.acceleo:maven:jar:3.2.1 not found(Running acceleo project with maven)
org.eclipse.acceleo:maven:jar:3.2.1 not found [message #893699] Thu, 05 July 2012 10:09 Go to next message
MeJ MeJ is currently offline MeJ MeJFriend
Messages: 9
Registered: July 2012
Junior Member
Hi,
I am trying to execute my acceleo project using MAVEN. When i try to run the command: mvn package i get the following error
[ERROR] Failed to execute goal on project simple: Could not resolve dependencies
for project org.sonatype.mavenbook.simple:simple:jar:1.0-SNAPSHOT: Failure to f
ind org.eclipse.acceleo:maven:jar:3.2.1 in http:// repo.maven.apache.org/maven2 w
as cached in the local repository, resolution will not be reattempted until the
update interval of central has elapsed or updates are forced -> [Help 1]

In my pom file i have these dependency:
<dependency>
<groupId>org.eclipse.acceleo</groupId>
<artifactId>maven</artifactId>
<version>3.2.1</version>
<type>maven-plugin</type>
</dependency>

I guess i have to create a repositori for it,maybe? I am new in Maven but if the repository is the case i try to search some online but i couldnt find any.
Does anyone have a clue of my error and if there is any repository which can solve my problem.
Thank you in advance
Re: org.eclipse.acceleo:maven:jar:3.2.1 not found [message #893795 is a reply to message #893699] Thu, 05 July 2012 14:08 Go to previous messageGo to next message
MeJ MeJ is currently offline MeJ MeJFriend
Messages: 9
Registered: July 2012
Junior Member
Hi i managed to solve my problem. I couldnt managed to use the repositories in my pom.xml files. but i installed the files manually.
I downloaded the jars from this webiste: https:// github.com/sbegaudeau/maven-repository/tree/master/repository/
And i used this command to install the libraries in my local repository:
mvn install:install-file -Dfile=C:/Users/common-3.3.0.jar -DgroupId=org.eclipse.acceleo -DartifactId=common -Dversion=3.3.0 -Dpackaging=jar
Of course that in pom file you need to add this class as a dependency in this format:
<dependency>
<groupId>org.eclipse.acceleo</groupId>
<artifactId>common</artifactId>
<version>3.3.0</version>
</dependency>

For sure there should be some smarter solutions. But this resolved my problem. I hope it will be useful for some other people.
cheers
Re: org.eclipse.acceleo:maven:jar:3.2.1 not found [message #894448 is a reply to message #893795] Mon, 09 July 2012 09:38 Go to previous message
Stephane Begaudeau is currently offline Stephane BegaudeauFriend
Messages: 413
Registered: April 2010
Location: Nantes (France)
Senior Member

Hi,

The maven documentation has been updated in the last couple weeks: http://wiki.eclipse.org/Acceleo/Maven
Two working examples are also provided here and there. Those examples are documented on the Maven documentation on the wiki.


Regards,

Stephane Begaudeau, Obeo

--
Twitter: @sbegaudeau & @acceleo
Google+: stephane.begaudeau & acceleo
Blog: http://stephanebegaudeau.tumblr.com
Acceleo Documentation: http://docs.obeonetwork.com/acceleo



Previous Topic:[Acceleo] Standalone generation
Next Topic:InvocationTargetException: Missing parameters
Goto Forum:
  


Current Time: Fri Dec 19 23:37:54 GMT 2014

Powered by FUDForum. Page generated in 0.01521 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software