Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » proxy recorder _not_ listening to port1080
proxy recorder _not_ listening to port1080 [message #118489] Tue, 20 November 2007 06:46 Go to next message
Eclipse User
Originally posted by: pascoualito.google_mail.com

Hi,

In Eclipse when I run a 'Test From Recording', everything seem working
well. I've the message 'proxy recorder listening to port1080' in eclipse
log but the port 1080 is in fact not open. My iptables has no rules so I
don't see where I'm wrong.

Someone has an idea about what can cause this ?

Version of
TPTP SDK : 4.4.0.3 working on Ubuntu 7.10
AC : 4.4.1.0 working on Debien 4.0

Best Regards.
--
Pascal.
Re: proxy recorder _not_ listening to port1080 [message #118499 is a reply to message #118489] Tue, 20 November 2007 07:00 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Pascal,
The recorder should be listening on port 10002, unless you changed it in
the preferences.

Paul
"Pascal" <pascoualito@google_mail.com> wrote in message
news:cc48adf32cd9ca355a6d799d1ca1a8b4$1@www.eclipse.org...
> Hi,
>
> In Eclipse when I run a 'Test From Recording', everything seem working
> well. I've the message 'proxy recorder listening to port1080' in eclipse
> log but the port 1080 is in fact not open. My iptables has no rules so I
> don't see where I'm wrong.
>
> Someone has an idea about what can cause this ?
>
> Version of
> TPTP SDK : 4.4.0.3 working on Ubuntu 7.10
> AC : 4.4.1.0 working on Debien 4.0
>
> Best Regards.
> --
> Pascal.
>
Re: proxy recorder _not_ listening to port1080 [message #118504 is a reply to message #118499] Tue, 20 November 2007 07:43 Go to previous messageGo to next message
Eclipse User
Originally posted by: pascoualito.google_mail.com

Hi Paul,

On 10002 this is the Agent Controller port and TPTP SDK on Eclipse is
connected to this port without any problem.

But I'm talking about the proxy recorder, on port 1080, create by TPTP SDK
on Eclipse
( http://help.eclipse.org/help31/topic/org.eclipse.hyades.test .doc.user/concepts/ctestwithhyades.htm),.

Thanks.
Best Regards.
--
Pascal.
Re: proxy recorder _not_ listening to port1080 [message #118529 is a reply to message #118504] Wed, 21 November 2007 06:09 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
As am I. See:

http://help.eclipse.org/help31/topic/org.eclipse.hyades.test .doc.user/images/recorderControl.gif

from:

http://help.eclipse.org/help31/index.jsp?topic=/org.eclipse. hyades.test.doc.user/tasks/trecordtest.htm

Can you post the entry in the Eclipse log?

PS
"Pascal" <pascoualito@google_mail.com> wrote in message
news:3a3cb5c452ad22f358601b2a009668f3$1@www.eclipse.org...
> Hi Paul,
>
> On 10002 this is the Agent Controller port and TPTP SDK on Eclipse is
> connected to this port without any problem.
>
> But I'm talking about the proxy recorder, on port 1080, create by TPTP SDK
> on Eclipse
> ( http://help.eclipse.org/help31/topic/org.eclipse.hyades.test .doc.user/concepts/ctestwithhyades.htm),.
>
> Thanks.
> Best Regards.
> --
> Pascal.
>
Re: proxy recorder _not_ listening to port1080 [message #118535 is a reply to message #118504] Wed, 21 November 2007 06:42 Go to previous messageGo to next message
Eclipse User
Originally posted by: pascoualito.google_mail.com

Hi,

I've just tested with tptp.runtime-TPTP-4.5.0M3 and got the same result.
Eclipse lunch the browser but don't want to create the proxy HTTP for
recording all actions. If someone has an idea.

Best Regards.
--
Pascal.
Re: proxy recorder _not_ listening to port1080 [message #118540 is a reply to message #118529] Wed, 21 November 2007 08:56 Go to previous messageGo to next message
Eclipse User
Originally posted by: pascoualito.google_mail.com

Hi Paul,

I was thinking that the proxy was created by Eclipse but in fact it's open
by the Agent Controller (on another computer) when the recording phase
begin.

So I found the 1080 socks port but now a new problem is here. Mozilla find
the proxy but when I try to load a page, nothing append, it's loading the
page indefinitely.

I will try some other version of AC and keep you informed.


Here the log you asked me even if this is a other problem now:
------------------------------------------------------------ --
Recording Started
Connecting to Agent controller on host '172.24.179.166' and port '10002'
Deploying required recorder files.
Sending commandInit
Sending commandStartRecording
Sending commandStartApp Mozilla
------------- Paused until I close Mozilla ------------------------
-- I have configured Mozilla with proxy 172.24.179.166 port 1080 --
-- but when I try to get access to a page, it's loading -----------
-- the page indefinitely ------------------------------------------
Recording completed
Test generation started with generator:TPTP URL Generator
Test to be generated:/PerfsCAS/test_login.testsuite
Test generation completed.

Here Eclipse logs :
-----------------------
!ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.220
!MESSAGE about to load recorder agent:
org.eclipse.hyades.execution.recorder.http.remote.SSLProxyRe corder

!ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.632
!MESSAGE load successful

!ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.632
!MESSAGE about to initialize recorder agent:
org.eclipse.hyades.execution.recorder.http.remote.SSLProxyRe corder

!ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.632
!MESSAGE initialization successful

!ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.983
!MESSAGE about to start SSLProxyServer

!ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.987
!MESSAGE proxy recorder listening to port1080

Thanks.
Best Resgard.
--
Pascal.
Re: proxy recorder _not_ listening to port1080 [message #118545 is a reply to message #118540] Thu, 22 November 2007 06:14 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Pascal,
I will have the lead committer for this component investigate.

Paul
"Pascal" <pascoualito@google_mail.com> wrote in message
news:19e79efdd564c6a5ff9b3b8864df0d17$1@www.eclipse.org...
> Hi Paul,
>
> I was thinking that the proxy was created by Eclipse but in fact it's open
> by the Agent Controller (on another computer) when the recording phase
> begin.
>
> So I found the 1080 socks port but now a new problem is here. Mozilla find
> the proxy but when I try to load a page, nothing append, it's loading the
> page indefinitely.
>
> I will try some other version of AC and keep you informed.
>
>
> Here the log you asked me even if this is a other problem now:
> ------------------------------------------------------------ --
> Recording Started
> Connecting to Agent controller on host '172.24.179.166' and port '10002'
> Deploying required recorder files.
> Sending commandInit
> Sending commandStartRecording
> Sending commandStartApp Mozilla
> ------------- Paused until I close Mozilla ------------------------
> -- I have configured Mozilla with proxy 172.24.179.166 port 1080 --
> -- but when I try to get access to a page, it's loading -----------
> -- the page indefinitely ------------------------------------------
> Recording completed
> Test generation started with generator:TPTP URL Generator
> Test to be generated:/PerfsCAS/test_login.testsuite
> Test generation completed.
>
> Here Eclipse logs :
> -----------------------
> !ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.220
> !MESSAGE about to load recorder agent:
> org.eclipse.hyades.execution.recorder.http.remote.SSLProxyRe corder
>
> !ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.632
> !MESSAGE load successful
>
> !ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.632
> !MESSAGE about to initialize recorder agent:
> org.eclipse.hyades.execution.recorder.http.remote.SSLProxyRe corder
>
> !ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.632
> !MESSAGE initialization successful
>
> !ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.983
> !MESSAGE about to start SSLProxyServer
>
> !ENTRY org.eclipse.hyades.test.core 1 1 2007-11-21 12:43:06.987
> !MESSAGE proxy recorder listening to port1080
>
> Thanks.
> Best Resgard.
> --
> Pascal.
>
Re: proxy recorder _not_ listening to port1080 [message #118556 is a reply to message #118545] Thu, 22 November 2007 12:01 Go to previous messageGo to next message
Eclipse User
Originally posted by: pascoualito.google_mail.com

Hi Paul,

Under Windows 2000:
-------------------
I've try under windows (AC 4.4.0.0 & SDK 4.4.0.3) and all recording phase
goes right. So the problem is just under linux.

Under linux:
------------
I've done my tests with AC and runtime Eclipse on the same computer. I
have the same behavior with these AC versions :
4.4.0.0
4.4.1-200711150100
4.5M3

Browser tested (with proxy localhost 1080):
Firefox 2.0.0.8
Galeon 2.0.2

Eclipse is well connected on port 10002 and browser is well connected to
port 1080 :
#netstat -an | grep 10
tcp 0 0 0.0.0.0:10002 0.0.0.0:* LISTEN

tcp 0 0 0.0.0.0:10006 0.0.0.0:* LISTEN

tcp 0 0 127.0.1.1:10002 127.0.1.1:45455
ESTABLISHED
tcp 0 0 127.0.0.1:34839 127.0.0.1:1080
ESTABLISHED
tcp6 0 0 :::10005 :::* LISTEN

tcp6 0 0 :::1080 :::* LISTEN

tcp6 0 0 ::ffff:127.0.0.1:1080 ::ffff:127.0.0.1:34839
ESTABLISHED
tcp6 0 0 ::ffff:127.0.1.1:58747 ::ffff:127.0.1.1:10005
TIME_WAIT
tcp6 0 0 ::ffff:127.0.1.1:45455 ::ffff:127.0.1.1:10002
ESTABLISHED

I will put a tarball with the AC 4.4.0.0 log (mode DEBUG) on rapidshare or
equivalent tonight, can't put it at work.

Best Regards.
--
Pascal.
Re: proxy recorder _not_ listening to port1080 [message #118558 is a reply to message #118556] Thu, 22 November 2007 14:00 Go to previous messageGo to next message
Eclipse User
Originally posted by: pascoualito.gmail.com

Hi,

Here the link for the AC log file :
http://rapidshare.com/files/71542591/TPTP.4.4.0.0.servicelog .log.200711221630.tgz.html

Thanks.
Best Regards.
--
Pascal.
Re: proxy recorder _not_ listening to port1080 [message #118783 is a reply to message #118558] Thu, 29 November 2007 12:43 Go to previous messageGo to next message
Eclipse User
Originally posted by: pascoualito.google_mail.com

Hi Paul,

>I will have the lead committer for this component investigate.

Do you have some news ?

Best Regards.
--
Pascal.
Re: proxy recorder _not_ listening to port1080 [message #118937 is a reply to message #118535] Mon, 03 December 2007 15:19 Go to previous messageGo to next message
DuWayne Morris is currently offline DuWayne Morris
Messages: 36
Registered: July 2009
Member
Hi,

In your initial message, you indicated the following:

Version of
TPTP SDK : 4.4.0.3 working on Ubuntu 7.10
AC : 4.4.1.0 working on Debien 4.0

Note that the recorder is designed to do the recording on the local host,
although it deploys to either an AC or the IAC on the local machine. So,
I am confused as to how the AC is being used as you listed on another
machine, or at least a different OS.

The browser needs to be configured, either automatically or manually on
the host machine to point to the proxy recorder. So, while recording,
verify that the the browser is be set to use a SOCKS proxy at 127.0.0.1
(local host) on default port 1080.

Please note that these platforms (Ubuntu and Debien) are not supported or
tested, although that is not necessarily the root of the problem you are
having.

From your notes, it looks like you were able to proceed on Windows.

I will look at the details further after you confirm how you are
attempting to record on Linux and verify that the browser is set properly,
to alleviate my confusion. Also, please try to record to some common
public site like eclipse or google. Be aware that there are some issues
recording traffic on the localhost. If that is the case, then set your
browser to the machine IP address http://x.x.x.x/whatever.html rather than
to 127.0.0.1 or localhost.

Regards,
DuWayne
Re: proxy recorder _not_ listening to port1080 [message #118950 is a reply to message #118937] Mon, 03 December 2007 15:39 Go to previous messageGo to next message
DuWayne Morris is currently offline DuWayne Morris
Messages: 36
Registered: July 2009
Member
In my last response, my last sentence was not very clear. The issue I was
referring to would be the case where the user is trying to record traffic
where the server is actually located on the same machine as Eclipse and
the TPTP recorder.

DuWayne
Re: proxy recorder _not_ listening to port1080 [message #118976 is a reply to message #118950] Tue, 04 December 2007 03:17 Go to previous messageGo to next message
Eclipse User
Originally posted by: pascoualito.google_mail.com

Hi,

In my last tests I've put AC & IAC (eclipse) on the same machine. As you
can see in my message from 22/11/2007 the browser is well configured and
connected to SOCKS proxy localhost 1080 but the recorder record nothing.
I've try recording some sites, not only localhost.

Best regards,
Pascal
Re: proxy recorder _not_ listening to port1080 [message #119001 is a reply to message #118783] Tue, 04 December 2007 06:40 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Duwayne has replied to this thread.

"Pascal" <pascoualito@google_mail.com> wrote in message
news:77f5fee27c6d7ca1912fd8bb66b221cf$1@www.eclipse.org...
> Hi Paul,
>
>>I will have the lead committer for this component investigate.
>
> Do you have some news ?
>
> Best Regards.
> --
> Pascal.
>
Previous Topic:Recording Preference Dialog events
Next Topic:storing enabled/disabled state of widgets
Goto Forum:
  


Current Time: Thu Jul 24 18:59:24 EDT 2014

Powered by FUDForum. Page generated in 0.09990 seconds