Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Newly installed Eclipse does not recognize Java(Various errors, depending on my function call)
Newly installed Eclipse does not recognize Java [message #885583] Wed, 13 June 2012 09:32 Go to next message
Erwin Rossen is currently offline Erwin Rossen
Messages: 5
Registered: June 2012
Junior Member
I have downloaded the CDT 8.0.2 for Eclipse Indigo package (from the Eclipse website, I cannot place a link now) and unzipped it.

I have installed the latest JRE: Java Runtime Environment 7u5 (from the Oracle website, I cannot place a link now).

If I run "C:\Program Files (x86)\Eclipse\eclipse.exe", it says No Java Virtual Machine was found after searching ...
If I run "C:\Program Files (x86)\Eclipse\eclipse.exe" -vm "C:\Program Files (x86)\Java\jre7\bin", it says: Failed to load the JNI shared library "C:\Program Files (x86)\Java\jre7\bin\client\jvm.dll". The dll file is in that directory however.
If I run "C:\Program Files (x86)\Eclipse\eclipse.exe" -vm "C:\Program Files (x86)\Java\jre7\bin\javaw.exe", it says: Java was started but returned exit code = 13 and -Dosgi.requiredJavaVersion=1.5. Since I downloaded the latest JRE, what does this error mean?

Can someone hint me what I am doing wrong and how to solve this?
Re: Newly installed Eclipse does not recognize Java [message #885608 is a reply to message #885583] Wed, 13 June 2012 10:12 Go to previous messageGo to next message
Dani Megert is currently offline Dani Megert
Messages: 3801
Registered: July 2009
Senior Member
On 13.06.2012 11:32, Erwin Rossen wrote:
> I have downloaded the CDT 8.0.2 for Eclipse Indigo package (from the
> Eclipse website, I cannot place a link now) and unzipped it.
>
> I have installed the latest JRE: Java Runtime Environment 7u5 (from
> the Oracle website, I cannot place a link now).
>
> If I run "C:\Program Files (x86)\Eclipse\eclipse.exe", it says No Java
> Virtual Machine was found after searching ...
> If I run "C:\Program Files (x86)\Eclipse\eclipse.exe" -vm "C:\Program
> Files (x86)\Java\jre7\bin", it says: Failed to load the JNI shared
> library "C:\Program Files (x86)\Java\jre7\bin\client\jvm.dll". The dll
> file is in that directory however.
> If I run "C:\Program Files (x86)\Eclipse\eclipse.exe" -vm "C:\Program
> Files (x86)\Java\jre7\bin\javaw.exe", it says: Java was started but
> returned exit code = 13 and -Dosgi.requiredJavaVersion=1.5. Since I
> downloaded the latest JRE, what does this error mean?
>
> Can someone hint me what I am doing wrong and how to solve this?
Maybe you are mixing 32-bit with 64-bit?

Dani
Re: Newly installed Eclipse does not recognize Java [message #885642 is a reply to message #885608] Wed, 13 June 2012 11:20 Go to previous message
Erwin Rossen is currently offline Erwin Rossen
Messages: 5
Registered: June 2012
Junior Member
Yes, that's it! Now I have downloaded the 32 bit Eclipse, everything is working. Smile
Previous Topic:Can't find run configuration (eclipse .launch file)
Next Topic:adding User specific plugin in Eclipse
Goto Forum:
  


Current Time: Tue Sep 23 12:39:33 GMT 2014

Powered by FUDForum. Page generated in 0.06130 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software