Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » unable to add tomcat installation
unable to add tomcat installation [message #116576] Wed, 06 July 2005 06:46 Go to next message
Eclipse User
Originally posted by: joerg.eschke.net

I try to add a tomcat v5 to the Installed Server Runtime Environment within
the preferences but recieve "The Tomcat installation directory is not
correct. It does not point to a valid Tomcat installation." from the
wizard.
I am running 0.7m5 using the default tomcat 5 installation
provided by SuSE Linux 9.3

Any hints ?
How does the wizard determine a so called "valid" tomcat installation ?

Greets,
Joerg
Re: unable to add tomcat installation [message #116628 is a reply to message #116576] Wed, 06 July 2005 09:02 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1287
Registered: July 2009
Senior Member
The Tomcat support expects the Tomcat installation to be under a single
install directory, like what is found the tar.gz binary distributions
that can be downloaded from Apache Jakarta. I assume the problem is
that the Tomcat installation appears under multiple directories.

If you identify your directory structure, I may be able to suggest how
to trick the Tomcat support in to accepting that structure. You are
also welcome to file an enhancement request in the Bug database.

Cheers,
Larry


Jörg Eschke wrote:
> I try to add a tomcat v5 to the Installed Server Runtime Environment within
> the preferences but recieve "The Tomcat installation directory is not
> correct. It does not point to a valid Tomcat installation." from the
> wizard.
> I am running 0.7m5 using the default tomcat 5 installation
> provided by SuSE Linux 9.3
>
> Any hints ?
> How does the wizard determine a so called "valid" tomcat installation ?
>
> Greets,
> Joerg
Re: unable to add tomcat installation [message #116641 is a reply to message #116628] Wed, 06 July 2005 09:16 Go to previous messageGo to next message
Jörg Eschke is currently offline Jörg Eschke
Messages: 5
Registered: July 2009
Junior Member
the directory structure look like this:
/usr/share/tomcat5/
bin
common
conf -> /srv/www/tomcat5/base/conf
logs -> /srv/www/tomcat5/base/logs
server
shared
temp -> /srv/www/tomcat5/base/temp
webapps -> /srv/www/tomcat5/base/webapps
work -> /srv/www/tomcat5/base/work

You are right, after installing a Tomcat .tar.gz binary distribution from
the Apache Jakarta Page everything works fine.

Thanks,
Joerg

Larry Isaacs wrote:

> The Tomcat support expects the Tomcat installation to be under a single
> install directory, like what is found the tar.gz binary distributions
> that can be downloaded from Apache Jakarta. I assume the problem is
> that the Tomcat installation appears under multiple directories.
>
> If you identify your directory structure, I may be able to suggest how
> to trick the Tomcat support in to accepting that structure. You are
> also welcome to file an enhancement request in the Bug database.
>
> Cheers,
> Larry
>
>
> Jörg Eschke wrote:
>> I try to add a tomcat v5 to the Installed Server Runtime Environment
>> within the preferences but recieve "The Tomcat installation directory is
>> not correct. It does not point to a valid Tomcat installation." from the
>> wizard.
>> I am running 0.7m5 using the default tomcat 5 installation
>> provided by SuSE Linux 9.3
>>
>> Any hints ?
>> How does the wizard determine a so called "valid" tomcat installation ?
>>
>> Greets,
>> Joerg
Re: unable to add tomcat installation [message #116670 is a reply to message #116628] Wed, 06 July 2005 10:27 Go to previous messageGo to next message
Eclipse User
Originally posted by: zen.rem.this.debian.linux.org.pl

Larry Isaacs napisał(a):
> The Tomcat support expects the Tomcat installation to be under a single
> install directory, like what is found the tar.gz binary distributions
> that can be downloaded from Apache Jakarta. I assume the problem is
> that the Tomcat installation appears under multiple directories.

This is probably the reason. But in most distros (most means Debian is
this case ;) Tomcat installation is divided into multiple locations.

> Cheers,
> Larry
--
Tomasz 'Zen' Napierala
JID: tzn@jabber.org | GSM: 509694518
http://debian.linux.org.pl | http://www.alrauna.org
RLU: 312924 | Debian SID | Firefox 1.0
Re: unable to add tomcat installation [message #116682 is a reply to message #116641] Wed, 06 July 2005 10:41 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1287
Registered: July 2009
Senior Member
I don't have a *nix system to play with at the moment, so I can't say
exactly why the symlinks aren't being accepted. I'll see what I can
find out. I don't know of a reason not to try to make this work.

Cheers,
Larry

Jörg wrote:
> the directory structure look like this:
> /usr/share/tomcat5/
> bin
> common
> conf -> /srv/www/tomcat5/base/conf
> logs -> /srv/www/tomcat5/base/logs
> server
> shared
> temp -> /srv/www/tomcat5/base/temp
> webapps -> /srv/www/tomcat5/base/webapps
> work -> /srv/www/tomcat5/base/work
>
> You are right, after installing a Tomcat .tar.gz binary distribution from
> the Apache Jakarta Page everything works fine.
>
> Thanks,
> Joerg
>
> Larry Isaacs wrote:
>
>
>>The Tomcat support expects the Tomcat installation to be under a single
>>install directory, like what is found the tar.gz binary distributions
>>that can be downloaded from Apache Jakarta. I assume the problem is
>>that the Tomcat installation appears under multiple directories.
>>
>>If you identify your directory structure, I may be able to suggest how
>>to trick the Tomcat support in to accepting that structure. You are
>>also welcome to file an enhancement request in the Bug database.
>>
>>Cheers,
>>Larry
>>
>>
>>Jörg Eschke wrote:
>>
>>>I try to add a tomcat v5 to the Installed Server Runtime Environment
>>>within the preferences but recieve "The Tomcat installation directory is
>>>not correct. It does not point to a valid Tomcat installation." from the
>>>wizard.
>>>I am running 0.7m5 using the default tomcat 5 installation
>>>provided by SuSE Linux 9.3
>>>
>>>Any hints ?
>>>How does the wizard determine a so called "valid" tomcat installation ?
>>>
>>>Greets,
>>>Joerg
>
>
Re: unable to add tomcat installation [message #116768 is a reply to message #116682] Wed, 06 July 2005 11:49 Go to previous messageGo to next message
Jörg Eschke is currently offline Jörg Eschke
Messages: 5
Registered: July 2009
Junior Member
Hmm, the directory structure doesn't seem to be the problems cause.
Using a SuSE Linux 9.1 installation where the tomcat directory structure is
identically the wizard does his job as expected.

Larry Isaacs wrote:

> I don't have a *nix system to play with at the moment, so I can't say
> exactly why the symlinks aren't being accepted. I'll see what I can
> find out. I don't know of a reason not to try to make this work.
>
> Cheers,
> Larry
>
> Jörg wrote:
>> the directory structure look like this:
>> /usr/share/tomcat5/
>> bin
>> common
>> conf -> /srv/www/tomcat5/base/conf
>> logs -> /srv/www/tomcat5/base/logs
>> server
>> shared
>> temp -> /srv/www/tomcat5/base/temp
>> webapps -> /srv/www/tomcat5/base/webapps
>> work -> /srv/www/tomcat5/base/work
>>
>> You are right, after installing a Tomcat .tar.gz binary distribution from
>> the Apache Jakarta Page everything works fine.
>>
>> Thanks,
>> Joerg
>>
>> Larry Isaacs wrote:
>>
>>
>>>The Tomcat support expects the Tomcat installation to be under a single
>>>install directory, like what is found the tar.gz binary distributions
>>>that can be downloaded from Apache Jakarta. I assume the problem is
>>>that the Tomcat installation appears under multiple directories.
>>>
>>>If you identify your directory structure, I may be able to suggest how
>>>to trick the Tomcat support in to accepting that structure. You are
>>>also welcome to file an enhancement request in the Bug database.
>>>
>>>Cheers,
>>>Larry
>>>
>>>
>>>Jörg Eschke wrote:
>>>
>>>>I try to add a tomcat v5 to the Installed Server Runtime Environment
>>>>within the preferences but recieve "The Tomcat installation directory is
>>>>not correct. It does not point to a valid Tomcat installation." from the
>>>>wizard.
>>>>I am running 0.7m5 using the default tomcat 5 installation
>>>>provided by SuSE Linux 9.3
>>>>
>>>>Any hints ?
>>>>How does the wizard determine a so called "valid" tomcat installation ?
>>>>
>>>>Greets,
>>>>Joerg
>>
>>
Re: unable to add tomcat installation [message #120517 is a reply to message #116576] Wed, 13 July 2005 14:53 Go to previous messageGo to next message
Juan Lanus is currently offline Juan Lanus
Messages: 3
Registered: July 2009
Junior Member
Jörg Eschke wrote:

> I try to add a tomcat v5 to the Installed Server Runtime Environment within
> the preferences but recieve "The Tomcat installation directory is not
> correct. It does not point to a valid Tomcat installation." from the
> wizard.

Me too. Only I just installed in W2K according to
http://download.eclipse.org/webtools/downloads/drops/S-1.0M5 -200506302219/
eclipse-SDK-3.1-win32.zip
emf-sdo-xsd-SDK-I200506230200.zip
GEF-SDK-3.1RC4.zip
JEM-SDK-I20050623.zip
wtp-1.0M5.zip.part
wtp-wst-1.0M5.zip

I have Tomcat 5.5.4 (tho the dir name says 5.0), the dir listing is
below. This Tomcat installation worked well with M4.
Please send me a hint, I'm stopped.
TIA
--
Juan Lanus


Directorio de E:\Tomcat 5.0

13/07/2005 15:46 <DIR> .
13/07/2005 15:46 <DIR> ..
09/01/2005 16:51 <DIR> bin
27/11/2004 10:29 <DIR> common
02/07/2005 19:18 <DIR> conf
26/11/2004 14:58 <DIR> copia de conf
10/06/2005 07:54 <DIR> doc
12/06/2005 11:43 <DIR> docs
29/10/2004 15:15 11.357 license
20/06/2005 09:15 <DIR> logs
29/10/2004 15:15 688 notice
29/10/2004 15:13 6.441 release-notes
27/11/2004 10:30 <DIR> server
27/11/2004 10:30 <DIR> shared
09/01/2005 16:47 <DIR> source
27/11/2004 10:30 <DIR> temp
29/10/2004 16:14 21.630 tomcat.ico
27/11/2004 10:30 66.710 uninstall.exe
27/11/2004 10:30 <DIR> webapps
27/11/2004 10:30 <DIR> work
27/11/2004 11:46 0 __esto es tomcat 5.5.4.txt
Re: unable to add tomcat installation [message #120531 is a reply to message #120517] Wed, 13 July 2005 15:32 Go to previous messageGo to next message
Juan Lanus is currently offline Juan Lanus
Messages: 3
Registered: July 2009
Junior Member
When I used E:\tomcat instead of E:\Tomcat 5.0 the error didn't show.
It's bug, because E:\Tomcat 5.0 is valid locatios. The default install
is C:\program ...\Tomcat 5.0 and I'm sure it will also fail.
Entering "E:\Tomcat 5.0" (with quotes) also failed.
--
Juan Lanus
Re: unable to add tomcat installation [message #157622 is a reply to message #116576] Sun, 22 January 2006 21:15 Go to previous messageGo to next message
Max Giesbert is currently offline Max Giesbert
Messages: 38
Registered: July 2009
Member
Has the problem finally been solved? I just expereience the same problem
running wtp1.0 and tomcat5. i can't get the wizard to accept my
directory as valid.

thx

max

Jörg Eschke wrote:
> I try to add a tomcat v5 to the Installed Server Runtime Environment within
> the preferences but recieve "The Tomcat installation directory is not
> correct. It does not point to a valid Tomcat installation." from the
> wizard.
> I am running 0.7m5 using the default tomcat 5 installation
> provided by SuSE Linux 9.3
>
> Any hints ?
> How does the wizard determine a so called "valid" tomcat installation ?
>
> Greets,
> Joerg
Re: unable to add tomcat installation [message #157710 is a reply to message #157622] Mon, 23 January 2006 12:58 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2142
Registered: July 2009
Senior Member
Max Giesbert wrote:
> Has the problem finally been solved? I just expereience the same problem
> running wtp1.0 and tomcat5. i can't get the wizard to accept my
> directory as valid.

Does the layout of your Tomcat 5.0 directory differ from the layout
in the .zip/.tar files provided by Apache?

--
- Nitin


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: unable to add tomcat installation [message #157755 is a reply to message #157710] Mon, 23 January 2006 18:25 Go to previous messageGo to next message
Max Giesbert is currently offline Max Giesbert
Messages: 38
Registered: July 2009
Member
Tomcat 5.0 came along with my Fedora Core 4 installation. Actually all
folders are there in /usr/share/tomcat5 as in the tar.gz. the only
difference is that almost all of the directories are symbolic links.

Max

Nitin Dahyabhai wrote:
> Max Giesbert wrote:
>
>> Has the problem finally been solved? I just expereience the same
>> problem running wtp1.0 and tomcat5. i can't get the wizard to accept
>> my directory as valid.
>
>
> Does the layout of your Tomcat 5.0 directory differ from the layout in
> the .zip/.tar files provided by Apache?
>
Re: unable to add tomcat installation [message #157786 is a reply to message #157755] Mon, 23 January 2006 21:26 Go to previous message
Max Giesbert is currently offline Max Giesbert
Messages: 38
Registered: July 2009
Member
I did a fresh install with tomcat 5.5 and now it works. So the problem
seems be related to the symbolic links.

Is this behaviour wanted?

Max

Max Giesbert wrote:
> Tomcat 5.0 came along with my Fedora Core 4 installation. Actually all
> folders are there in /usr/share/tomcat5 as in the tar.gz. the only
> difference is that almost all of the directories are symbolic links.
>
> Max
>
> Nitin Dahyabhai wrote:
>
>> Max Giesbert wrote:
>>
>>> Has the problem finally been solved? I just expereience the same
>>> problem running wtp1.0 and tomcat5. i can't get the wizard to accept
>>> my directory as valid.
>>
>>
>>
>> Does the layout of your Tomcat 5.0 directory differ from the layout in
>> the .zip/.tar files provided by Apache?
>>
Previous Topic:Applet jar under WebContent
Next Topic:I think i found a bug
Goto Forum:
  


Current Time: Wed Apr 23 17:44:12 EDT 2014

Powered by FUDForum. Page generated in 0.06075 seconds