Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Nebula » toggle not appearing in tree column in CTableTree
toggle not appearing in tree column in CTableTree [message #10625] Mon, 04 September 2006 23:07 Go to next message
Eclipse UserFriend
Originally posted by: alnospammajor.noboxspamspoon.com

i took an existing working example of a View that uses a TreeViewer and
changed it to use a CTableTreeViewer. i got the following code. most of
the code remains unchanged (other than obvious changes of type, the
commented out sections correspond to the TreeViewer code). i had to add
lines to set the cell provider and to set the tree column.

so, the transition was quite painless. the content and label providers
are unchanged.

unfortunately, i'm not seeing the toggles that should appear in the tree
column to permit viewing of children (as happens with the TreeViewer).
the corresponding cell provider is set to "null". i'm wondering if i did
something wrong or if this is a bug.

this is running on windows XP.

regards,

al


/* fViewer = new TreeViewer(parent,
SWT.H_SCROLL | SWT.V_SCROLL | SWT.MULTI |
SWT.FULL_SELECTION);
final Tree t = fViewer.getTree();
*/
fViewer = new CTableTreeViewer(parent);
fViewer.setCellProvider(new Class[]{null,
MultiLineTextCell.class});
final CTableTree t = fViewer.getCTableTree();

t.setTreeColumn(0);

// fAreaCol = new TreeColumn(t, SWT.LEFT);
fAreaCol = new CContainerColumn(t, SWT.LEFT);
fAreaCol.setText("Area");
fAreaCol.setWidth(200);

// fSalesCol = new TreeColumn(t, SWT.LEFT);
fSalesCol = new CContainerColumn(t, SWT.LEFT);
fSalesCol.setText("Sales");
fSalesCol.setWidth(200);

t.setHeaderVisible(true);
t.setLinesVisible(true);

fViewer.setLabelProvider( new GroupsLabelProvider() );
fViewer.setContentProvider( new GroupsContentProvider() );
Re: toggle not appearing in tree column in CTableTree [message #10657 is a reply to message #10625] Tue, 05 September 2006 20:35 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: alnospammajor.noboxspamspoon.com

so i found part of the problem. the content provider i'm using
implements ITreePathContentProvider rather than ITreeContentProvider.
the former interface appears to be unsupported at the moment by CTableTree.

unfortunately, the semantics of the model do require
ITreePathContentProvider. any chance of getting this into CTableTree
relatively soon?

regards,

al
Re: toggle not appearing in tree column in CTableTree [message #10687 is a reply to message #10657] Tue, 05 September 2006 20:37 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: alnospammajor.noboxspamspoon.com

Al Major wrote:
> the former interface appears to be unsupported at the moment by CTableTree.
>
correction. i believe that should read "unsupported at the moment by
CTableTreeViewer".
Re: toggle not appearing in tree column in CTableTree [message #10720 is a reply to message #10657] Tue, 05 September 2006 22:07 Go to previous messageGo to next message
Jeremy Dowdall is currently offline Jeremy DowdallFriend
Messages: 181
Registered: July 2009
Senior Member
Please file a bug report / feature request in bugzilla for this.

I will be on the road most of the week, so if "relatively soon" means a
couple of weeks then most likely you've got a "yes" :)
Also, the more info you can provide regarding your setup the better - if
this is open code please include a link in the report, or just attach
what you can (most important is the content provider).

thanks!

Al Major wrote:
> so i found part of the problem. the content provider i'm using
> implements ITreePathContentProvider rather than ITreeContentProvider.
> the former interface appears to be unsupported at the moment by CTableTree.
>
> unfortunately, the semantics of the model do require
> ITreePathContentProvider. any chance of getting this into CTableTree
> relatively soon?
>
> regards,
>
> al
Re: toggle not appearing in tree column in CTableTree [message #10752 is a reply to message #10720] Wed, 06 September 2006 06:23 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: alnospammajor.noboxspamspoon.com

done. i've filed a request for an enhancement (156312), which is what
this effectively boils down to. two weeks would be fine, thanks a bunch!!

if it somehow becomes more time-critical, or i find myself with loads of
time on my hands, i will get off my plush posterior and attempt the
changes myself :-).

unfortunately, i couldn't attach the content provider as is. while the
provider itself is not very much code, the model underlying it is rather
large and currently closed code. :-(.

al

Jeremy Dowdall wrote:
> Please file a bug report / feature request in bugzilla for this.
>
> I will be on the road most of the week, so if "relatively soon" means a
> couple of weeks then most likely you've got a "yes" :)
> Also, the more info you can provide regarding your setup the better - if
> this is open code please include a link in the report, or just attach
> what you can (most important is the content provider).
>
> thanks!
>
> Al Major wrote:
>> so i found part of the problem. the content provider i'm using
>> implements ITreePathContentProvider rather than ITreeContentProvider.
>> the former interface appears to be unsupported at the moment by CTableTree.
>>
>> unfortunately, the semantics of the model do require
>> ITreePathContentProvider. any chance of getting this into CTableTree
>> relatively soon?
>>
>> regards,
>>
>> al
Re: toggle not appearing in tree column in CTableTree [message #10783 is a reply to message #10752] Wed, 06 September 2006 10:40 Go to previous message
Jeremy Dowdall is currently offline Jeremy DowdallFriend
Messages: 181
Registered: July 2009
Senior Member
thanks Al!

Al Major wrote:
> done. i've filed a request for an enhancement (156312), which is what
> this effectively boils down to. two weeks would be fine, thanks a bunch!!
>
> if it somehow becomes more time-critical, or i find myself with loads of
> time on my hands, i will get off my plush posterior and attempt the
> changes myself :-).
>
> unfortunately, i couldn't attach the content provider as is. while the
> provider itself is not very much code, the model underlying it is rather
> large and currently closed code. :-(.
>
> al
>
> Jeremy Dowdall wrote:
>> Please file a bug report / feature request in bugzilla for this.
>>
>> I will be on the road most of the week, so if "relatively soon" means a
>> couple of weeks then most likely you've got a "yes" :)
>> Also, the more info you can provide regarding your setup the better - if
>> this is open code please include a link in the report, or just attach
>> what you can (most important is the content provider).
>>
>> thanks!
>>
>> Al Major wrote:
>>> so i found part of the problem. the content provider i'm using
>>> implements ITreePathContentProvider rather than ITreeContentProvider.
>>> the former interface appears to be unsupported at the moment by
>>> CTableTree.
>>>
>>> unfortunately, the semantics of the model do require
>>> ITreePathContentProvider. any chance of getting this into CTableTree
>>> relatively soon?
>>>
>>> regards,
>>>
>>> al
Re: toggle not appearing in tree column in CTableTree [message #564800 is a reply to message #10625] Tue, 05 September 2006 20:35 Go to previous message
Al Major is currently offline Al MajorFriend
Messages: 72
Registered: July 2009
Member
so i found part of the problem. the content provider i'm using
implements ITreePathContentProvider rather than ITreeContentProvider.
the former interface appears to be unsupported at the moment by CTableTree.

unfortunately, the semantics of the model do require
ITreePathContentProvider. any chance of getting this into CTableTree
relatively soon?

regards,

al
Re: toggle not appearing in tree column in CTableTree [message #564847 is a reply to message #10657] Tue, 05 September 2006 20:37 Go to previous message
Al Major is currently offline Al MajorFriend
Messages: 72
Registered: July 2009
Member
Al Major wrote:
> the former interface appears to be unsupported at the moment by CTableTree.
>
correction. i believe that should read "unsupported at the moment by
CTableTreeViewer".
Re: toggle not appearing in tree column in CTableTree [message #564868 is a reply to message #10657] Tue, 05 September 2006 22:07 Go to previous message
Jeremy Dowdall is currently offline Jeremy DowdallFriend
Messages: 181
Registered: July 2009
Senior Member
Please file a bug report / feature request in bugzilla for this.

I will be on the road most of the week, so if "relatively soon" means a
couple of weeks then most likely you've got a "yes" :)
Also, the more info you can provide regarding your setup the better - if
this is open code please include a link in the report, or just attach
what you can (most important is the content provider).

thanks!

Al Major wrote:
> so i found part of the problem. the content provider i'm using
> implements ITreePathContentProvider rather than ITreeContentProvider.
> the former interface appears to be unsupported at the moment by CTableTree.
>
> unfortunately, the semantics of the model do require
> ITreePathContentProvider. any chance of getting this into CTableTree
> relatively soon?
>
> regards,
>
> al
Re: toggle not appearing in tree column in CTableTree [message #564888 is a reply to message #10720] Wed, 06 September 2006 06:23 Go to previous message
Al Major is currently offline Al MajorFriend
Messages: 72
Registered: July 2009
Member
done. i've filed a request for an enhancement (156312), which is what
this effectively boils down to. two weeks would be fine, thanks a bunch!!

if it somehow becomes more time-critical, or i find myself with loads of
time on my hands, i will get off my plush posterior and attempt the
changes myself :-).

unfortunately, i couldn't attach the content provider as is. while the
provider itself is not very much code, the model underlying it is rather
large and currently closed code. :-(.

al

Jeremy Dowdall wrote:
> Please file a bug report / feature request in bugzilla for this.
>
> I will be on the road most of the week, so if "relatively soon" means a
> couple of weeks then most likely you've got a "yes" :)
> Also, the more info you can provide regarding your setup the better - if
> this is open code please include a link in the report, or just attach
> what you can (most important is the content provider).
>
> thanks!
>
> Al Major wrote:
>> so i found part of the problem. the content provider i'm using
>> implements ITreePathContentProvider rather than ITreeContentProvider.
>> the former interface appears to be unsupported at the moment by CTableTree.
>>
>> unfortunately, the semantics of the model do require
>> ITreePathContentProvider. any chance of getting this into CTableTree
>> relatively soon?
>>
>> regards,
>>
>> al
Re: toggle not appearing in tree column in CTableTree [message #564909 is a reply to message #10752] Wed, 06 September 2006 10:40 Go to previous message
Jeremy Dowdall is currently offline Jeremy DowdallFriend
Messages: 181
Registered: July 2009
Senior Member
thanks Al!

Al Major wrote:
> done. i've filed a request for an enhancement (156312), which is what
> this effectively boils down to. two weeks would be fine, thanks a bunch!!
>
> if it somehow becomes more time-critical, or i find myself with loads of
> time on my hands, i will get off my plush posterior and attempt the
> changes myself :-).
>
> unfortunately, i couldn't attach the content provider as is. while the
> provider itself is not very much code, the model underlying it is rather
> large and currently closed code. :-(.
>
> al
>
> Jeremy Dowdall wrote:
>> Please file a bug report / feature request in bugzilla for this.
>>
>> I will be on the road most of the week, so if "relatively soon" means a
>> couple of weeks then most likely you've got a "yes" :)
>> Also, the more info you can provide regarding your setup the better - if
>> this is open code please include a link in the report, or just attach
>> what you can (most important is the content provider).
>>
>> thanks!
>>
>> Al Major wrote:
>>> so i found part of the problem. the content provider i'm using
>>> implements ITreePathContentProvider rather than ITreeContentProvider.
>>> the former interface appears to be unsupported at the moment by
>>> CTableTree.
>>>
>>> unfortunately, the semantics of the model do require
>>> ITreePathContentProvider. any chance of getting this into CTableTree
>>> relatively soon?
>>>
>>> regards,
>>>
>>> al
Previous Topic:toggle not appearing in tree column in CTableTree
Next Topic:variable CTableTreeCell
Goto Forum:
  


Current Time: Fri Nov 21 02:47:37 GMT 2014

Powered by FUDForum. Page generated in 0.01948 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software